• Recently Browsing

    No registered users viewing this page.

  • Posts

    • As long as vanilla use them, they exists 😉 Minecraft#displayGuiScreen opens a Screen on client
    • I'm new here, so forgive me if I'm making a stupid mistake. I've been trying for the last two days or so to set up a modding environment with JEI API and the JEI mod itself in it. Here are the relevant pieces of my build.gradle: dependencies { minecraft 'net.minecraftforge:forge:1.16.5-36.0.1' compileOnly fg.deobf("mezz.jei:jei-") { transitive = false } runtimeOnly fg.deobf("mezz.jei:jei-") { transitive = false } } repositories { maven { // location of the maven that hosts JEI files name = "Progwml6 maven" url = "https://dvs1.progwml6.com/files/maven/" } maven { // location of a maven mirror for JEI files, as a fallback name = "ModMaven" url = "https://modmaven.k-4u.nl" } } I'm honestly not sure what the "transitive = false" bit does, but it made the API download properly. The problem is, the mod itself (not the API) isn't being downloaded when I build my project. Or at least that's what I think is happening. I might be wrong. Anyways, here's the error. It doesn't prevent the client or server from running, it just shows up as a problem and JEI isn't listed as a mod in the client's home screen's "mods" menu. This error used to appear twice, once for each missing library, but one of them is fine now that I added that "transitive = false" bit of text and built my project again. Given that I don't see JEI when I run the client, I'm guessing it's the API that downloaded properly and the mod that's missing. When I say "built my project" I mean that I ran "gradlew eclipse" and "gradlew genEclipseRuns" from cmd with the working directory set in my mod's workspace.   Is there anything I'm doing wrong? If I left out any important information please let me know. Thanks!
    • Went to read the manual and found nothing when it came to GUI's. (To be specific I am making an item that will show a GUI when right clicked.). I know this is a dumb question, but are GUI's supported on the newest version of the MDK? If so, where can I find a way to add them? If GUI support isn't allowed, can I just use J Frames instead?  https://mcforge.readthedocs.io/en/1.15.x/blocks/interaction/#usage-examples I am assuming this is the only documentation Forge released for GUI's.
    • Here is the debug log from client: https://gist.github.com/LukeeMaster/0d617831bf42d08df53605d992ee6d7a
    • Thanks so much for your help! I removed the log4j dependency, I honesty don't remember when I put that there. Once I fixed the jar.finalizedBy line, everything worked! (One small issue where I was relocating all of "com.google" when I just should've relocated "com.google.common," too)   Thanks again!
  • Topics

  • Who's Online (See full list)