Jump to content

[UNSOLVED]Gui Texture : java.io.FileNotFoundException


mar21

Recommended Posts

Hello, I created a machine > Works fine, the side textures (sides, top, front)are working fine, but the Gui cant be loaded.

It says this:

 

2013-06-24 19:55:48 [iNFO] [sTDERR] java.io.FileNotFoundException: mods/mar21/textures/gui/powerMelter.png

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.texturepacks.TexturePackDefault.func_98139_b(TexturePackDefault.java:42)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.texturepacks.TexturePackImplementation.func_98137_a(TexturePackImplementation.java:149)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.texturepacks.TexturePackImplementation.getResourceAsStream(TexturePackImplementation.java:169)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.renderer.RenderEngine.getTexture(RenderEngine.java:208)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.renderer.RenderEngine.bindTexture(RenderEngine.java:148)

2013-06-24 19:55:48 [iNFO] [sTDERR] at mar21.omega.machine.tileEntity.GuiPoweredMelter.drawGuiContainerBackgroundLayer(GuiPoweredMelter.java:40)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.gui.inventory.GuiContainer.drawScreen(GuiContainer.java:107)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.renderer.EntityRenderer.updateCameraAndRender(EntityRenderer.java:1022)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:872)

2013-06-24 19:55:48 [iNFO] [sTDERR] at net.minecraft.client.Minecraft.run(Minecraft.java:761)

2013-06-24 19:55:48 [iNFO] [sTDERR] at java.lang.Thread.run(Unknown Source)

 

And my code for Gui is:

 

    protected void drawGuiContainerBackgroundLayer(float par1, int par2, int par3)

    {

        GL11.glColor4f(1.0F, 1.0F, 1.0F, 1.0F);

        this.mc.renderEngine.bindTexture("mods/mar21/textures/gui/powerMelter.png");

        int k = (this.width - this.xSize) / 2;

        int l = (this.height - this.ySize) / 2;

        this.drawTexturedModalRect(k, l, 0, 0, this.xSize, this.ySize);

        int i1;

 

        if (this.furnaceInventory.isBurning())

        {

            i1 = this.furnaceInventory.getBurnTimeRemainingScaled(12);

            this.drawTexturedModalRect(k + 56, l + 36 + 12 - i1, 176, 12 - i1, 14, i1 + 2);

        }

 

        i1 = this.furnaceInventory.getCookProgressScaled(24);

        this.drawTexturedModalRect(k + 79, l + 34, 176, 14, i1 + 1, 16);

    }

 

I have the texture for Gui placed as I writed to the .bindTexture().

I was followed some topics there, but any worked.

If I have the gui texture as it have a normal furnace it works.

Thanks for any response !

Check out my m2cAPI: http://pastebin.com/SJmjgdgK [WIP! If something doesnt work or you have a better resolution, write me a PM]

If you want to use my API please give me a Karma/Thank you

Sorry for some bad words ´cause I am not a walkin´ library!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Another Minecraft Launcher https://multimc.org/#Download or https://atlauncher.com/downloads
    • Remove these mods and combine OptiFine HD U I6 with Forge 47.2.18 Start with Optifine - without any other mods - if this works, add the mods one by one or in groups until you find the mod, conflicting with Optifine
    • Ok yeah I think this might be where the problem starts. For starters, I think you can get rid of your RecipeType impl and make it a static constant instead. I'm not 100% sure this will fix it but it's posssible. RuneInscribingRecipe public class RuneInscribingRecipe implements Recipe<SimpleContainer> { public static final RecipeType<RuneInscribingRecipe> RECIPE_TYPE = new RecipeType<>(){}; // .... @Override public RecipeType<?> getType() { return RECIPE_TYPE; } // .... } RuneInscriberMenu private Optional<RecipeHolder<RuneInscribingRecipe>> getCurrentRecipe() { SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); List<RecipeHolder<RuneInscribingRecipe>> list = this.blockEntity.getLevel().getRecipeManager().getRecipesFor(RuneInscribingRecipe.RECIPE_TYPE, inventory, this.blockEntity.getLevel()); if (list.isEmpty()) { return Optional.empty(); } return Optional.of(list.get(0)); }   Also, this here is a little suspicious where you're getting the `this.inventory.getStackInSlot` calls. I'd try and make sure those are what you expect they are with either a Debug line in IDE or print statement SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); System.out.printf("CHECKING BASE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); System.out.printf("CHECKING TEMPLATE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); ^ See what the result of those print statements are, make sure they're right
    • Upon testing again after adding them, the game still doesn't crash however the resource packs are still unfortunately broken.
    • Hi! Can someone please point me to the correct FAQ or place? I'm not able do DuckDuckGo myself out of this one. As you can hopefully see, chunks are not rendered. I run a forge server, fresh install on a linux VM. Curseforge on the Win11 client with Embeddium, Oculus and Unbound shader. No mods. Forge 47.2.23 on server & client.  No errors, no crashes, no apparent CPU or RAM issues with the VM. This screenshot was captured while creative, but the same happens when flying in survival. Waiting (floating) for a few minutes sooner or (often) later, lets the missing chunks appear. Usually takes 5-10 minutes.  When on a local game, the chunks appear slowly, but they do appear without pause.   This must be something simple, obvious, but I can't find the correct "search words" to find my way out. "Chunks not loading / rendering" didn't help. Browsing several forums neither. 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.