Jump to content

Custom worldgen Features 1.16.3


Recommended Posts

I've gotten custom biomes down and have them generating with vanilla features, but defining new features is giving me hell and I can't find good resources on them (Thank you forge docs for not even mentioning world gen).

I created the deferred registry and have the `.register(id, () -> new AbstractFeatureBase(NoFeatureConfig.field_236558_a_)));` pattern and finally I have

`genBuilder.func_242513_a(GenerationStage.Decoration.VEGETAL_DECORATION, feature);` where `genBuilder` is of type `BiomeGenerationSettingsBuilder` and `feature` is of type `ConfiguredFeature<?,?>`


I guess all I need to do is turn the `Feature<?>` that is created with `register()`  into a `ConfiguredFeature<?,?>`. I think I have to use `.withConfiguration(IFeatureConfig.NO_FEATURE_CONFIG)` but it's not working.

Here's my repo. I just realized that my features are in net.minecraft instead of jam.jamfactory so I'll fix that in a bit.

If you need more explanation of what I'm asking for I'll try to give it, but I don't quite understand this yet 😛
Any help is appreciated!

Link to comment
Share on other sites

12 minutes ago, Beethoven92 said:

Define "not working"

Good question. 
I don't really understand features at all so all I can offer you is that in the line 

addBiome("caelum_forest", Category.SWAMP, .15f, .8f, BiomeTemplate.DEFAULT_OVERWORLD_SKY_COLOR, BiomeTemplate.DEFAULT_OVERWORLD_FOG_COLOR, BiomeTemplate.DEFAULT_OVERWORLD_WATER_COLOR,	BiomeTemplate.DEFAULT_OVERWORLD_WATER_FOG_COLOR, color(0,50, 70), color(0, 100, 150), GrassColorModifier.NONE, ParticleTypes.ENCHANT, .01f, 0f, .8f, new ConfiguredFeature<?, ?>[] {Features.field_243934_cq, features.get("test").get().withConfiguration(IFeatureConfig.NO_FEATURE_CONFIG) }, new StructureFeature<?,?>[] {StructureFeatures.field_244151_q});

".withConfiguration(IFeatureConfig.NO_FEATURE_CONFIG)" is underlined and it says "The method withConfiguration(capture#3-of ?) in the type Feature<capture#3-of ?> is not applicable for the arguments (NoFeatureConfig)."

If I cast features.get("test").get() as a Feature<NoFeatureConfig> the red line goes away but the game crashes on load with only the message "Mod Loading has failed" and points to the line that I pasted above

I don't even need help with this specifically, I just need a working example of features using deferred registries

Edited by JamFactory
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I have a structure, and sometimes several mobs spawn there. This is a boss and must spawn alone. Here is the code for spawning entities in the structure { "type": "minecraft:jigsaw", "start_pool": "egyptcraft:boss_pyramid/start_pool", "size": 5, "max_distance_from_center": 80, "biomes": "#egyptcraft:has_structure/boss_pyramid", "step": "surface_structures", "start_height": { "absolute": 0 }, "project_start_to_heightmap": "WORLD_SURFACE_WG", "use_expansion_hack": false, "spawn_overrides": { "monster": { "bounding_box": "full", "spawns": [ { "type": "egyptcraft:anubis", "maxCount": 1, "minCount": 1, "weight": 100 } ] } } } Maybe it's something else?
    • I have OreGenEvent.GenerateMinable event, I need to get a chance to spawn (generate) every ore that is processed in this event. Also e.getType().name().toString() is name this is the same block name by which it can be entered in the Block.getByID?  forge 1.12.2 59(recommended)
    • Hello everybody! Out of nowhere my minecraft doesn't allow me to play on forge 1.19.2 I tried to reinstall minecraft, doesn't have any mod right now on the forge version. Tried the newest version of forge, tried recommended version as well. I have the newest version of Java as well...   I dont know why it stopped working but it just stopped completly out of nowhere...   Thank you so much for your help guys ❤️
    • Hello, my world is crashing at 0% loaded and I don't know why. (Forge 43.2.14, 1.19.2) I have two worlds that I play on, and one works and the other doesn't, even with the same mod list. Here's the crash report: https://pastebin.com/AUbRwkGj
    • Minecraft 1.12.2 Very frustrating error. only ever occurs on one device. Started yesterday without prompting (maybe java updated or something?) Says things that have been imported actually arent when running client Reinstalled Intellij, cleared cache, cleaned and rebuilt gradle, redownloaded the entire file from git. Nothing works. (I believe I have the right plugins installed, dependencies OK, and am using corretto 1.8).   One thing I did for more of the below errors was just to explicitly import them, which was working up until this little guy who literally does not exist in forge to import. the class inhereting something inhereting it refers to import net.minecraftforge.registries.IForgeRegistryEntry.Impl, not net.minecraftforge.registries.IForgeRegistryEntry$Impl as the output implies. also I didn't even have to manually import these things for it to work on my other device. (which is just importing the minecraft package that contains them), but here I did have to just to get rid of a few errors--not even make anything work?? I dont know. (edited) here's the aforementioned "below error" (one of many like it): error: cannot access net.minecraftforge.registries.IForgeRegistryEntry.Impl public class BlockBase extends Block {        ^   class file for net.minecraftforge.registries.IForgeRegistryEntry$Impl not found Here's the class BlockBase:   package com.quantum.exodus.common.blocks; import com.quantum.exodus.ExodusMod; import net.minecraft.block.Block; import net.minecraft.block.material.Material; import net.minecraft.creativetab.CreativeTabs; import net.minecraft.item.Item; import net.minecraft.item.ItemBlock; import net.minecraftforge.registries.IForgeRegistryEntry.Impl; public class BlockBase extends Block { protected String name; public BlockBase(Material material, String name) { super(material); this.name = name; setTranslationKey(name); setRegistryName(name); } public void registerItemModel(Item itemBlock) { ExodusMod.proxy.registerItemRenderer(itemBlock, 0, name); } public Item createItemBlock() { return new ItemBlock(this).setRegistryName(getRegistryName()); } @Override public BlockBase setCreativeTab(CreativeTabs tab) { super.setCreativeTab(tab); return this; } }
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.