Jump to content

Question about MatrixStacks - 1.16.3 [SOLVED]


Turtledove

Recommended Posts

I am currently creating dozens (potentially 100+) different animations for the player's hand in first person view, and to make it easier on myself I have a system that lets me parse .json files for expressions, in a form like this:

 

{
	"transform":[
		{"translation":["__i * 0.56 - __swing_ratio * 1.75 + 0.9","-0.38", "-0.52"]},
		{"rotation":["0.0","90.0","0.0"]},
		{"rotation":["0.0","0.0","-90.0"]},
		{"rotation":["-25.0 + 25.0 * Math.cos(__swing_ratio * __swing_ratio * Math.PI)","0.0","0.0"]}
	]
}

 

these get read into a list of an HandTransformation class where type is the type of transformation.

 

public class HandTransformation
{
    public String type;
    public String[] transformation = new String[3];
}

 

At runtime, this method is called which evaluates the expression in the .json via a JS ScriptEngine, and does the appropriate transformations to the MatrixStacks object from the RenderHand event:

	matrixStack.clear();
        matrixStack.push();
        for (ItemTransformation itemTransformation:action.getTransformations())
        {
            String type = itemTransformation.type;
            Vector3f transform = getVector(itemTransformation, side, swingRatio, equippedRatio);

            if (type.equals("translation"))
            {
                matrixStack.translate(transform.getX(), transform.getY(), transform.getZ());
            }
            else if (type.equals("rotation"))
            {
                matrixStack.rotate(Vector3f.XP.rotationDegrees(transform.getX()));
                matrixStack.rotate(Vector3f.YP.rotationDegrees(transform.getY()));
                matrixStack.rotate(Vector3f.ZP.rotationDegrees(transform.getZ()));
            }
        }
        Minecraft.getInstance().getFirstPersonRenderer().renderItemSide(Minecraft.getInstance().player, itemStack, rightHanded ? ItemCameraTransforms.TransformType.FIRST_PERSON_RIGHT_HAND : ItemCameraTransforms.TransformType.FIRST_PERSON_LEFT_HAND, !rightHanded, matrixStack, buffer,light);
        matrixStack.pop();
    private Vector3f getVector(ItemTransformation itemTransformation, float side, float swingRatio, float equippedRatio)
    {
        String[] transformation = itemTransformation.transformation;
        String sideString = Float.toString(side);
        String swingRatioString = Float.toString(swingRatio);
        String equppedRatioString = Float.toString(equippedRatio);

        Vector3f transforms = new Vector3f();
        for (int i = 0; i < 3; i++)
        {
            String expression = transformation[i];
            expression.replaceAll("__i", sideString);
            expression.replaceAll("__swing_ratio", swingRatioString);
            expression.replaceAll("__equip_ratio", equppedRatioString);

            float result = evaluateScript(expression);

            switch(i)
            {
                case 0:
                    transforms.setX(result);
                    break;
                case 1:
                    transforms.setY(result);
                    break;
                default:
                    transforms.setZ(result);
            }
        }
        return transforms;
    }
    public float evaluateScript(String expression)
    {
        float result = 0.0f;
        ScriptEngineManager factory = new ScriptEngineManager();
        ScriptEngine engine = factory.getEngineByName("JavaScript");
        try
        {
            Object obj = engine.eval(expression);
            result = Float.parseFloat(obj.toString());
        }
        catch(ScriptException e)
        {
            e.printStackTrace();
        }
        return result;
    }

This all works, but as expected it cripples the framerate whenever it runs due to ScriptEngine. So, the next best thing is to apply the transformations to my own MatrixStacks object at initialization, for when I need them during gameplay.

 

Can I simply create my own MatrixStacks object at initialization (outside of the render event call) and not use the one provided by the event call? Or does it work more like the old GLStateManager and just wouldn't work?

 

Or better yet, is there an equally robust alternative to the JS script engine for evaluating mathematical expressions at runtime?

Edited by Turtledove
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hi everyone  I'm trying to make a custom door and give it a custom sound. In order to do so I've registered the sounds like this   private static final DeferredRegister<SoundEvent> SOUNDS = DeferredRegister.create(ForgeRegistries.SOUND_EVENTS, MineWorld.MOD_ID); ... public static final RegistryObject<SoundEvent> SCULK_DOOR_CLOSE = SOUNDS.register("sculk_door_close", () -> SoundEvent.createVariableRangeEvent(new ResourceLocation(MineWorld.MOD_ID, "sculk_door_close"))); public static final RegistryObject<SoundEvent> SCULK_DOOR_OPEN = SOUNDS.register("sculk_door_open", () -> SoundEvent.createVariableRangeEvent(new ResourceLocation(MineWorld.MOD_ID, "sculk_door_open"))); call the register method of the Sounds registry as the first thing in my mod initialize method IEventBus eventBus = FMLJavaModLoadingContext.get().getModEventBus(); SOUNDS.register(eventBus); Then I create a BlockSetType like this   public static final BlockSetType SCULK = BlockSetType.register(new BlockSetType(new ResourceLocation(MineWorld.MOD_ID, "sculk").toString(), true, SoundType.WOOD, SCULK_DOOR_CLOSE.get(), SCULK_DOOR_OPEN.get(), SoundEvents.WOODEN_TRAPDOOR_CLOSE, SoundEvents.WOODEN_TRAPDOOR_OPEN, SoundEvents.WOODEN_PRESSURE_PLATE_CLICK_OFF, SoundEvents.WOODEN_PRESSURE_PLATE_CLICK_ON, SoundEvents.WOODEN_BUTTON_CLICK_OFF, SoundEvents.WOODEN_BUTTON_CLICK_ON); And finally the door block like this private static final DeferredRegister<Block> BLOCKS = DeferredRegister.create(ForgeRegistries.BLOCKS, MineWorld.MOD_ID); ... BLOCKS.register("sculk_door", () -> new DoorBlock(BlockBehaviour.Properties.copy(Blocks.OAK_DOOR), blockSetType)); But when I launch the game I get this error   Registry Object not present: mineworld:sculk_door_close Am I doing something wrong? Maybe the BlockSetType registration needs to be done in a different way? I have other BlockSetTypes registered like this that only uses vanilla sounds and they work just fine. You can see an example in my GitHub repo here: https://github.com/JimiIT92/MineWorld/blob/master/src/main/java/org/mineworld/core/MWBlockSetTypes.java
    • it was eldritch end, thank you
    • Okay. Thank you. I think it works now. I added the jdk-17 path to the batch instead of the jvm arguments txt file. The windows command prompt is just blank, but when I close the native windows command prompt, the java command prompt opens & loads the server. If that won't cause issues then I'm all good. 
    • I have no idea - the last mentioned mods are eldritch_end, supplementaries and mahoutsukai Start with removing mahoutsukai
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.