Jump to content

[SOLVED!] exception while I run Minecraft + Forge through my launcher


lekrosa

Recommended Posts

I have been coding a launcher and am now completely stuck. A few seconds after the minecraft window opens, I get an exception:

2013-06-27 20:14:42 [iNFO] [sTDERR] java.lang.IllegalArgumentException: URI is not hierarchical
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at java.io.File.<init>(File.java:363)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at cpw.mods.fml.common.ModClassLoader.getParentSources(ModClassLoader.java:66)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at cpw.mods.fml.common.discovery.ModDiscoverer.findClasspathMods(ModDiscoverer.java:45)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at cpw.mods.fml.common.Loader.identifyMods(Loader.java:341)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at cpw.mods.fml.common.Loader.loadMods(Loader.java:479)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:160)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:410)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at net.minecraft.client.Minecraft.run(Minecraft.java:732)
2013-06-27 20:14:42 [iNFO] [sTDERR] 	at java.lang.Thread.run(Thread.java:662)

This doesn't point to any of my code. (which is here: http://www.github.com/lekro/ModdishLauncher) I have tested with the same files (binaries & natives) in MultiMC, without getting this problem. So I'm almost certain that I am missing something in my code. I can't pinpoint exactly what it is, though. I've looked in the java part of MultiMC's code and through the parts of FML that the stack trace points to, but I couldn't find anything but a hint at it might be something wrong with my classpath... or FML's... (? I heard Eclipse automatically did that for me)

Here is a pastebin of the significant part of the console output:

http://pastebin.com/vdCpvgeW

It is older than the exception above, but it's the same. I have FML's console output set manually to ALL.

I can't figure out why it works perfectly in MultiMC but throws this in my launcher. I have done everything that MultiMC has with its Java portion. (launcher part)

 

Perhaps someone that knows FML and Java better than me can help me out? xP

 

EDIT: I have also tried using my jars/natives from an instance of Minecraft with Forge in it from MultiMC, I get the same problem when using my launcher, but no problems with MultiMC and those files.

 

EDIT 2: I think it's a good idea to give some information about my system: I'm using JDK 1.6.0_38 and its corresponding JRE, 64-bit, on Windows 7. I am using Minecraft 1.5.2, downloaded directly from Mojang (like all other launchers do it) I am also using Forge 7.8.1.737 (the recommended build), FML 5.2.23.737, and LWJGL 2.9.0.

 

 

EDIT 3: I have solved this problem! I was putting a scheme before the jars where I shouldn't have.

Link to comment
Share on other sites

No... there's nowhere I've done that. There is one place where I have changed the path field to the minecraft folder directly inside the Minecraft class (like MultiMC does), but what I give that class is a File. I've tried removing that part, too, but nothing happened.

I do this at one point:

System.setProperty("minecraft.applet.TargetDirectory", myDir + "/minecrafts/" + minecraftType);

but I'm not quite sure that that's the problem, because myDir starts with a / which makes it hierarchical.

 

I found that there is some problem with FML's mainClassLoader or something, it gives opaque URIs that can't be converted into Files. But I don't know enough about Forge/FML to say anything there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.