Jump to content

Issues with serverside mod (SOLVED)


Sciman101

Recommended Posts

I'm trying to make a simple mod that works server or clientside - if you have it on your client it works fine, but if you join a modded server without it it also works.

The mod doesn't have any assets or clientside features, to my knowledge. I also made sure to add the line

ModLoadingContext.get().registerExtensionPoint(ExtensionPoint.DISPLAYTEST,() -> Pair.of(()-> FMLNetworkConstants.IGNORESERVERONLY,(a,b)->true));

from the docs, to ensure it worked. However, even when the player joins with the mod, the server reports 'failed to synchronize registry data minecraft'. It might have something to do with the config files? But even then the config is set up as the SERVER type, so I would assume it doesn't need to match.

All the mod does is register a block break event handler, a server config file, and a single command.

Does anyone know what the issue could be?

 

I'm stupid, I accidentally deleted a mod on my client while developing the mod. Sorry about that

Edited by Sciman101
Fixed issue
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.