Jump to content

Help with my crafting table?


Flenix
 Share

Recommended Posts

Hey guys,

 

I'm trying to make a custom 5x5 crafting table, but it doesn't seem to be working. Everything is ok, except it doesn't craft - I don't get a result when I place my recipe inside!

I followed a tutorial so I probably did something wrong, but the author never got back to me when I tried to contact them. Here's all the classes for my table.

 

It's worth noting also that I want the table to store items, so when you exit the items should STAY inside.

 

Not sure what classes you need to see (or even what I need to have, It seems like there's quite a few for something I expected to be relatively simple) so I just put all the ones directly relevant.

 

Container

GUI

Crafting Manager

Recipe Sorter

Shaped Recipe

Shapeless Recipe

Slot

Block

TileEntity

Renderer

 

I'm also getting a strange bug whereby sometimes items fall out of your inventory when you click them instead of picking them up. I've not quite worked out what causes it, because it's not consistant, so any ideas? The other issue is much more important right now though.

width=463 height=200

http://s13.postimg.org/z9mlly2av/siglogo.png[/img]

My mods (Links coming soon)

Cities | Roads | Remula | SilvaniaMod | MoreStats

Link to comment
Share on other sites

First of all, you have only 25 slots in your TE, so you're excluding the output.

 

Secondly, re "items should STAY inside", you have redefined onCraftGUIClosed() in your container code so that they won't. I assume you copied ContainerWorkbench or something... at any rate, remove that.

 

As to why your recipes don't work... if it persists after you add the output slot, I'll look at your recipe classes. I don't see any reason why they shouldn't work, but I haven't actually examined them.

BEWARE OF GOD

---

Co-author of Pentachoron Labs' SBFP Tech.

Link to comment
Share on other sites

First of all, you have only 25 slots in your TE, so you're excluding the output.

 

Fixed that now, didn't change anything =/

 

Secondly, re "items should STAY inside", you have redefined onCraftGUIClosed() in your container code so that they won't. I assume you copied ContainerWorkbench or something... at any rate, remove that.

 

The recipes were staying inside anyway, so that's quite strange. I removed that anyway, doesn't seem to have changed anything but at least I don't have a bit of useless code now :P

width=463 height=200

http://s13.postimg.org/z9mlly2av/siglogo.png[/img]

My mods (Links coming soon)

Cities | Roads | Remula | SilvaniaMod | MoreStats

Link to comment
Share on other sites

First of all, you have only 25 slots in your TE, so you're excluding the output.

 

Fixed that now, didn't change anything =/

 

Secondly, re "items should STAY inside", you have redefined onCraftGUIClosed() in your container code so that they won't. I assume you copied ContainerWorkbench or something... at any rate, remove that.

 

The recipes were staying inside anyway, so that's quite strange. I removed that anyway, doesn't seem to have changed anything but at least I don't have a bit of useless code now :P

Ah, you seemed to imply that they weren't. Anyway. Is the output actually being set? I notice that, while you have your own recipe classes defined, they don't seem to be getting used by your crafting manager.

BEWARE OF GOD

---

Co-author of Pentachoron Labs' SBFP Tech.

Link to comment
Share on other sites

  • 2 weeks later...

Gonna have to bump this. I tried tinkering a little but couldn't get it to work then focused on other things for a little while :P

 

Here's my updated code, but there's not MUCH different to before.

 

In your RoadsShapedRecipe class, the for loops within your matches method (lines 46 and 48) are checking "i <= 5"; shouldn't this be "i < 5" for a 5x5 grid?

 

Probably true, I changed it but to no avail.

 

Ah, you seemed to imply that they weren't. Anyway. Is the output actually being set? I notice that, while you have your own recipe classes defined, they don't seem to be getting used by your crafting manager.

 

I've fixed that now, didn't change anything :(

width=463 height=200

http://s13.postimg.org/z9mlly2av/siglogo.png[/img]

My mods (Links coming soon)

Cities | Roads | Remula | SilvaniaMod | MoreStats

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.