Jump to content

Custom Beacon Beam Renderer Help


skip999

Recommended Posts

Hello,

I seem to be having a slight issue with a custom TileEntityRenderer. Essentially, I am creating a custom beacon. I know the block correctly generates the beacon beams, yet the beams do not get sent to the client to actually be rendered. I do not have a lot of experience with tile entity rendering, so I would appreciate it if someone could take a look and tell me what I am doing wrong.

 

I have attached a link to my github. The reliant classes are:

>client.renderer.WardingBeaconTileEntityRenderer

>tileentity.WardingBeaconTileEntity

 

github link: https://github.com/skiprocks999/Rings-of-Infinity/tree/Rings-Of-Infinity-1.16.4/RingsOfInfinity

 

Thanks in advance!

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.