Jump to content

[ 1.16.5 ] How to cancel or replace particles of potion effects.


idev

Recommended Posts

7 hours ago, diesieben07 said:

If you want to change them, you're going to have to set visibility to false (so the default particles don't spawn) and spawn your own in Effect#applyEffectTick.

Forgive me if I am wrong, but wouldn't that only work for players, since potion effects are not synched to the client for other entities?

Link to comment
Share on other sites

  • 5 months later...
On 3/28/2021 at 12:18 PM, diesieben07 said:

Your question is somewhat vague. Is this for your own effect or in general? Generally an effect can be set invisible (see EffectInstance#visible), which means it won't spawn any particles.

If you want to change them, you're going to have to set visibility to false (so the default particles don't spawn) and spawn your own in Effect#applyEffectTick.

I have similar question, but in my case i am curious how to make effect produce less particles than usual, like particles from invisibility effect (their number is less comparing to other effects). Is there any way to achieve that?

Edited by mclich
Link to comment
Share on other sites

13 hours ago, diesieben07 said:

Show what you tried.

I actually tried nothing, i mean i don't even know where i can find method that creates potion particles in Forge library. Effect#applyEffectTick has two args: LivingEntity and int, and there is no such method in LivingEntity class. The only method i know and can use is World#addParticle, but if i use this method, potion particles from my effect and vanilla effects don't mix in one color, but they should do, so that is the issue. I aslo don't know what ParticleType should i use: ENTITY_EFFECT or AMBIENT_ENTITY_EFFECT, i don't know what is the difference between them

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Please share a link to your crash report on https://paste.ee, as explained in the FAQ. Dumping it directly into the thread often triggers the anti-spam and makes it hard to read due to word wrapping
    • Hi all, I'm running a 1.20.1 Minecraft Forge server with a hosting website and something seems to have gone wrong. It started as an occasional crash that has now become extremely frequent and I don't know what exactly is causing it. I already tried disabling watchdog but the server crashes anyway. Oddly it only occasionally generates a crash report after a crash occurs. Based on viewing the server console's research usage it seems that the CPU spikes astronomically high (100% usage), especially when chunks are being loaded or when a new person joins the server. I downloaded Spark to create a profile (https://spark.lucko.me/bBlWe7ou29) but I lack experience with this mod and don't understand what I'm looking at/how this should help me diagnose the issue. I am using a lot of mods so I'm guessing there is some sort of issue there or a corrupted chunk (although MCRF found no chunk errors). We actually don't experience any lag until the crash occurs, so it's some sort of sudden spike in resource usage. Based on the crash report I've already tried removing Canary and Modernfix but there was no change. Thanks for any help you can provide. Specs:  4 cores x 4200MHz AMD Ryzen 9 5950X 4GB RAM Crash report:  
    • will test that once i get home, thanks
    • I am getting this exception (I am new and just trying to create an item) Caused by: java.io.FileNotFoundException: abrasmagics:models/item/ingot_test.json at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:69) ~[SimpleReloadableResourceManager.class:?] at net.minecraft.client.renderer.block.model.ModelBakery.loadModel(ModelBakery.java:334) ~[ModelBakery.class:?] at net.minecraftforge.client.model.ModelLoader.access$1400(ModelLoader.java:115) ~[ModelLoader.class:?] at net.minecraftforge.client.model.ModelLoader$VanillaLoader.loadModel(ModelLoader.java:861) ~[ModelLoader$VanillaLoader.class:?] at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]   However the directory is set up correctly and the file does exist   idk how to upload images so here is a treeview of the directories:   src ├───main │ ├───java │ │ └───net │ │ └───abrasmods │ │ └───abrasmagics │ │ ├───init │ │ ├───items │ │ └───utils │ │ ├───handlers │ │ ├───misc │ │ └───proxy │ └───resources │ └───assets │ └───abrasmagics │ ├───models │ │ ├───block │ │ └───item │ └───textures └───test ├───java └───resources   the file ingot_test.json is under models/item. The directory seems fine and the file does exist so anyone plz help.   i am using intellij and is coding for 1.12.2
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.