Jump to content

[SOLVED 1.16.5] Custom dimension: Player world not saved


Recommended Posts

So i have a custom dimension. It can be entered by activating an item. However if i exit the game while inside this dimension and then restart the game, i will spawn on the overworld at the coordinates i left my custom dimension. I think the custom dimension is not properly saved inside the ServerPlayer. Any changes made to the dimension are changed. Like placing or removing blocks. I use ServerPlayerEntity.teleport(...) to enter my dimension. This should actually set the reference to the new world(dimension) and thus it should be saved somewhere even if i restart the game.

Am i missing something?



SOLVED: I forgot to register the Chunkgenerator CODEC to the Registry

Edited by DietmarKracht
Link to comment
Share on other sites

  • DietmarKracht changed the title to [SOLVED 1.16.5] Custom dimension: Player world not saved

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.