Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Gloombone

Members
  • Content Count

    9
  • Joined

  • Last visited

Everything posted by Gloombone

  1. Just tested with the latest #1025 build of forge, getting the same error.
  2. I am on a mac using the java version that works for that environment e.g. 1.6.0 You can see the full log of the terminal here: https://gist.github.com/lslinnet/3243d53ad082c94d7bbe Additional information: ➜ forge-1.7.2-10.12.0.1024-src java -version java version "1.6.0_65" Java SE Runtime Environment (build 1.6.0_65-b14-462-11M4609) Java HotSpot 64-Bit Server VM (build 20.65-b04-462, mixed mode) ➜ forge-1.7.2-10.12.0.1024-src gradle -v ------------------------------------------------------------ Gradle 1.10 ----------------------------------------------------
  3. They do keep the execution flag, it's just a matter of adding it before packaging it.
  4. As the subject says, everytime I need to setup forge for a development environment, I have to do: chmod +x install.sh would be nice if this was done before hand.
  5. Have just testet it with the latest build minecraftforge-src-1.4.5-6.4.1.437 and it seems like it have been fixed, thank you very much for fixing this so quickly! you are a champ
  6. To be more clear, I have previously been able to run the ./install.sh script from forge - before forge was changed to download mcp by it self. This was due to the fact that mcp actually includes the astyle-osx in it's runtime/bin directory. So it is not a matter of detecting it nor throwing an error - but just make sure it has the execute flag, the mcp zip does have this flag configured but somehow forge doesn't respect this when unpacking it, so my guess without having looking into the code that handles the unpacking is that the problem is a missing parameter or similar on the call to
  7. It is missing execution flag for the astyle-osx command that mcp is supplying. unzipping the mcp zip manually sets the execution flag for runtime/bin/astyle-osx correctly.
  8. 1) I downloaded the latest forge, at the time of writing this it was: Build 6.4.1.436: 2012-12-10 15:59:55 for MC: 1.4.5 2) Read the readme which wasn't very clear on the area of MCP it both stats it includes it self but also that it should be placed in the MCP folder? continued without placing it in a MCP folder. 3) chmod +x install.sh 4) ./install.sh which ended in a failed recompile. se log below for further details http://pastebin.com/V9WkzT6N Let me know if I should try something different - will try it while it's in an MCP folder later tonight.
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.