Jump to content

buridan

Members
  • Posts

    4
  • Joined

  • Last visited

Everything posted by buridan

  1. Error: Execution failed for task ':compileJava'. > Could not resolve all files for configuration ':compileClasspath'. > Could not find net.minecraftforge:forge:1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12. Searched in the following locations: - https://maven.minecraftforge.net/net/minecraftforge/forge/1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12/forge-1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12.pom - https://maven.minecraftforge.net/net/minecraftforge/forge/1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12/forge-1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12.jar - file:/C:/Users/burid/.gradle/caches/forge_gradle/bundeled_repo/net/minecraftforge/forge/1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12/forge-1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12.pom - file:/C:/Users/burid/.gradle/caches/forge_gradle/bundeled_repo/net/minecraftforge/forge/1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12/forge-1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12.jar - https://libraries.minecraft.net/net/minecraftforge/forge/1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12/forge-1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12.jar - https://repo.maven.apache.org/maven2/net/minecraftforge/forge/1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12/forge-1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12.pom - https://repo.maven.apache.org/maven2/net/minecraftforge/forge/1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12/forge-1.12.2-14.23.5.2859_mapped_snapshot_20171003-1.12.jar Required by: project : Possible solution: - Declare repository providing the artifact, see the documentation at https://docs.gradle.org/current/userguide/declaring_repositories.html
  2. Resolved. You need open as project folder, fokder in which you have src(Not gradle file)
  3. After building project with gradle and open it in IntelIiJ, I can't find task fot run(debug) launch. When I start in IntelliJ gradle task 'prepareRuns', it gives me this log: 11:34:39: Executing 'prepareRuns'... > Configure project : Java: 1.8.0_345, JVM: 25.345-b01 (Temurin), Arch: amd64 WARNING: This project is configured to use the official obfuscation mappings provided by Mojang. These mapping fall under their associated license, you should be fully aware of this license. For the latest license text, refer below, or the reference copy here: https://github.com/MinecraftForge/MCPConfig/blob/master/Mojang.md, You can hide this warning by running the `hideOfficialWarningUntilChanged` task WARNING: (c) 2020 Microsoft Corporation. These mappings are provided "as-is" and you bear the risk of using them. You may copy and use the mappings for development purposes, but you may not redistribute the mappings complete and unmodified. Microsoft makes no warranties, express or implied, with respect to the mappings provided here. Use and modification of this document or the source code (in any form) of Minecraft: Java Edition is governed by the Minecraft End User License Agreement available at https://account.mojang.com/documents/minecraft_eula. > Task :downloadMcpConfig > Task :extractSrg UP-TO-DATE > Task :createSrgToMcp UP-TO-DATE > Task :downloadMCMeta UP-TO-DATE > Task :downloadAssets UP-TO-DATE > Task :extractNatives UP-TO-DATE > Task :makeSrcDirs > Task :prepareRuns Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0. You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins. See https://docs.gradle.org/7.5/userguide/command_line_interface.html#sec:command_line_warnings BUILD SUCCESSFUL in 3s 7 actionable tasks: 2 executed, 5 up-to-date 11:34:42: Execution finished 'prepareRuns'. Forge: forge-1.19.2-43.1.1-mdk Minecraft: 1.19.2 JDK: jdk-8.0.345.1-hotspot gradlew --version output: ------------------------------------------------------------ Gradle 7.5 ------------------------------------------------------------ Build time: 2022-07-14 12:48:15 UTC Revision: c7db7b958189ad2b0c1472b6fe663e6d654a5103 Kotlin: 1.6.21 Groovy: 3.0.10 Ant: Apache Ant(TM) version 1.10.11 compiled on July 10 2021 JVM: 1.8.0_345 (Temurin 25.345-b01) OS: Windows 10 10.0 amd64
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.