Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Zathrox

Members
  • Posts

    26
  • Joined

  • Last visited

Converted

  • Gender
    Undisclosed
  • Personal Text
    I am new!

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Zathrox's Achievements

Tree Puncher

Tree Puncher (2/8)

5

Reputation

  1. Thanks for that! Figured it out, might not be the cleanest way to implement it but I added this to my FMLCommonSetupEvent setup like this and it works: event.enqueueWork(() -> { ((FlowerPotBlock)Blocks.FLOWER_POT).addPlant(ExplorerBlocks.BAMBOO_SAPLING.getId(), ExplorerBlocks.POTTED_BAMBOO_SAPLING::get); });
  2. As mentioned in the title, I noticed that whenever I used the recommended method to initializing custom saplings/plants with the flower pot block, it never allows me to add said sapling to an empty pot but when I use the depreciated method it works perfectly. I also think this has been the case since its implementation, probably in 1.14? Now I may not fully understand or be utilizing the supplier/getters correctly either so I'll provide my code below just incase. This is my code below: public static final RegistryObject<Block> POTTED_BAMBOO_SAPLING = register("potted_bamboo_sapling", () -> new FlowerPotBlock(() -> (FlowerPotBlock) Blocks.FLOWER_POT, BAMBOO_SAPLING::get, AbstractBlock.Properties.create(Material.MISCELLANEOUS).zeroHardnessAndResistance()));
  3. Do we really need to register each block in the clientsetupevent that we want to be a transparent block? that seems horribly redundant from just adding a simple method to a base class like bush block or something! *edit* but after looking at rendertypelookup, it is indeed how vanilla does it! well I guess that's the new rendering engine for you
  4. As mentioned in the title, i'm in the process of updating of updating my mod to 1.15 from 1.14 and most of the blocks and stuff have ported over quite nicely, however, I noticed that all my non-solid blocks such as plants aren't rendering properly, when I evaluate the differences, 1.14 BushBlock has this line of code: public BlockRenderLayer getRenderLayer() { return BlockRenderLayer.CUTOUT; } but 1.15 BushBlock doesn't have anything regarding rendering and such, does anyone know how I can fix this? had a nose around and can't find anything in particular that'll get it to work! Many thanks!
  5. Thanks, that might actually work! Might be difficult for me to test but hopefully it works
  6. The zombie pigmen are just spawned as a spawn condition on the nether biome, aren't they? I'm not having a problem spawning them in the dimension, its adding additional checks to make sure that it is a particular dimension, so my mobs don't randomly spawn in say, a birch forest biome on a sky island in the sky dimension mod. this.addSpawn(EntityClassification.MONSTER, new SpawnListEntry(EntityType.ZOMBIE_PIGMAN, 100, 4, 4)); I'm basically, trying to clean up some of the bugs in my 1.14 version to make it more polished before working on my 1.15 version, so hopefully, someone can help me figure this out
  7. As the title says, how would I go about checking the dimension and not just the biome from scratch ? I've had some users of my mod say a sky dimension was spawning my monsters in it because it used vanilla biomes in its generator, so I wanted to add a an additional check to my mob spawning conditions to make sure that its only the overworld/end/nether variants of the biomes and not random dimensions! My Entity Registration/Spawning Code public class ExplorerEntities { private static List<EntityType> entities = Lists.newArrayList(); private static List<Item> spawnEggs = Lists.newArrayList(); public static final EntityType<EnderreeperEntity> ENDERREEPER = createEntity(EnderreeperEntity.class, EnderreeperEntity::new, EntityClassification.MONSTER, "enderreeper", 0.6F, 1.99F, 3801171, 7078066); /* Unneeded Code Redacted */ @SubscribeEvent public static void registerEntities(RegistryEvent.Register<EntityType<?>> event) { for (EntityType entity : entities) { event.getRegistry().register(entity); } EntitySpawnPlacementRegistry.register(ENDERREEPER, EntitySpawnPlacementRegistry.PlacementType.ON_GROUND, Heightmap.Type.MOTION_BLOCKING_NO_LEAVES, MonsterEntity::func_223325_c); private static void registerEntityWorldSpawn(EntityType<?> type, int weight, int minCount, int maxCount, Biome... biomes) { for(Biome biome : biomes) { if(biome != null) { biome.getSpawns(type.getClassification()).add(new Biome.SpawnListEntry(type, weight, minCount, maxCount)); } } } public static void registerEntityWorldSpawns() { if(EntityConfig.enderreeper_enabled.get()) { registerEntityWorldSpawn(ENDERREEPER, 5, 1, 2, Biomes.THE_END); registerEntityWorldSpawn(ENDERREEPER, 8, 1, 2, Biomes.END_BARRENS, Biomes.SMALL_END_ISLANDS, Biomes.END_HIGHLANDS, Biomes.END_MIDLANDS); } //&& DimensionType.getById(0) == DimensionType.OVERWORLD if(EntityConfig.enderreeper_overworld_spawn_enabled.get()) { EnderreeperEntity.addSpawn(); } if(EntityConfig.enderreeper_nether_spawn_enabled.get()) { registerEntityWorldSpawn(ENDERREEPER, 5, 1, 2, Biomes.NETHER); } } } My Enderreeper addSpawn() code: //==== Spawning ====// public static void addSpawn() { ForgeRegistries.BIOMES.getValues().stream().forEach(EnderreeperEntity::processSpawning); } private static void processSpawning(Biome biome) { if (biome != Biomes.MUSHROOM_FIELDS || biome != Biomes.MUSHROOM_FIELD_SHORE || biome != Biomes.NETHER) { biome.getSpawns(EntityClassification.MONSTER).add(new Biome.SpawnListEntry(ExplorerEntities.ENDERREEPER, 2, 1, 1)); } } How would I go about this? unfortunately i've been away from modding for a good few months and i'm rusty as hell, so any help regarding this would be massively appreciative! Many Thanks
  8. Ah thanks for this! I basically got the trades working after finding the VillagerTradesEvent myself and between looking at that and other peoples examples for the wandering trader, I got it working buuuuut for the trades, I practically ripped and copied the VillagerTrades class and made it public so finding the BasicTrade class is very useful to know! I can pretty much scrap my own and use that! Nevermind, will stick to my class, when they say basic trade, they really do mean basic! its good if you want to use emeralds to buy something like a sword or other items but not so much for 22 CustomCrop for emeralds, etc
  9. Hello there, has anyone figured out how to easily add new trades to existing villager trades? Like add a new crop to the farmer trades for example? I can see the villager traders hashmaps/array, etc but i'm not quite sure how to go about adding to that list correctly and get it registered and noticed by vanilla? if someone has the time to explain how to approach the problem I'd love to learn more about manipulating these so I can add new trades, that'd be amazing! *edit* Another issue I have is when I sort of copy the code to another class just to play about with adding, alot of the VillagerTrades.class functions are locked and private and I know you can use merchant offer to make new trades but its not recognised as an ITrade array, just boggled and confused, so clarity would be nice! Zathrox
  10. THE INFECTION EXPANSION HAS DROPPED, WITH NEW MOBS, WORLD GEN, BLOCKS AND MORE! GET THE MOD HERE: EXPLORERCRAFT - INFECTION EXPANSION
  11. Updated to 2.2.7, added some ore-dict compatibility and tweaked various sounds for blocks under feedback, also added some creative mode only ocean items (couldn't get generation code working!)
  12. Last 3 updates have added final passes over the artwork on the gems, ores, tools in the game to new designs and consistent colouring's throughout
  13. Anyone able to help with this? Still stuck with what is causing the issue, from all the different variations i've done, can't seem to get it to work
  14. Hello everyone! I've noticed a few people struggling with this and also delved into the problem myself so I decided to make a little tutorial on my blog, hopefully explaining how to create foods in the latest version of minecraft! Checkout the tutorial here: Creating Custom Foods Hope this helps, Zathrox
  15. Hey guys, just throwing this out there to see if any of you guys can figure it out! Basically trying to create a new banner pattern, everything works well in terms of items generating, code loading etc, but when I put the banner pattern in the loom with a banner+dye, I get this error log: https://pastebin.com/J2fwkHA5 This is my item setup: BannerPatternItem(BannerPattern.create("welshflag", "welshflag", "welshflag",new ItemStack(ModItems.RUBY)), new Item.Properties().maxStackSize(1).group(ModItemGroups.MOD_ITEM_GROUP)), "welshflag_banner_pattern") with regards to my issue, I can see it's something to do with the loom, renderer and client but I can't pin-point what it causing it / how to fix it! but i've been working on this for ages now, with no avail, so passing the baton on! while i work on other things! as a side note if I do: /give @p black_banner{BlockEntityTag:{Patterns:[{Pattern:"welshflag",Color:14}]}} 1 it generates the flag perfectly, I can even put the banner on a shield and have it work, however, I think it has something to do with the mini-icons that appear in the loom, not sure if they are a separated template or just a shrunk down version of the shield/banner textures but yeah, help decoding that error message would be great!
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.