Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

crackedEgg

Members
  • Posts

    60
  • Joined

  • Last visited

Everything posted by crackedEgg

  1. Same here, had a working project, updated to 32.2.5 and got the same error message.
  2. It looks like the bees have a list of flowers that they are attracted to in the TemptGoal. That list is a tag in /data/minecraft/tags/blocks/small_flowers.json or the /data/minecraft/tags/blocks/tall_flowers.json directories. You should be able to add to those tags.
  3. All of the minecraft .png files are in the assets directory of the minecraft jar. just extract that and have a look. this includes all items that would appear in an inventory and also the inventory container gui. It seems like that's what you want.
  4. I have a parachute mod that works as expected in singleplayer. The mod also seems to work as expected in multiplayer for the individual player on the parachute. However it seems other players are not receiving position or motion updates from the server. While the player(s) on the parachute experience the parachute acting normally and can maneuver just fine the other players see the player on the parachute as drifting slowly to the ground. I don't know how to update the other players or tell the server to update the other players. Any help would be appreciated. Here is a link to the entity class. ParachuteEntity.java
  5. Thanks! Now my parachute spawns and I can mount it. I can't control it though, still working on that.
  6. I think something may be missing in the forge registry/spawn code. I have an entity that is mountable and I get a [minecraft/ClientPlayNetHandler]: Received passengers for unknown entity warning in the console. The entity is not visible and cannot be controlled. So you're not the only one experiencing this type of issue.
  7. I can't find where BlockEvent.PlaceEvent is used in forge code. rg BlockEvent.PlaceEvent minecraftforge/event/ForgeEventFactory.java 125:import net.minecraftforge.event.world.BlockEvent.PlaceEvent; minecraftforge/common/ForgeHooks.java 635: BlockEvent.PlaceEvent placeEvent = null; Only two places in forge code that this shows up. That may be why its not firing.
  8. Using both your suggestions I got spawning working. It looks like I needed an EntitySpawnPlacement as well. I didn't see any spawns until I added the placement. Thanks for all your help! private void registerEntitySpawn(EntityType<? extends EntityLiving> type, Biome[] biomes, int spawnProb, int minSpawn, int maxSpawn) { EntitySpawnPlacementRegistry.register(type, EntitySpawnPlacementRegistry.SpawnPlacementType.ON_GROUND, Heightmap.Type.MOTION_BLOCKING_NO_LEAVES, null); for (Biome bgb : biomes) { Biome biome = ForgeRegistries.BIOMES.getValue(bgb.getRegistryName()); if (biome != null) { biome.getSpawns(EnumCreatureType.MONSTER).clear(); biome.getSpawns(EnumCreatureType.MONSTER).add(new Biome.SpawnListEntry(type, spawnProb, minSpawn, maxSpawn)); } } }
  9. I'm trying to spawn mobs in specific biomes. I noticed addSpawn method is protected in Biome class and there doesn't seem to be a forge registry for this. Is there another way to do this in 1.13.x or am I missing something?
  10. you can look at this code I use to steer the parachute and adopt it to steer the boat EntityParachute.java ParachuteInputEvent.java
  11. Sorry, I am not asking for help. Just trying to back up what TheJ-max04 is saying. The logger appears to be broken for deobfuscated environments like Eclipse or Intellij. And I'm out....
  12. I've been using LogManager.getLogger() all along. This doesn't work any longer. I recently changed to using event.getModLog() in FMLPreInitialzationEvent per the documentation in the FMLPreInitializationEvent class. This doesn't work in 2768 but does work in 2705.
  13. This happens in Intellij as well. The logging works in forge 2705 and does not work in 2768.
  14. You might try checking which java version the OS has set. If you are using Ubuntu/Fedora/Debian you would use "update-alternatives" to check/set the java version. Archlinux you would use archlinux-java command to check/set the java version. Also I use OpenJDK and have no issues. I used to have and issue now and then early on, but so far its been as stable as the Oracle version.
  15. MathHelper.wrapDegrees wraps from -180 to +180 degrees. That may be what he needs here, but the getInt() part threw me off since the angles are ARGUMENT_ROTX_MIN and 0 (zero). Falina-Lain: if you look at the clamp methods you can see that you can specify the values to clamp to. final int pitchMin = MathHelper.clamp(argumentMap, ARGUMENT_ROTX_MIN, 0); I think that would work for you, if you need to clamp between zero and ARGUMENT_ROTX_MIN.
  16. Perhaps you're looking for MathHelper.clamp(int num, int min, int max), there are float and double versions too.
  17. Here is one way to do this: https://github.com/m1k3s/crackedzombie/blob/master/crackedzombie/common/CrackedZombie.java#L129 This method excludes Void, End, and Nether.
  18. In my case 'preview_OptiFine_1.12.2_HD_U_C8_pre' prior to 12-18-2017 was causing chests not to open. I DL'd the 12-18-2017 version that is compatible with forge 2577 and the chests open as before.
  19. I've had the same issue. I started using ForgeRegistries.BIOMES.getValues() to get a list of biomes to filter by type. This list also return Biomes O Plenty mod biomes, so it should work for all biome mods that use BiomeDictionary.
  20. I am trying to use BiomeDictionary for spawning and the BiomeDictionary.getBiomes(Type t) method returns zero biomes for any given type. What am I doing wrong? I call this method for testing in postInit. (I've tried preInit and Init as well). ... listBiomes(Type.HOT, Type.DRY, Type.SANDY); ... private void listBiomes(Type... types) { for (Type t : types) { Set<Biome> biomes = BiomeDictionary.getBiomes(t); if (biomes.size() == 0) { proxy.info(t.getName() + ": no biomes found"); } else { for (Biome b : biomes) { proxy.info(t.getName() + ": " + b.getBiomeName()); } } } } [15:33:17] [Client thread/INFO] [FML]: HOT: no biomes found [15:33:17] [Client thread/INFO] [FML]: DRY: no biomes found [15:33:17] [Client thread/INFO] [FML]: SANDY: no biomes found This is the output. The code can be found at Github
  21. try putting the modid in the sound name. This is what my sounds.json file looks like: { "chuteopen": { "category": "neutral", "sounds": [ "parachutemod:chuteopen1", "parachutemod:chuteopen2", "parachutemod:chuteopen3", "parachutemod:chuteopen4" ] } }
  22. Please look at my code on github. I have three repos there that may help. look at the json files as well.
  23. Have a look at this: https://github.com/m1k3s/parachute/blob/master/parachute/client/ParachuteClientProxy.java#L47
  24. I think you need to add the "name" tag to your json if you are going to have other tags such as "stream" in there. { "noise_maker_noise": { "category": "master", "sounds": [ { "name": "something:noiseMakerNoise", "stream": false } ] } }
  25. The same thing has happened to me. Opened an old world with updated mods that create new blocks and the blocks are all scrambled. I suspect that the updated mod with blocks is using different block IDs or something. Occasionally Minecraft adds blocks to the game and that may have something to do with the block IDs changing. I have a mod that has a metal ladder and that was consistently replaced with an iron trapdoor. Another mod block was replaced with slime blocks. The fact that you can open the old world with the correct version of forge and everything reverts makes me think the block ID is the issue. I don't really know though.
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.