Jump to content

[Solved][1.6.2] Installing problems


Naiten
 Share

Recommended Posts

Firstly, when i unzipped forge and started installing, i got errors when decompiling caused by something with libraries.

But i believe, this method fixed them correctly.

 

Than I tried recompiling clear MC 1.6.2 and got a buch of errors:

 

== MCP 8.04 (data: 8.04, client: 1.6.2, server: 1.6.2) ==
"scalac" is not found on the PATH.  Scala files will not be recompiled
# found ff, ff patches, srgs, name csvs, doc csvs, param csvs, astyle, astyle co
nfig, rg, ss
== Recompiling client ==
> Cleaning bin
> Recompiling
'"C:\Program Files\Java\jdk1.7.0_17\bin\javac" -encoding UTF-8 -Xlint:-options -
deprecation -g -sourc...' failed : 1

== ERRORS FOUND in JAVA CODE ==

src\minecraft\net\minecraft\client\gui\LoadingScreenRenderer.java:52: error: run
ning is not public in Minecraft; cannot be accessed from outside package
        if (!this.mc.running)
                    ^

src\minecraft\net\minecraft\client\gui\LoadingScreenRenderer.java:77: error: run
ning is not public in Minecraft; cannot be accessed from outside package
        if (!this.mc.running)
                    ^

src\minecraft\net\minecraft\client\gui\LoadingScreenRenderer.java:98: error: run
ning is not public in Minecraft; cannot be accessed from outside package
        if (!this.mc.running)
                    ^

src\minecraft\net\minecraft\util\ChatMessageComponent.java:258: warning: non-var
args call of varargs method with inexact argument type for last parameter;
                var7.append(StatCollector.translateToLocalFormatted(this.field_1
11090_h, var13));

         ^

  cast to Object for a varargs call
  cast to Object[] for a non-varargs call and to suppress this warning
3 errors
1 warning
==================

== Recompiling server ==
> Cleaning bin
> Recompiling
Server side recompiling might be skipped, this is normal, do not complain to FML
/Forge team about server side.
- Done in 4.72 seconds
Для продолжения нажмите любую клавишу . . .

 

I opened Minecraft class and changed the visibility of running to public. Now it recompiles, but when i try to start, i get a damn i-can't-even-suppose-what-the-duck-can-it-be error.

 

== MCP 8.04 (data: 8.04, client: 1.6.2, server: 1.6.2) ==
"scalac" is not found on the PATH.  Scala files will not be recompiled
[01:38:07] Error: Could not find or load main class net.minecraft.launchwrapper.
Launch
'"C:\Program Files\Java\jdk1.7.0_17\bin\java" -Xincgc -Xms1024M -Xmx1024M -cp ".
.\bin\minecraft;..\sr...' failed : 1
FATAL ERROR
Traceback (most recent call last):
  File "runtime\startclient.py", line 42, in startclient
  File "E:\Minecraft\RoW1.6.2\mcp\runtime\commands.py", line 1362, in startclien
t
    self.runmc(forkcmd)
  File "E:\Minecraft\RoW1.6.2\mcp\runtime\commands.py", line 1402, in runmc
    raise CalledProcessError(process.returncode, forkcmd, output)
CalledProcessError: Command '"C:\Program Files\Java\jdk1.7.0_17\bin\java" -Xincg
c -Xms1024M -Xmx1024M -cp "..\bin\minecraft;..\src\minecraft;..\jars\versions\1.
6.2\1.6.2.jar;..\lib;..\lib\*;..\jars\libraries\net\java\jinput\jinput\2.0.5\jin
put-2.0.5.jar;..\jars\libraries\org\lwjgl\lwjgl\lwjgl-platform\2.9.1-nightly-201
30708-debug3\lwjgl-platform-2.9.1-nightly-20130708-debug3-natives-windows.jar;..
\jars\libraries\org\lwjgl\lwjgl\lwjgl_util\2.9.1-nightly-20130708-debug3\lwjgl_u
til-2.9.1-nightly-20130708-debug3.jar;..\jars\libraries\com\paulscode\codecwav\2
0101023\codecwav-20101023.jar;..\jars\libraries\net\java\jinput\jinput-platform\
2.0.5\jinput-platform-2.0.5-natives-windows.jar;..\jars\libraries\argo\argo\2.25
_fixed\argo-2.25_fixed.jar;..\jars\libraries\com\paulscode\codecjorbis\20101023\
codecjorbis-20101023.jar;..\jars\libraries\org\bouncycastle\bcprov-jdk15on\1.47\
bcprov-jdk15on-1.47.jar;..\jars\libraries\org\apache\commons\commons-lang3\3.1\c
ommons-lang3-3.1.jar;..\jars\libraries\com\paulscode\soundsystem\20120107\sounds
ystem-20120107.jar;..\jars\libraries\org\lwjgl\lwjgl\lwjgl\2.9.1-nightly-2013070
8-debug3\lwjgl-2.9.1-nightly-20130708-debug3.jar;..\jars\libraries\commons-io\co
mmons-io\2.4\commons-io-2.4.jar;..\jars\libraries\com\paulscode\libraryjavasound
\20101123\libraryjavasound-20101123.jar;..\jars\libraries\net\sf\jopt-simple\jop
t-simple\4.5\jopt-simple-4.5.jar;..\jars\libraries\com\paulscode\librarylwjglope
nal\20100824\librarylwjglopenal-20100824.jar;..\jars\libraries\com\google\guava\
guava\14.0\guava-14.0.jar;..\jars\libraries\com\google\code\gson\gson\2.2.2\gson
-2.2.2.jar;..\jars\libraries\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar" -Dja
va.library.path=..\jars\versions\1.6.2\1.6.2-natives net.minecraft.launchwrapper
.Launch --tweakClass cpw.mods.fml.common.launcher.FMLTweaker --version FML_DEV '
returned non-zero exit status 1
Для продолжения нажмите любую клавишу . . .

 

Grrr!!!  >:(

 

Any ideas what i have to do?

If i helped you, don't forget pressing "Thank You" button. Thanks for your time.

Link to comment
Share on other sites

i found an answer: the minecraftforge installation guide wrote this:

"You do not need to run any of the MCP scripts to decompile Minecraft and install Forge. Forge's install.sh will do it for you."(Minecraftforge)

unfortunately i don't know where the java codes are. when i start eclipse the 'src' ordner of minecraft is empty ?!?

Link to comment
Share on other sites

I've tryed once more and now it's fine. Seems that it happened because i had no minecraft 1.6.2 installed itself, lol.

 

Java sources are in there usual place — forge/mcp/src if everything went good.

If i helped you, don't forget pressing "Thank You" button. Thanks for your time.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • This is my first time making a pack and i just wanted to add mods that i know or that look interesting. So When making the pack i get this error with Refined Storage https://pastebin.com/DxtTbVZW
    • Hello! When I'm trying to get items by tag during the recipe serialization, I'm getting an empty list. I have a guess that item tags're not loaded by the time minecraft loads my recipes. Here's my code: Class that saves information about ingredient's count Recipe serializer with some aux methods: Registry: Example of the json recipe file:  
    • I tried to install client forge on my linux desktop. But after "installation" it's missing forge[version].jar file in .minecraft/versions. I tried java 11 and 8 environment with same result. Here link to log file from installation: https://drive.google.com/file/d/1vtg9NT-WX5ilb1aNUvZlOv54gKWJuaT1/view?usp=share_link. I don't know what to do. I give for every directory permissions that I don't think that is issue. I will try check older versions if universal file work. Debian 11 (kernel 5.10)
    • I recently got error 1 in the launcher, so I restarted the .minecraft. After restarting it, I can't get the Forge 1.19.2 - 43.1.1 installer to run, I tried other versions and I get the same result, it opens a black box that closes instantly and nothing happens. I already tried to restart my pc, minecraft, update and reinstall java, run vanilla 1.19.2 and more recent versions of the game, disable Windows Firewall and antivirus and I still haven't solved it. Many times I installed forge and never ran into this problem. If I could receive assistance I would be very grateful.  
    • Here's the default loot table for gravel block: { "type": "minecraft:block", "pools": [ { "rolls": 1.0, "bonus_rolls": 0.0, "entries": [ { "type": "minecraft:alternatives", "children": [ { "type": "minecraft:item", "conditions": [ { "condition": "minecraft:match_tool", "predicate": { "enchantments": [ { "enchantment": "minecraft:silk_touch", "levels": { "min": 1 } } ] } } ], "name": "minecraft:gravel" }, { "type": "minecraft:alternatives", "conditions": [ { "condition": "minecraft:survives_explosion" } ], "children": [ { "type": "minecraft:item", "conditions": [ { "condition": "minecraft:table_bonus", "enchantment": "minecraft:fortune", "chances": [ 0.1, 0.14285715, 0.25, 1.0 ] } ], "name": "minecraft:flint" }, { "type": "minecraft:item", "name": "minecraft:gravel" } ] } ] } ] } ] } This is a finicky loot table. If I add anything to it, nothing drops. I've added pools, entries, children ... you name it. Does anyone know the particulars about this table? I mean, periodically gravel drops flint instead of a gravel block. I understand the condition that could drop flint if the block survives an explosion. Otherwise, it drops the gravel block itself. I would like to further understand why the use of `children` and the set of `chance` values given in the explosion child entry. What I do understand is that `"type" : "minecraft:alternatives"` means that if this child/entry is successful, then it stops generating loot for this entry/pool. How often does the flint drop and is that taken care of in another location? Is that in a `"condition" : "minecraft:table_bonus"` loot table? Hmmm... I'll have to go take a look and see if there is something called table_bonus.json.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.