Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge 1.12 won't install. "exception in initializer error"


Recommended Posts

I ran 1.12 on the minecraft launcher first. Worked fine.

I've played on 1.17.1 as well.

1.12 and 1.17.1 fabric and vanilla 1.17.1 work fine.

 

I downloaded both the "latest" and "recommended" installers(not the windows installers) from the main forge website.

https://files.minecraftforge.net/net/minecraftforge/forge/index_1.12.html

I downloaded the "recommended" first and when the following steps didn't work, i tried with the "latest". so there was no mixing of files.

 

Double clicking the file brought up the loading hourglass for a split second but nothing else.

right-click open with java platform... does nothing except create a text document in the directory that says

 

"Exception in thread "main" java.lang.ExceptionInInitializerError
    at net.minecraftforge.installer.ClientInstall.getSponsorMessage(ClientInstall.java:401)
    at net.minecraftforge.installer.InstallerAction.getSponsorMessage(InstallerAction.java:60)
    at net.minecraftforge.installer.InstallerPanel.updateFilePath(InstallerPanel.java:334)
    at net.minecraftforge.installer.InstallerPanel.<init>(InstallerPanel.java:315)
    at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:164)
    at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:51)
Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
    at net.minecraftforge.installer.MirrorData.buildMirrorList(MirrorData.java:84)
    at net.minecraftforge.installer.MirrorData.<init>(MirrorData.java:63)
    at net.minecraftforge.installer.MirrorData.<clinit>(MirrorData.java:17)
    ... 6 more"
 

 

opening the jar file through the command prompt generates the same error in the command prompt as the above text document.

 

i tried jarfix, it seemed to work properly for converting the icons but the same error persists.

 

java version 8 update 261 (build 1.8.0_261-b12)

 

i then updated java to the newest version which is

version 8 update 301 (Build 1.8.0_301-b09)

 

 

Thank you for any help or advice.

 

-Pongosdaddy

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello, I was wondering wether item groups are client or server-sided?
    • i would really appreciate help on this. i just can't figure out how to deobf my api module / prevent the api module from being obfuscated in the dev env.
    • I want to debug in intellij but when i click the debug icon it runs like normal, and if you go to top right(Gradle icon), normally i use runClient but if i try runServer minecraft doesnt open, or runServer with debug(https://imgur.com/a/KuSUqwt), (the eula.txt file has eula=true just in case) before minecraft window open it close with no errors, like if i closed it on purpose
    • By looking at the log output for command 'gradlew --debug runData', it appears that the Standard Library jars get passed to Forge via the '-cp' command line parameter correctly in both versions. Trying to create a workaround earlier revealed that the module resolver is aware of the Standard Library's exports, and therefore conflicts with any attempt to manually copy stdlib over to 'build/classes/kotlin/main'. This means I cannot create a workaround that way. I have also switched to 1.18, and this issue still persists. This is most likely an issue regarding JVM options, which I do not have enough knowledge about. The build.gradle snippets shown above (remember switching jvmTarget in kotlinOptions to 17 when building for 1.18), alongside with the following piece of code for a mod class, should be enough to reproduce: File: src/main/kotlin/com/example/examplemod/ExampleMod.kt package com.example.examplemod import net.minecraftforge.fml.common.Mod import org.apache.logging.log4j.LogManager import org.apache.logging.log4j.Logger @Mod("examplemod") class ExampleMod { init { LOGGER.info("Hello World!") } companion object { private val LOGGER: Logger = LogManager.getLogger() } } Note that removing the explicit type Logger (so it becomes 'private val LOGGER = LogManager.getLogger()') loads successfully, because when there is no explicit type specified, Koltin implicitly infers a so-called platform type, shown in IDE as 'Logger!' (note the exclamation mark). This platform type is not null checked by default, so there are no references to 'kotlin.jvm.internal.Intrinsics' for null checks. Specifying the type explicitly as not null however creates a null check under the hood, because in Kotlin, for a type to be nullable, it has to be suffixed with a question mark (Logger?). Otherwise it is guaranteed to be not null. Explanation for those not knowing Kotlin: The 'init' block is essentially a constructor block. The Java equivalent would be 'public ExampleMod() { LOGGER.info("Hello World!"); }'. Declarations inside 'companion object' basically behave like static declarations, so the Java equivalent would be 'private static Logger LOGGER = LogManager.getLogger();'. Looking forward to a fix! Thank you for your time.
    • affter a bit of time this worked: @SubscribeEvent public static void renderPlayerPre(RenderPlayerEvent.Pre event) { //here i was canceling the pre event so... event.getRenderer().getEntityModel().bipedLeftArm.showModel = false; } @SubscribeEvent public static void renderPlayerPost(RenderPlayerEvent.Post event) { PlayerEntity player = event.getPlayer(); PlayerModel<AbstractClientPlayerEntity> model = event.getRenderer().getEntityModel(); ModelRenderer rightArm = model.bipedLeftArm; rightArm.showModel = true; rightArm.render( event.getMatrixStack(), event.getBuffers().getBuffer(RenderType.getEntitySolid(((AbstractClientPlayerEntity)player).getLocationSkin())), Minecraft.getInstance().getRenderManager().getPackedLight(player, 1f), OverlayTexture.NO_OVERLAY); } But just one more thing, i promess no more questions..., the hand is like this: https://imgur.com/a/KTVudC3, and there is no offsetX, Y, or Z, do i need arm.rotationPointSOMETHING to move the hand wherever i want?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.