Jump to content

[Solved]Can't Install forge src!(1.6.2)

Recommended Posts

So I'm using "minecraftforge-src-1.6.2-" and every time I run the install.cmd I get this error:


================ Forge ModLoader Setup Start ===================

Checking MCP zip (may take time to download)

Downloaded mcp8.04.zip

Extracting MCP to 'C:\Users\─ύΉ▐Ϊ±ύ≥\Desktop\mod\forge\mcp'

Setting up MCP

Patching commands.py

patching file commands.py

Commands patch applied successfully

Copying FML conf

Creating Repackaged data

Creating re-packaged srg

Creating re-packaged exc

Creating re-packaged MCP patches

Fixing MCP Workspace

Traceback (most recent call last):

  File "install.py", line 76, in <module>

decompile=options.decompile, gen_conf=False)

  File "install.py", line 17, in fml_main


  File "C:\Users\─ύΉ▐Ϊ±ύ≥\Desktop\mod\forge\fml\fml.py", line 1013, in decompile


pre_decompile(mcp_dir, fml_dir, disable_assets=disable_assets)

  File "C:\Users\─ύΉ▐Ϊ±ύ≥\Desktop\mod\forge\fml\fml.py", line 1061, in pre_decom


download_minecraft(mcp_dir, fml_dir)

  File "C:\Users\─ύΉ▐Ϊ±ύ≥\Desktop\mod\forge\fml\fml.py", line 1125, in download_


failed = download_libraries(mcp_dir, version_json['libraries'], mc_info['nat

ives_dir']) or failed

  File "C:\Users\─ύΉ▐Ϊ±ύ≥\Desktop\mod\forge\fml\fml.py", line 1180, in download_


file_path = os.path.join(lib_dir, os.sep.join(path), file_name)

  File "ntpath.pyc", line 108, in join

UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 9: ordinal

not in range(128)



I'm using Windows 7 Home Premium 64bit. Any help on how to make the installer work? or can I install it manually somehow?


Edit: I really need help.... I don't know what is wrong with my system... everything was working fine before (I'm using forge for a lot of time without a single problem!). Now I even get an error with MCEdit, I will post it because they look similar and it may help


Running in portable mode. MCEdit-schematics and mcedit.ini are stored alongside


Minecraft_Server.jar storage initialized.

Each server is stored in a subdirectory of C:\Users\Δημήτρης\Desktop\Mcedit\Serv

erJarStorage named with the server's version number

Cached servers:  []

Loading texture pack Default...

Loading textures from minecraft.jar

IOError(2, 'No such file or directory') while reading terrain.png from  u'C:\\Us



Couldn't get font (u'C:\\Users\\\u0394\u03b7\u03bc\u03ae\u03c4\u03c1\u03b7\u03c2

\\Desktop\\Mcedit\\MCEdit-0.1.6.win-amd64\\fonts\\Vera.ttf', 15), using sysfont

Couldn't get font (u'C:\\Users\\\u0394\u03b7\u03bc\u03ae\u03c4\u03c1\u03b7\u03c2

\\Desktop\\Mcedit\\MCEdit-0.1.6.win-amd64\\fonts\\VeraBd.ttf', 17), using sysfon


Couldn't get font (u'C:\\Users\\\u0394\u03b7\u03bc\u03ae\u03c4\u03c1\u03b7\u03c2

\\Desktop\\Mcedit\\MCEdit-0.1.6.win-amd64\\fonts\\Vera.ttf', 10), using sysfont

Couldn't get font (u'C:\\Users\\\u0394\u03b7\u03bc\u03ae\u03c4\u03c1\u03b7\u03c2

\\Desktop\\Mcedit\\MCEdit-0.1.6.win-amd64\\fonts\\VeraBd.ttf', 18), using sysfon


[ERROR][mcedit.py:1018]:An unhandled error occured.

Traceback (most recent call last):

  File "mcedit.py", line 1014, in main

  File "mcedit.py", line 929, in main

  File "esky\__init__.pyo", line 721, in auto_update

  File "esky\__init__.pyo", line 769, in _do_auto_update

  File "esky\__init__.pyo", line 811, in fetch_version

  File "esky\finder.pyo", line 80, in fetch_version

  File "esky\finder.pyo", line 230, in fetch_version_iter

  File "esky\finder.pyo", line 332, in _prepare_version

  File "esky\patch.pyo", line 299, in apply_patch

  File "esky\patch.pyo", line 598, in patch

  File "esky\patch.pyo", line 678, in _do_VERIFY_MD5

  File "esky\patch.pyo", line 431, in calculate_patch_digest

TypeError: 'NoneType' object is not iterable

UnicodeDecodeError('ascii', 'C:\\Users\\\xc4\xe7\xec\xde\xf4\xf1\xe7\xf2', 9, 10

, 'ordinal not in range(128)') while scrubbing user directories from crash log!

Error not reported.

Error while reporting crash:  UnicodeDecodeError('ascii', 'C:\\Users\\\xc4\xe7\x

ec\xde\xf4\xf1\xe7\xf2', 9, 10, 'ordinal not in range(128)')

[ERROR][mcedit.py:1020]:MCEdit version 0.1.6

Press RETURN or close this window to dismiss.



Link to comment
Share on other sites

Your user account screws up a lot of things because it's non-standard ascii and can't be decoded by utf-8.

So, move all things out of your user directory.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.