Jump to content

Error when setting up mac server 1.17.1


wee_ag

Recommended Posts

After downloading and installing a forge server on my mac (Intel chip, OS X 10.15.7) I try to open run.sh but get the following "Error: could not open 'user_jvm_args.txt'"

I have installed Java 16 as I've seen others say this is an issue. I have also used chmod a+x on both run.sh and user_jvm_args.txt

Edited by wee_ag
added more info
Link to comment
Share on other sites

Thanks for the reply!

Here's my output:

Quote

Last login: Mon Nov  1 12:39:42 on ttys000

wee@iMac ~ % /Users/wee/Forgeserver17/run.sh ; exit;

Error: could not open `user_jvm_args.txt'

 

[Process completed]

And here's java -version

Quote

Last login: Mon Nov  1 12:41:00 on ttys001

wee@iMac ~ % java -version

java version "16.0.2" 2021-07-20

Java(TM) SE Runtime Environment (build 16.0.2+7-67)

Java HotSpot(TM) 64-Bit Server VM (build 16.0.2+7-67, mixed mode, sharing)

 

Link to comment
Share on other sites

Ok, just tried what I think you're saying... still getting the same error

Quote

Last login: Mon Nov  1 13:49:47 on ttys000

wee@iMac ~ % cd /Users/wee/minecraft\ server 

wee@iMac minecraft server % /Users/wee/Forgeserver17/run.sh 

Error: could not open `user_jvm_args.txt'

wee@iMac minecraft server % 

I feel like I'm missing something simple.

Here's the list of files where run.sh is (Forgerserver17 folder):

Libraries folder
run.bat
run.sh
user_jvm_args.txt

Edited by wee_ag
Link to comment
Share on other sites

  • 8 months later...

OK with time I have a solution. I am using MacOS Catalina 10.15.7 I am also using Forge Server 19.1

chmod 755 /path to file/run.sh

cd /path to file/

file being run.sh

edit the file user_jvm_args.txt to set the memory usage for the server

e.g I add the lines

-Xms3G
-Xmx4G

./run.sh

This will run the server in gui mode

Not ideal as you would need to cd to the server path every time you run it.

So like the servers from 16 down I modified the start.command file as below (make sure it is executable, chmod 755)

#!/bin/bash
cd "$(dirname "$0")"
exec ./run.sh

Then you can alias start.command and have it on the desktop.

 

Edited by PM3747
Link to comment
Share on other sites

  • 7 months later...
  • 10 months later...

Please read the FAQ

And start your own thread for your problem instead of hijacking other peoples questions.

 

But most likely your problem can be solved by one of these solutions:

https://forums.minecraftforge.net/topic/122698-forge-1182-server-wont-load-up-with-dawncraft/?do=findComment&comment=533997

Edited by warjort

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.