Jump to content

Wrong java (JDK version) in gradle and problems with building


Recommended Posts

Hey everyone!
I Try to modding on 1.18.2 - Forge MDK 1.18.2 - 40.0.52. Modding on IntelliJ IDEA
I Opened this MDK in IntelliJ, and saw some problems


1) Caused by: java.util.zip.ZipException: zip END header not found ( https://pastenow.ru/GOYIB )
2) https://pastenow.ru/dc218a519a81c436df52e5713fef572c

Okey, I checked java version and saw that
1) in IntelliJ is using JDK 17 (which is requred) ( https://pastenow.ru/GOYKU ) ( https://pastenow.ru/GOYLN )
2) ./gradlew --version  (JVM 1.8.0_322) ( https://pastenow.ru/GOYK9 )

and my questions

1) why in ./gradlew uses java 1.8?
2) how I can change ./gradlew java version
3) how I can solve another problems (on first and second screenshots)?

(PS I have experience in java on school level)
(PPS I checked another topic and did not see a similar problem [with java version])


Link to comment
Share on other sites

14 hours ago, diesieben07 said:

Change where JAVA_HOME points to.

Delete .gradle/caches/forge_gradle. This happens if you interrupt one of the ForgeGradle tasks

I Changed JAVA_HOME, but this do not solved ./gradlew --version
But i deleted JRE 8 and installed JRE17 = problem with --version disappeared

In my Linux I found it at /home/$USER$/.gradle/caches/forge_gradle/ and deleted it

I'll probably remember this

Thank you for help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • So, I try to make a katana, with katana and scabbard, is that possible to make 2 different models to be on player while he holding item? Katana in hands, and scabbard at belt. 
    • I created a server with the Pixelmon mod, it's fine and everything but a person enters and the server closes, I don't know how to explain it very well but I attach the detailed file of the error that happens to me https://mclo.gs/eSemvtq This error had not happened to me until now, so I don't understand very well why this happens, could you help me solve it?
    • When I create the server and log in it lets me play, but a person ends up joining and it sends me an error and the server closes The report says Exception in server tick Loop I put here what the console tells me because I honestly don't know how to explain it: https://mclo.gs/eSemvtq I use Forge mods and this has not happened to me until now 
    • Sorry I wasn't on this site for a few days. But anyways, if you just simply want to install forge to play with mods, you need to click on the installer option, thqat way, forge will be automatically installed to your device at the version you chose. Then you could just open Minecraft launcher to play on that version.
    • I've been putting together a modpack for a few weeks, and it's worked just fine. Until today, I logged onto my survival world and went exploring. As soon as I entered my boat the game froze and crashed. Now when I try to start the world, nothing loads and the game crashes. I tried creating a new world and the same thing happened when I tried to use a boat. Here's the latest crash report from the original world: If anyone knows how to fix the issue, I'd really appreciate the help, thanks.
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.