Jump to content

Errors in currently selected datapacks prevented the world from loading... EDIT: and more.....

Recommended Posts

Before I start to shower y'all with words, do note that I'm using 1.18.2 of Better Minecraft(Forge) on CurseForge with some included mods. NO OPTIFINE(due to errors I've previously dealt with and solved). And if y'all can help, please talk to me like I'm completely new cause I don't know any of this coding language.

The full error when trying to start a world is :

"Errors in currently selected datapacks prevented the world from loading. You can either try to load it with only the vanilla data pack ("safe mode") or go back to the title screen to manually fix it."

As you may already know, I've tried researching and following what some are telling me what I should do. Also, pressing "safe mode as one of the options does absolutely nothing.
I'm not so great at reading and understanding the issues through the debug logs but I've honestly had a ridiculous amount of issues with mods on Minecraft using Forge. I, honestly, haven't been able to play Minecraft since February with how many issues I've been having.
Yes, I've tried everything from a clean install of Java(Seven times within the past Four months), browsing through every mod in a modpack(even ones that have 200+ mods(Vahelsia 3 & ATM6)) and giving every possible dependency I can find, not even touching the pre-made modpacks(including or removing any mods)... Oh, that works.. Let me add....AppleSkin. Nope, game crashed with error code #1 and now there's 15+ errors in the log with so many dependencies required or 1.16 mods in a 1.18 modpack that's apparently included with the modpack... Why did the game launch the first time with those mods, you may ask? I have no clue.

Back on the main topic, what's happening with the modpack I'm struggling with right now. 

At first, my issue was along the line that ended off with Optifine. Only took 6 hours and a ridiculous amount of research to figure that one out. Yay! I can finally launch Minecraft without crashing. I was now having issues with starting a survival world. I don't remember what the error was but it went along the lines of telling me I need to look at the debug log or something and so I did. I then had to delete every single resource pack in the resource packs folder because the logs were telling me that they're all "Invalid", including ones that came with the modpack, or a folder that would automatically be installed called "graphics" which I'm guessing was needed for displaying the Minecraft logo and some other buttons because those disappeared after throwing that folder into my desktop.. Yes, the log told me specifically that the folder "graphics" was an invalid resource pack, as well as a Quark pack and some others.
Sir, yes sir! After deleting all my resource packs(not the resource pack folder itself ofc), now I'm having this pop up I'm having right now which is:
"Errors in currently selected datapacks prevented the world from loading. You can either try to load it with only the vanilla data pack ("safe mode") or go back to the title screen to manually fix it."

Here's the log I managed to save:


I put the resource packs back in nothing changes, still the "Errors in currently...."


EDIT: Eight hours later and I've decided to try out my luck on getting this modpack running, but to no avail.. Oh wait!! A new error message on top of the previous one I've already had😒:

"Download from https://piston-data.mojang.com/v1/objects/2e9a3e3107cca00d6bc9c97bf7d149cae163ef21/client.jar had invalid checksum! Expected: 2e9a3e3107cca00d6bc9c97bf7d149cae163ef21 got: 04292004f7145d1d991b8808d2976f9dc8db5cba" (DON'T CLICK ON LINK UNLESS YOU'RE OKAY WITH AN AUTOMATIC DOWNLOAD)

There's also a message below explaining exactly where I must place this .jar file:

"Downloaded https://piston-data.mojang.com/v1/objects/2e9a3e3107cca00d6bc9c97bf7d149cae163ef21/client.jar to C:\Users\A0001\curseforge\minecraft\Install\versions\forge-40.1.23\forge-40.1.23.jar"


I tried this, numerous times and several different ways and still the same error message. But look on the bright side, I'm still able to launch the game, not mentioning the fact I'm still receiving the same "Errors in currently selected datapacks.." etcetera etcetera.

Here's the most recent debug log with that new error:


How come there's this new error in the logs only about eight hours after previously trying?

Not sure if this helps any but this one error pops out like a sore thumb to me:

"Couldn't load tag minecraft:piglin_repellents as it is missing following references: nourished_nether:flint_and_quartz (from NourishedNetherV12.jar)"

The hell does that mean?

I swear, I just want to start a modded survival, chill out, work on a crazy Minecolonies base, and complete if not most, then all achievements since😒. I graduated high school and need something to do on my free time after work😩...

IF I'm able to receive any help with this then that'd be an absolute lifesaver! Remember, please talk to me like a beginner. I've modded for years, but never had as many issues as I've been having the past year so just never thought to learn how to understand the logs.


Also, unsure why the paste.ee links I've added created such small debug logs. I definitely copied all of it, all 500+ lines for both😕.

Edited by CrispyOBacon
Link to comment
Share on other sites

9 hours ago, Luis_ST said:

Problem with Pollen. Make sure you are using the latest version.
If the Mod is already up to date, report this bug to the Mod author.

Alright, I've tried updating "[Forge 1.18.2] Pollen 1.4.1" to the newest version, except it's already the newest version, but no effect


I've also looked at the dependencies of Pollen yet there's nothing in the list, except there's plenty of dependents including the modpack itself: Better Minecraft(Forge) which tells me I must include Pollen in order for the modpack to work properly... So I removed it temporarily... Game crashed immediately with an error in the logs stating:

"Missing mandatory dependencies: pollen"


Did a brand new install of [Forge 1.18.2] Pollen 1.4.1 and dropped it into the mods folder. Opened Minecraft. It launched successfully. Clicked Singleplayer, Create New World.... Oh, It's saying loading now!! Nevermind.. Same error "Errors in currently selected datapacks..."

Edited by CrispyOBacon
Adding more info
Link to comment
Share on other sites

Wait, here's the new log, figured out how to copy all of it(but is very time consuming copying every ten lines):



4 minutes ago, Luis_ST said:

Remove Lithium

also do not use magic performance mods

As for your request, I've checked though ought the whole mod list and I cant seem to find Lithium nor any magic performance mods

Link to comment
Share on other sites

10 minutes ago, CrispyOBacon said:

As for your request, I've checked though ought the whole mod list and I cant seem to find Lithium nor any magic performance mods

the mod is there me.jellysquid.mods.lithium.common.shapes.VoxelShapeSimpleCube

Link to comment
Share on other sites

If this helps any, The modpack would work perfectly fine before adding any additional mods until I've added the following:


Iron chests

Sophisticated Backpacks



Optifine(then deleted it)



There may have been a couple others but I don't remember. I've also added about resource packs which then, like I've stated in the beginning, I had to remove all resource packs, even ones for the Minecraft logo in the title screen cause they were all "Invalid".

Link to comment
Share on other sites

4 minutes ago, Luis_ST said:

could also be a problem with Radium

Now there's an insanely long list of errors after removing radium😬

but here's the short error:

The game crashed whilst rendering overlay Error: java.lang.NullPointerException: Cannot invoke "de.keksuccino.konkrete.config.Config.getOrDefault(String, Object)" because "de.keksuccino.drippyloadingscreen.DrippyLoadingScreen.config" is null

Edited by CrispyOBacon
Adding more info
Link to comment
Share on other sites

Alright, so, without touching the modpack at all ever since the the day before, the game now works with what seems to be no issues at all. Not sure what changed this time but I'm able to launch and even start a world.

Here's the log:



Like I've said before, I've never even touched the modpack ever since I've gotten rid of radium and the game was having issues the day before🤔.

About all I've done was try creating a 1.12.2 RlCraft modpack and adding about 60 mods to it to make it a little better for me(including all it's dependencies, etc.). I even managed to add Optifine and shaders and the game ran well over 80fps🤷‍♂️, absolutely no issues at all besides the fact Forge takes almost 5-8 minutes of loading in the title screen USING AN M.2 SSD😑


Thanks a lot though man! If you see any hidden issues that I should probably know in the debug log then that'd be great if you're able to lmk.


Thanks again and if I come up with new issues with this modpack then I'll be back, which probably'll be soon😅


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.