Jump to content

Weird mob and player movement lag, with 20 tps high fps.


Recommended Posts

Hey y'all, I made a 1.12.2 Minecraft Forge server (for 5 people including me with the average online being 3)  a week ago and we've all been experiencing this really odd lag specifically with mobs/players and their movement. I've made a good amount of servers with spigot/paper/vanilla etc, but, I haven't experienced this. I also tried for a few days looking at config files, and looking online without any luck. The lag/choppiness is almost as if the mobs and players had a capped refresh rate of 2 fps, as the movement updates every 500 milliseconds relatively consistently. The problem is mobs like skeletons become frustrating to fight due to them freezing and then unfreezing to be in a different spot and have already shot you with an arrow, which I can't imagine fighting the ender dragon or a wither like this.
The server has never been below 20 tps every time I check with /forge tps, it's running on a virtual machine Ubuntu 20.04 on a dedicated server in my home. It has a R5 1500X at 4Ghz (rock stable, no issues there), 16GB of 2400mhz ram, and speedtest results is 1 gigabit upload and download with 0-1 ms of ping on average with ethernet. Essentially something that shouldn't have issues running a new lightly modded server.
On the virtual machine it has 3 cores, and 6 gigs allocated, which never gets fully utilized tbh, especially the ram. The server uses about 500mb average with a few players in it which is odd being so low. I would occasionally get "Running behind!" messages, usually upon startup but, otherwise not much. The gameplay on the server for everyone including me is always smooth, responsive, and not laggy.

Here's the mod list:
-AI Improvements (tried running server without mod, and with it just disabled in config with same results)
-Charset Audio
-Charset Lib
-Fast Leaf Decay
-Galacticraft Core
-Galacticraft Planets
-Micdoodle Core
-Just Enough Items
-Journey Map
-Level Up! Reloaded

The Forge version everyone is using is I also added Optifine to my client with nothing changing with mobs/players.

I hope this was in the correct sub, and if anyone wants to know anything more, see any logs, or see clips of what's happening just let me know! Thanks.

Edited by Galactic-_-Rebel
Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.