Jump to content

Won't let me install forge


Recommended Posts

Every time I try installing forge, It opens a page saying

url: adfoc.us

"This page isn’t working right now

adfoc.us redirected you too many times.

To fix this issue, try clearing your cookies.


I tried clearing everything. I even downloaded a new browser to make sure that wasn't the problem. Made sure ad block was off, and it still says that everytime I try installing it. I tried installing different versions too, but ran into the same problem. I know it's supposed to pull up an ad then let me download after clicking, but it goes straight to that page from the download button.

Link to comment
Share on other sites

6 hours ago, ClumsyCat said:

I even downloaded a new browser to make sure that wasn't the problem

Which browser? I'm just curious, since this issues seems to be a chrome issue, and if you got another browser that is based on chrome, it may have the same issue. I'm able to download forge just fine using Firefox.

If you search around on here, Lex posted a possible fix, but from what I've seen it does not work for everyone.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.