Jump to content

Java GUI doesn't work at all and I found out because of Forge


Recommended Posts

I have tried to reinstall Java multiple times, I've tried installing it on a different drive, I've tried using Jarfix, I've tried manually fixing the path of Java, I've tried most recommended fixes including creating a batch file and running it through that, I've tried -nogui. No matter what I do, .jar files will not launch on their own (they used to work fine but tbh I haven't tried in years, I think I know the root of the issue but it would involve a fresh install of Windows to fix so I'm hoping there is another way)


JVM info: Oracle Corporation - 19.0.1 - 19.0.1+10-21
Found java version 19.0.1
Exception in thread "main" 
    at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:166)
    at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:147)
Caused by: java.lang.IllegalArgumentException: 40 incompatible with Text-specific LCD contrast key
    at java.desktop/java.awt.RenderingHints.put(RenderingHints.java:1133)
    at java.desktop/sun.awt.windows.WDesktopProperties.getDesktopAAHints(WDesktopProperties.java:307)
    at java.desktop/sun.awt.windows.WToolkit.getDesktopAAHints(WToolkit.java:1087)
    at java.desktop/sun.awt.SunToolkit.getDesktopFontHints(SunToolkit.java:1805)
    at java.desktop/sun.awt.windows.WDesktopProperties.getProperties(WDesktopProperties.java:244)
    at java.desktop/sun.awt.windows.WToolkit.lazilyInitWProps(WToolkit.java:963)
    at java.desktop/sun.awt.windows.WToolkit.lazilyLoadDesktopProperty(WToolkit.java:952)
    at java.desktop/java.awt.Toolkit.getDesktopProperty(Toolkit.java:1554)
    at java.desktop/javax.swing.UIManager.<clinit>(UIManager.java:388)
    ... 2 more

This shows instantly when trying to run any .jar file with a batch file. Clearly something is causing it not to work, I've googled most of these exceptions and such without any luck, maybe someone here can see why .jar files just won't work no matter what.

I have Java SE 8 and JDK 19.

Link to comment
Share on other sites

Looks like there is something broken in your gui configuration?


All I could find searching google is this old bug: https://www.rarst.net/software/cleartype-install4j-java-bug/

where an application had set the font size to an non-integer number.


You would likely get more help contacting your java vendor.


JVM info: Oracle Corporation - 19.0.1 - 19.0.1+10-21



If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

You absolute legend... I can't believe it was ClearType... WOW. I've been around computers most of my life, I'm the "tech expert" of the family and I usually solve most problems on a software and hardware level but this, this was something I just couldn't figure out... IT WAS MY CLEARTYPE SETTINGS... That's just insane haha thank you so much though, all I did was run Better ClearType Tuner and change my Contrast from 400 to 1000. (It does have 1000-2200 in a box underneath as I'm guessing a recommendation) I went with 1000 just to see and bingo, .jar files immediately open as normal. Still can't believe it was the ClearType settings lol

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.