Jump to content

Minecraft exit code 1 error on mc forge above 1.18.2


Black_Darte

Recommended Posts

So I hapend to have a problem on one of my secondary computer with forge 1.19.2 here is the log exit code 1 (i know it say some mods are missing but are in fact present) 

[12janv.2023 21:11:45.222] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, Black_Darte, --version, 1.19.2-forge-43.2.0, --gameDir, C:\Users\Baptiste\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Baptiste\AppData\Roaming\.minecraft\assets, --assetIndex, 1.19, --uuid, 33f295048bdb4a04aa6bf0981fb6420c, --accessToken, ????????, --clientId, NTI4ZGIxZmUtNWI4MC00ZmY1LWE1MzYtNjRhNjdlNjVhMDE5, --xuid, 2535459343329119, --userType, msa, --versionType, release, --launchTarget, forgeclient, --fml.forgeVersion, 43.2.0, --fml.mcVersion, 1.19.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20220805.130853]
[12janv.2023 21:11:45.240] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.8+10.0.8+main.0ef7e830 starting: java version 17.0.3 by Microsoft; OS Windows 10 arch amd64 version 10.0
[12janv.2023 21:11:46.304] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/C:/Users/Baptiste/AppData/Roaming/.minecraft/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%2391!/ Service=ModLauncher Env=CLIENT
[12janv.2023 21:11:47.281] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\Baptiste\AppData\Roaming\.minecraft\libraries\net\minecraftforge\fmlcore\1.19.2-43.2.0\fmlcore-1.19.2-43.2.0.jar is missing mods.toml file
[12janv.2023 21:11:47.289] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\Baptiste\AppData\Roaming\.minecraft\libraries\net\minecraftforge\javafmllanguage\1.19.2-43.2.0\javafmllanguage-1.19.2-43.2.0.jar is missing mods.toml file
[12janv.2023 21:11:47.297] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\Baptiste\AppData\Roaming\.minecraft\libraries\net\minecraftforge\lowcodelanguage\1.19.2-43.2.0\lowcodelanguage-1.19.2-43.2.0.jar is missing mods.toml file
[12janv.2023 21:11:47.306] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\Baptiste\AppData\Roaming\.minecraft\libraries\net\minecraftforge\mclanguage\1.19.2-43.2.0\mclanguage-1.19.2-43.2.0.jar is missing mods.toml file
[12janv.2023 21:11:47.481] [main/INFO] [net.minecraftforge.fml.loading.moddiscovery.JarInJarDependencyLocator/]: No dependencies to load found. Skipping!
[12janv.2023 21:11:47.658] [main/ERROR] [net.minecraftforge.fml.loading.ModSorter/LOADING]: Missing or unsupported mandatory dependencies:
    Mod ID: 'badpackets', Requested by: 'wthit', Expected range: '[0.1.2,)', Actual version: '[MISSING]'
    Mod ID: 'balm', Requested by: 'waystones', Expected range: '[4.1.0,)', Actual version: '[MISSING]'
    Mod ID: 'autoreglib', Requested by: 'quark', Expected range: '[1.8-54,)', Actual version: '[MISSING]'
    Mod ID: 'blueprint', Requested by: 'savage_and_ravage', Expected range: '[6.0.5,)', Actual version: '[MISSING]'
    Mod ID: 'puzzleslib', Requested by: 'visualworkbench', Expected range: '[4.2.1,)', Actual version: '[MISSING]'
    Mod ID: 'moonlight', Requested by: 'supplementaries', Expected range: '[1.19.2-2.1.21,]', Actual version: '[MISSING]'
[12janv.2023 21:11:50.603] [main/INFO] [mixin/]: Compatibility level set to JAVA_17
[12janv.2023 21:11:50.750] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target 'forgeclient' with arguments [--version, 1.19.2-forge-43.2.0, --gameDir, C:\Users\Baptiste\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Baptiste\AppData\Roaming\.minecraft\assets, --uuid, 33f295048bdb4a04aa6bf0981fb6420c, --username, Black_Darte, --assetIndex, 1.19, --accessToken, ????????, --clientId, NTI4ZGIxZmUtNWI4MC00ZmY1LWE1MzYtNjRhNjdlNjVhMDE5, --xuid, 2535459343329119, --userType, msa, --versionType, release]
[12janv.2023 21:11:51.043] [main/INFO] [Rubidium/]: Loaded configuration file for Rubidium: 29 options available, 0 override(s) found
[12janv.2023 21:11:51.069] [main/WARN] [mixin/]: Reference map 'yungsextras.refmap.json' for yungsextras.mixins.json could not be read. If this is a development environment you can ignore this message
[12janv.2023 21:11:51.073] [main/WARN] [mixin/]: Reference map 'yungsextras.refmap.json' for yungsextras_forge.mixins.json could not be read. If this is a development environment you can ignore this message
[12janv.2023 21:11:52.957] [main/WARN] [mixin/]: Error loading class: vectorwing/farmersdelight/common/block/TomatoVineBlock (java.lang.ClassNotFoundException: vectorwing.farmersdelight.common.block.TomatoVineBlock)
[12janv.2023 21:11:52.958] [main/WARN] [mixin/]: @Mixin target vectorwing.farmersdelight.common.block.TomatoVineBlock was not found supplementaries.mixins.json:CompatFarmersDelightMixin
[12janv.2023 21:11:53.301] [main/WARN] [mixin/]: Error loading class: net/mehvahdjukaar/moonlight/api/block/ILightable$FireSourceType (java.lang.ClassNotFoundException: net.mehvahdjukaar.moonlight.api.block.ILightable$FireSourceType)
[12janv.2023 21:11:53.308] [main/WARN] [mixin/]: Error loading class: net/mehvahdjukaar/moonlight/api/block/WaterBlock (java.lang.ClassNotFoundException: net.mehvahdjukaar.moonlight.api.block.WaterBlock)
[12janv.2023 21:11:53.309] [main/ERROR] [mixin/]: supplementaries.mixins.json:SelfPlanterMixin: Super class 'net.minecraft.world.level.block.Block' of SelfPlanterMixin was not found in the hierarchy of target class 'net/mehvahdjukaar/supplementaries/common/block/blocks/PlanterBlock'
org.spongepowered.asm.mixin.transformer.throwables.InvalidMixinException: Super class 'net.minecraft.world.level.block.Block' of SelfPlanterMixin was not found in the hierarchy of target class 'net/mehvahdjukaar/supplementaries/common/block/blocks/PlanterBlock'
    at org.spongepowered.asm.mixin.transformer.MixinInfo$SubType$Standard.validate(MixinInfo.java:593) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinInfo$State.validate(MixinInfo.java:327) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinInfo.validate(MixinInfo.java:913) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinConfig.postInitialise(MixinConfig.java:801) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinProcessor.prepareConfigs(MixinProcessor.java:567) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinProcessor.select(MixinProcessor.java:462) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinProcessor.checkSelect(MixinProcessor.java:438) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinProcessor.applyMixins(MixinProcessor.java:290) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.mixin.transformer.MixinTransformer.transformClass(MixinTransformer.java:250) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.service.modlauncher.MixinTransformationHandler.processClass(MixinTransformationHandler.java:131) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at org.spongepowered.asm.launch.MixinLaunchPluginLegacy.processClass(MixinLaunchPluginLegacy.java:131) ~[mixin-0.8.5.jar:0.8.5+Jenkins-b310.git-155314e6e91465dad727e621a569906a410cd6f4]
    at cpw.mods.modlauncher.serviceapi.ILaunchPluginService.processClassWithFlags(ILaunchPluginService.java:156) ~[modlauncher-10.0.8.jar:10.0.8+10.0.8+main.0ef7e830]
    at cpw.mods.modlauncher.LaunchPluginHandler.offerClassNodeToPlugins(LaunchPluginHandler.java:88) ~[modlauncher-10.0.8.jar:?]
    at cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:120) ~[modlauncher-10.0.8.jar:?]
    at cpw.mods.modlauncher.TransformingClassLoader.maybeTransformClassBytes(TransformingClassLoader.java:50) ~[modlauncher-10.0.8.jar:?]
    at cpw.mods.cl.ModuleClassLoader.readerToClass(ModuleClassLoader.java:113) ~[securejarhandler-2.1.4.jar:?]
    at cpw.mods.cl.ModuleClassLoader.lambda$findClass$15(ModuleClassLoader.java:219) ~[securejarhandler-2.1.4.jar:?]
    at cpw.mods.cl.ModuleClassLoader.loadFromModule(ModuleClassLoader.java:229) ~[securejarhandler-2.1.4.jar:?]
    at cpw.mods.cl.ModuleClassLoader.findClass(ModuleClassLoader.java:219) ~[securejarhandler-2.1.4.jar:?]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:632) ~[?:?]
    at java.lang.Class.forName(Class.java:545) ~[?:?]
    at net.minecraftforge.fml.loading.targets.CommonClientLaunchHandler.lambda$launchService$0(CommonClientLaunchHandler.java:27) ~[fmlloader-1.19.2-43.2.0.jar%2395!/:?]
    at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:30) [modlauncher-10.0.8.jar%2382!/:?]
    at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) [modlauncher-10.0.8.jar%2382!/:?]
    at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71) [modlauncher-10.0.8.jar%2382!/:?]
    at cpw.mods.modlauncher.Launcher.run(Launcher.java:106) [modlauncher-10.0.8.jar%2382!/:?]
    at cpw.mods.modlauncher.Launcher.main(Launcher.java:77) [modlauncher-10.0.8.jar%2382!/:?]
    at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26) [modlauncher-10.0.8.jar%2382!/:?]
    at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23) [modlauncher-10.0.8.jar%2382!/:?]
    at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:141) [bootstraplauncher-1.1.2.jar:?]
[12janv.2023 21:11:55.998] [pool-3-thread-1/WARN] [mixin/]: Error loading class: net/mehvahdjukaar/moonlight/api/block/WaterBlock (java.lang.ClassNotFoundException: net.mehvahdjukaar.moonlight.api.block.WaterBlock)
[12janv.2023 21:11:57.302] [pool-3-thread-1/WARN] [mixin/]: Error loading class: fuzs/puzzleslib/init/RegistryReference (java.lang.ClassNotFoundException: fuzs.puzzleslib.init.RegistryReference)
 

Link to comment
Share on other sites

Quote

[12janv.2023 21:11:47.658] [main/ERROR] [net.minecraftforge.fml.loading.ModSorter/LOADING]: Missing or unsupported mandatory dependencies:
    Mod ID: 'badpackets', Requested by: 'wthit', Expected range: '[0.1.2,)', Actual version: '[MISSING]'
    Mod ID: 'balm', Requested by: 'waystones', Expected range: '[4.1.0,)', Actual version: '[MISSING]'
    Mod ID: 'autoreglib', Requested by: 'quark', Expected range: '[1.8-54,)', Actual version: '[MISSING]'
    Mod ID: 'blueprint', Requested by: 'savage_and_ravage', Expected range: '[6.0.5,)', Actual version: '[MISSING]'
    Mod ID: 'puzzleslib', Requested by: 'visualworkbench', Expected range: '[4.2.1,)', Actual version: '[MISSING]'
    Mod ID: 'moonlight', Requested by: 'supplementaries', Expected range: '[1.19.2-2.1.21,]', Actual version: '[MISSING]'

When you download mods, check their mod pages for to see what other mods they need.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.