Jump to content

Exception in thread "main": zip END header not found


Recommended Posts

Quote

Exception in thread "main" java.io.UncheckedIOException: java.util.zip.ZipException: zip END header not found

Looks like one of your mods is corrupted. Probably because it didn't finish downloading properly?

The error message does not say which mod.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

I tried removing every single mod from the mods folder 1 by 1, found the mod that (i thought) was causing the problem, reinstalled it, and put them all back in the mods folder.

I got the same error.

What should i do now? (do i have to reinstall every mod again individually?)

Link to comment
Share on other sites

Try it without any mods.

If you still get the problem without any mods then the problem is with your forge installation.

Try reinstalling forge. If you are using a launcher that installs forge for you, you need to ask whoever provides the launcher.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Posted (edited)

Good news and bad news.

Good news: I found the issue. I was trying the mods 1 by 1 and there were ~20 broken mods, now all fixed.

Bad news: I started the server with all the (supposedly) working mods, and it gave me this error: https://pastebin.com/zSv01x9A

Can anyone help please?

Edited by Pengy_yay
typo
Link to comment
Share on other sites

Quote

[09:24:46] [pool-2-thread-1/ERROR] [ne.mi.fm.lo.mo.BackgroundScanHandler/SCAN]: An error occurred scanning file Mod File: C:\Users\cross\Desktop\server\mods\create_enchantment_industry-1.18.2-for-create-0.5.0.e-1.1.6.jar

java.util.concurrent.CompletionException: java.io.UncheckedIOException: java.util.zip.ZipException: too many length or distance symbols

It still says one of your mod files is corrupted/broken.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

thanks for all your help so far!

I've just come across an error with Terrablender which doesn't seem to be fixable by reinstalling it. I tried reinstalling 1.2.0.126 then when that didn't work, tried 1.2.0.101.

Perhaps it's an incompatibility with another mod?

Here's the log: https://pastebin.com/Qw9F1wYJ

Thank you in advance for your help.

Link to comment
Share on other sites

Quote

Mod File: /C:/Users/cross/Desktop/server/mods/TerraBlender-forge-1.18.2-1.2.0.126.jar

Failure message: TerraBlender (terrablender) has failed to load correctly

java.lang.ExceptionInInitializerError: null

Mod Version: 1.2.0.126

Mod Issue URL: https://github.com/Glitchfiend/TerraBlender/issues

Exception message: com.electronwill.nightconfig.core.io.ParsingException: Not enough data available

This error says there is something wrong with the terrablender configuration file.

The error does not say what the file is called but it will be in the config folder.

If you don't have a backup of the file, you can delete it and it should be recreated with default values.

You can use the link shown if you can't get terrablender to work.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.