Jump to content

1.18.2 For Some Reason my pack is having datapack errors

Recommended Posts

Backstory: So I was creating this pack and a week ago it had errors, it wouldnt start up for some reason so i had to remove a bunch of mods and i finally did and fixed it to where it actually launches. But today and yesterday it started not wanting to work by not allowing me to create worlds because of datapack issues I have no clue why but it is a problem I have now. It is a problem since even without the datapacks for epic fight in the pack it wasn't working due to the same error, I tried fixing it by deleting worlds and files and transporting them to a new but it just really wasnt working and I need help plz

Debug: https://gist.github.com/GSharkGamer/e47c2b669ee5d7ed94e4414e817843c0

Normal Log: https://gist.github.com/GSharkGamer/39f6e8e4c53655c29462a73796d510b0 

Link to comment
Share on other sites

The first error in your log is:


[17May2023 10:22:06.328] [Render thread/ERROR] [net.minecraftforge.fml.javafmlmod.FMLModContainer/]: Exception caught during firing event: yesman/epicfight/api/animation/property/Property$AttackPhaseProperty

Index: 1 Listeners: 0: NORMAL 1: net.minecraftforge.eventbus.EventBus$$Lambda$4119/0x0000000800cef860@69dca59d 2: ASM: class reascer.efdg.gameasset.EFSkills registerSkills(Lyesman/epicfight/api/forgeevent/SkillRegistryEvent;)V

java.lang.NoClassDefFoundError: yesman/epicfight/api/animation/property/Property$AttackPhaseProperty

at TRANSFORMER/[email protected]/reascer.efdg.gameasset.EFSkills.registerSkills(EFSkills.java:26)

which suggests some incompability between the efdg mod and the epicfight mod.


There are two errors at the end of the log:


[17May2023 10:22:51.457] [Render thread/ERROR] [Reputation/]: 'Duplicate key entity.minecraft.pig (attempted merging values mods.thecomputerizer.reputation.common.ai.ServerTrackers$Data@f44b408 and mods.thecomputerizer.reputation.common.ai.ServerTrackers$Data@ca9b2c)' java.lang.IllegalStateException: Duplicate key entity.minecraft.pig (attempted merging values mods.thecomputerizer.reputation.common.ai.ServerTrackers$Data@f44b408 and mods.thecomputerizer.reputation.common.ai.ServerTrackers$Data@ca9b2c)

-- snip --

at mods.thecomputerizer.reputation.common.ai.ServerTrackers.parseChatIcons(ServerTrackers.java:36) ~[Reputation-1.18-0.9.9.jar%23188!/:1.18-0.9.9]

and the crash:


[17May2023 10:22:51.460] [Render thread/WARN] [net.minecraft.client.Minecraft/]: Failed to load datapacks, can't proceed with server load

-- snip --

Caused by: java.lang.RuntimeException: Failed to read faction data!

at mods.thecomputerizer.reputation.util.FactionListener.apply(FactionListener.java:87) ~[Reputation-1.18-0.9.9.jar%23188!/:1.18-0.9.9]


i.e. some issue with the faction data for the reputation mod

minecraft:pig is usually a sign that there is a reference to an entity that doesn't exist.

Maybe you uninstalled the mod for whatever entity is missing?


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.