Jump to content

1.18.2 Server Crash


Provoda22

Recommended Posts

Hello. I have a problem with the server. Of course, I'm not very good at forge. I'm not very good with errors, so I'm asking for help. There is an assembly on the server. Everything was fine for four days. But one of us found, as I understand it, a chunk that couldn't load something. Please help me to find the error

 

Crash-log: https://pastebin.com/sFt57Tmq

Link to comment
Share on other sites

Quote

java.lang.NullPointerException: Cannot read field "f_46443_" because "this.f_58857_" is null

at com.simibubi.create.content.contraptions.base.GeneratingKineticTileEntity.updateGeneratedRotation(GeneratingKineticTileEntity.java:95) ~[create-1.18.2-0.5.0.i.jar%2383!/:0.5.0.i] {re:classloading}

at java.util.Optional.ifPresent(Optional.java:178) ~[?:?] {re:mixin}

at com.simibubi.create.foundation.block.ITE.withTileEntityDo(ITE.java:29) ~[create-1.18.2-0.5.0.i.jar%2383!/:0.5.0.i] {re:classloading}

at com.simibubi.create.content.contraptions.components.waterwheel.WaterWheelBlock.updateWheelSpeed(WaterWheelBlock.java:144) ~[create-1.18.2-0.5.0.i.jar%2383!/:0.5.0.i] {re:classloading}

-- snip --

at com.telepathicgrunt.repurposedstructures.world.features.NbtDungeon.m_142674_(NbtDungeon.java:153)~[repurposed_structures_forge-5.1.14+1.18.2.jar%23174!/:5.1.14+1.18.2] {re:classloading}

Looks like some issue with a create water wheel.

The issue appears to happen when repurposed structures is generating a structure?

Check you have the latest versions then contact the mod authors.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Quote

[23May2023 08:22:42.364] [main/ERROR] [net.minecraftforge.fml.loading.ModSorter/LOADING]: Missing or unsupported mandatory dependencies:

Mod ID: 'forge', Requested by: 'create', Expected range: '[40.2.4,)', Actual version: '40.2.1'

That version of create wants a later version of forge.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.