Jump to content

[1.19.2] Issue with level.playsound()

Recommended Posts

For some reason, this code doesn't work:

public void GameStart() {
        System.out.println("Checking for server"); //(1)
        if (Value.server != null && Value.server.isRunning()) {
            System.out.println("Playing Sound"); //(2)
            Value.server.getPlayerList().getPlayers().forEach(p ->{
                double x = p.getX();
                double y = p.getY();
                double z = p.getZ();
                p.getLevel().playSound(p.getInventory().player, x, y, z, LoadSounds.GAME_START.get(), SoundSource.PLAYERS, 100f, 100f);


Both System.out.print are executed, but no sound is played.

I can play the sound using /playsound, so I don't think it is caused by a typo in the all the JSON file or in the name of those files.

Here are aditional file that may be needed:


public class LoadSounds {
    public static final DeferredRegister<SoundEvent> SOUND_EVENT = DeferredRegister.create(ForgeRegistries.SOUND_EVENTS, FlagsHunters.MODID);

    //Load Sound
    public static final RegistryObject<SoundEvent> GAME_START = soundEventRegistryObject("game_start");

    //Random Stuff
    private static RegistryObject<SoundEvent> soundEventRegistryObject(String name) {
        ResourceLocation id = new ResourceLocation(FlagsHunters.MODID, name);
        return SOUND_EVENT.register(name, () -> new SoundEvent(id));
    //Load function
    public static void Load(IEventBus eventBus) {


  "game_start": {
    "subtitle": "flagshunters.subtitle.game_start",
    "sounds": [ "flagshunters:game_start" ]

all the file and folder:


The minecraft version: 1.19.2

The forge version: 43.2.21

Edited by ____tbvns____
Forgot to add version
Link to comment
Share on other sites

  • ____tbvns____ changed the title to [1.19.2] Issue with level.playsound()

Please use the search function in future.

These playsound FAQs have been asked and answered sooo many times before.



You are doing 2.2 which assumes the sound has already been played by the client for any player passed in the first parameter. i.e. the player for ServerLevel.playsound is an "exclude this player".


Server Behavior: Plays the sound event to everyone nearby except the passed in player. Player can be null.


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

10 minutes ago, warjort said:

Please use the search function in future.

These playsound FAQs have been asked and answered sooo many times before.



You are doing 2.2 which assumes the sound has already been played by the client for any player passed in the first parameter. i.e. the player for ServerLevel.playsound is an "exclude this player".

Nice! thx you so much !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I have a structure, and sometimes several mobs spawn there. This is a boss and must spawn alone. Here is the code for spawning entities in the structure { "type": "minecraft:jigsaw", "start_pool": "egyptcraft:boss_pyramid/start_pool", "size": 5, "max_distance_from_center": 80, "biomes": "#egyptcraft:has_structure/boss_pyramid", "step": "surface_structures", "start_height": { "absolute": 0 }, "project_start_to_heightmap": "WORLD_SURFACE_WG", "use_expansion_hack": false, "spawn_overrides": { "monster": { "bounding_box": "full", "spawns": [ { "type": "egyptcraft:anubis", "maxCount": 1, "minCount": 1, "weight": 100 } ] } } } Maybe it's something else?
    • I have OreGenEvent.GenerateMinable event, I need to get a chance to spawn (generate) every ore that is processed in this event. Also e.getType().name().toString() is name this is the same block name by which it can be entered in the Block.getByID?  forge 1.12.2 59(recommended)
    • Hello everybody! Out of nowhere my minecraft doesn't allow me to play on forge 1.19.2 I tried to reinstall minecraft, doesn't have any mod right now on the forge version. Tried the newest version of forge, tried recommended version as well. I have the newest version of Java as well...   I dont know why it stopped working but it just stopped completly out of nowhere...   Thank you so much for your help guys ❤️
    • Hello, my world is crashing at 0% loaded and I don't know why. (Forge 43.2.14, 1.19.2) I have two worlds that I play on, and one works and the other doesn't, even with the same mod list. Here's the crash report: https://pastebin.com/AUbRwkGj
    • Minecraft 1.12.2 Very frustrating error. only ever occurs on one device. Started yesterday without prompting (maybe java updated or something?) Says things that have been imported actually arent when running client Reinstalled Intellij, cleared cache, cleaned and rebuilt gradle, redownloaded the entire file from git. Nothing works. (I believe I have the right plugins installed, dependencies OK, and am using corretto 1.8).   One thing I did for more of the below errors was just to explicitly import them, which was working up until this little guy who literally does not exist in forge to import. the class inhereting something inhereting it refers to import net.minecraftforge.registries.IForgeRegistryEntry.Impl, not net.minecraftforge.registries.IForgeRegistryEntry$Impl as the output implies. also I didn't even have to manually import these things for it to work on my other device. (which is just importing the minecraft package that contains them), but here I did have to just to get rid of a few errors--not even make anything work?? I dont know. (edited) here's the aforementioned "below error" (one of many like it): error: cannot access net.minecraftforge.registries.IForgeRegistryEntry.Impl public class BlockBase extends Block {        ^   class file for net.minecraftforge.registries.IForgeRegistryEntry$Impl not found Here's the class BlockBase:   package com.quantum.exodus.common.blocks; import com.quantum.exodus.ExodusMod; import net.minecraft.block.Block; import net.minecraft.block.material.Material; import net.minecraft.creativetab.CreativeTabs; import net.minecraft.item.Item; import net.minecraft.item.ItemBlock; import net.minecraftforge.registries.IForgeRegistryEntry.Impl; public class BlockBase extends Block { protected String name; public BlockBase(Material material, String name) { super(material); this.name = name; setTranslationKey(name); setRegistryName(name); } public void registerItemModel(Item itemBlock) { ExodusMod.proxy.registerItemRenderer(itemBlock, 0, name); } public Item createItemBlock() { return new ItemBlock(this).setRegistryName(getRegistryName()); } @Override public BlockBase setCreativeTab(CreativeTabs tab) { super.setCreativeTab(tab); return this; } }
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.