Jump to content

[Solved] 1.18.2 Minecraft crashes when using mod on server


Recommended Posts

Hello, Forge community! I am trying to make a custom creative tab with hidden items (like command blocks). When I using it on server I get "java.lang.AbstractMethodError: Missing implementation of resolved method 'abstract net.minecraft.world.item.ItemStack m_6976_()' of abstract class net.minecraft.world.item.CreativeModeTab." error. How can I fix this problem?

My code for creative tab:

public class OperatorCreativeTab {
    public static CreativeModeTab OPERATOR_TAB;

    public static void init() {
        OPERATOR_TAB = new CreativeModeTab("operator_tab") {
            public void fillItemList(NonNullList<ItemStack> list) {


                CompoundTag blockStateTag;
                ItemStack lightBlockWithNbt;

                for(int i = 15; i > -1; i--) {
                    blockStateTag = new CompoundTag();
                    blockStateTag.putInt("level", i);

                    lightBlockWithNbt = Items.LIGHT.getDefaultInstance();
                    lightBlockWithNbt.addTagElement("BlockStateTag", blockStateTag);


            public ItemStack makeIcon() {
                return Items.COMMAND_BLOCK.getDefaultInstance();

            public ItemStack getIconItem() {
                return Items.COMMAND_BLOCK.getDefaultInstance();


Edited by zimavi
Link to comment
Share on other sites

No code in mods should use @OnlyIn




If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

  • zimavi changed the title to [Solved] 1.18.2 Minecraft crashes when using mod on server

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.