Jump to content

Errors preventing runClient from starting game in Eclipse


Recommended Posts

I recently started trying to get back into modding after having last done anything in 1.15. Now when I try to run the client with Java8 I get this error

Exception in thread "main" java.lang.UnsupportedClassVersionError: cpw/mods/bootstraplauncher/BootstrapLauncher has been compiled by a more recent version of the Java Runtime (class file version 60.0), this version of the Java Runtime only recognizes class file versions up to 52.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at java.security.SecureClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.access$100(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

Doing some research I found I needed to update to at least Java16 to fix this error. But when I do that I now get this error

Exception in thread "main" java.lang.ExceptionInInitializerError
	at cpw.mods.niofs.union.UnionFileSystemProvider.newFileSystemInternal(UnionFileSystemProvider.java:115)
	at cpw.mods.niofs.union.UnionFileSystemProvider.newFileSystem(UnionFileSystemProvider.java:105)
	at cpw.mods.jarhandling.impl.Jar.<init>(Jar.java:84)
	at cpw.mods.jarhandling.SecureJar.from(SecureJar.java:70)
	at cpw.mods.jarhandling.SecureJar.from(SecureJar.java:66)
	at cpw.mods.jarhandling.SecureJar.from(SecureJar.java:58)
	at cpw.mods.jarhandling.SecureJar.from(SecureJar.java:50)
	at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:84)
Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make field static final java.lang.invoke.MethodHandles$Lookup java.lang.invoke.MethodHandles$Lookup.IMPL_LOOKUP accessible: module java.base does not "opens java.lang.invoke" to unnamed module @7d4793a8
	at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:354)
	at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:297)
	at java.base/java.lang.reflect.Field.checkCanSetAccessible(Field.java:178)
	at java.base/java.lang.reflect.Field.setAccessible(Field.java:172)
	at cpw.mods.niofs.union.UnionFileSystem.<clinit>(UnionFileSystem.java:52)
	... 8 more

I can execute runClient in command prompt without any issues, but not through Eclipse. I have tried this with both Java16 and Java17 and both give this same error. Does anyone have any suggestions to get this working correctly?

Link to comment
Share on other sites

I managed to get this fixed. I remembered reading someone saying that the command order matters when setting up. Previously I had set up by running gradlew eclipse then gradlew genEclipseRuns I swapped the order and that seems to have fixed my issue.

Edited by saxon564
Spelling Correction
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.