Jump to content

Creating core mod [Solved]


Recommended Posts



I found culegooner's lovely tutorial on how to make a core mod, which I've been following lately.



The tutorial is for 1.6.2, but I tried to use it for modding 1.6.4 instead and it worked perfectly fine within eclipse. But when obfuscated, it wouldn't work. There was no crash though, it simply didn't do anything and wouldn't show up in the mods list in minecraft. Interestingly enough the log says that forge actually finds it's "mcmod.info".


For testing, I downloaded culegooner's two example mods "creeper burn" and "explosion drops" and they work fine when I'm running minecraft 1.6.2. But as soon as I try to play 1.6.4 instead, they won't do anything.


What can be the significant difference between 1.6.2 and 1.6.4 when it comes to core mods, and why does it work within eclipse but not when obfuscated?


Ps: I know that I am supposed to avoid making a core mod as far as it's possible. But if I actually need to make a core mod one day, I would like to know how to.





Link to comment
Share on other sites

Hi this may not be a solution, but the reason the 1.6.2 mod doesn't work with 1.6.4 is the obfuscation changes with each Minecraft version, so to make his mod compatible with 1.6.4 you have to fix all the references to obfuscated code.  The mappings can be found in the MCP files he mentioned (*.cvs and *.srg I think?).  Core mods always have to be updated for every new Minecraft version (sv.class in 1.6.2 could be gj.class in 1.6.4).

Link to comment
Share on other sites

Thanks a lot for answers, sorry for being busy lately.


Yes, I have noted that the classes may change obfuscated names between minecraft updates. But that does not seem to be the problem... I have changed them to their right name, but still it won't work!


Although, I ran some test with the 1.6.2 version of the mod and noted that the mod doesn't show up in the mods list if it can't find which class to override. So now I am pretty convinced that the problem has to do with the mod not finding the obfuscated classes.


GotoLink, by "using searge names" you must mean adding some code so that minecraft with my mod can guess on its own which obfuscated class to override out from the searge name. Since I'm not a very experienced programmer, I think I'll have a hard time figuring out this piece of code by myself.


There must have been some path changes for the obfuscated classes since 1.6.4, or am I totally wrong?

Please keep replying!  :)


Link to comment
Share on other sites



Eeerrr... I know that by running reobfuscate_srg.bat, I will make mcp create folders and class files with their serge names. What of it? When running minecraft with a core mod outside Eclipse, the core mod cannot refer to someting like: "net.minecraft.entity.monster.EntityCreeper" or even "EntityCreeper", because the classes are recompiled. Instead the mod must refer to it's compiled name: "tf" ("te" in 1.6.2)

Please tell me I'm wrong if I am.


The mod "Creeperburn" has no problem overriding "te.class" in 1.6.2

Same mod seems to not be able to find and override "tf.class" in 1.6.4 (Of course it cannot override te.class)


Of course I know that core mods no longer goes into the "core mods" folder but the "mods" folder nowadays!


I am not sure I got your message right, it was quite short.

Link to comment
Share on other sites

Hahahaha! I solved the issue! (It was so basic I almost feed ashamed)


At the top of the CBFMLLoadingPlugin class there is a line that says:

@MCVersion(value = "1.6.2")


You must change it to 1.6.4, or else the mod will be ignored in 1.6.4


A little bit ashamed but very happy


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.