Jump to content

(Fixed) [1.20.1] Apply full armor effect doesn't work


Recommended Posts

I'm trying to apply effects to the emerald armor but it doesn't work, I read that the onArmorTick() method doesn't work anymore, but I tried with inventoryTick, onInventoryTick and onArmorTick but they don't apply the effect either, I don't know if I'm writing it wrong, so I need help to fix it.

This is the code in question:

public class ModArmorItem extends ArmorItem{

    private static final Map<ArmorMaterial, MobEffectInstance> MATERIAL_TO_EFFECT_MAP =
        (new ImmutableMap.Builder<ArmorMaterial, MobEffectInstance>())
            .put(ModArmorMaterials.EMERALD, new MobEffectInstance(
    public ModArmorItem(ArmorMaterial pMaterial, Type pType, Properties pProperties) {
        super(pMaterial, pType, pProperties);
    public void onArmorTick(ItemStack stack, Level world, Player player){
        if (!world.isClientSide()) {
            if (hasFullSuitOfArmorOn(player)) {

    private void evaluateArmorEffects(Player player) {
        for (Map.Entry<ArmorMaterial,MobEffectInstance> entry : MATERIAL_TO_EFFECT_MAP.entrySet()){
            ArmorMaterial mapArmorMaterial = entry.getKey();
            MobEffectInstance mapStatusEffect = entry.getValue();

            if (hasCorrectArmorOn(mapArmorMaterial, player)) {
                addStatusEffectForMaterial(player, mapArmorMaterial, mapStatusEffect);

    private void addStatusEffectForMaterial(Player player, ArmorMaterial mapArmorMaterial, MobEffectInstance mapStatusEffect) {
        boolean hasPlayerEffect = player.hasEffect(mapStatusEffect.getEffect());

        if (hasCorrectArmorOn(mapArmorMaterial, player) && !hasPlayerEffect) {
            player.addEffect(new MobEffectInstance(mapStatusEffect));

    private boolean hasCorrectArmorOn(ArmorMaterial material, Player player) {
        for (ItemStack armorStack : player.getInventory().armor){
            if (!(armorStack.getItem() instanceof ArmorItem)) {
                return false;

        ArmorItem helmet = ((ArmorItem)player.getInventory().getArmor(3).getItem());
        ArmorItem brestplace = ((ArmorItem)player.getInventory().getArmor(2).getItem());
        ArmorItem leggins = ((ArmorItem)player.getInventory().getArmor(1).getItem());
        ArmorItem boots = ((ArmorItem)player.getInventory().getArmor(0).getItem());

        return helmet.getMaterial() == material && brestplace.getMaterial() == material && leggins.getMaterial() == material && boots.getMaterial() == material;

    private boolean hasFullSuitOfArmorOn(Player player){
        ItemStack helmet = player.getInventory().getArmor(3);
        ItemStack breastplace = player.getInventory().getArmor(2);
        ItemStack leggins = player.getInventory().getArmor(1);
        ItemStack boots = player.getInventory().getArmor(0);

        return !helmet.isEmpty() && !breastplace.isEmpty() && !leggins.isEmpty() && boots.isEmpty();


And here is the armor

public static final RegistryObject<Item> EMERALD_HELMET = ITEMS.register(
        () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.HELMET, new Item.Properties())
    public static final RegistryObject<Item> EMERALD_CHESTPLATE = ITEMS.register(
        () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.CHESTPLATE, new Item.Properties())
    public static final RegistryObject<Item> EMERALD_LEGGINS = ITEMS.register(
        () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.LEGGINGS, new Item.Properties())
    public static final RegistryObject<Item> EMERALD_BOOTS = ITEMS.register(
        () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.BOOTS, new Item.Properties())

I hope you can help me. Thanks.

Edited by vacolandia
Link to comment
Share on other sites

Posted (edited)
18 minutes ago, Xoroshio said:

On the one off the last lines of code you have put && boots.isEmpty()

Instead of && !boots.isEmpty()

is that a typo?

.Omg, I'm so freaking blind I didn't notice that, it works now, thank you so much @Xoroshio

Edited by vacolandia
Link to comment
Share on other sites

  • vacolandia changed the title to (Fixed) [1.20.1] Apply full armor effect doesn't work

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.