Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge Texture Render Error


reaper45693
 Share

Recommended Posts

Note this is regarding 1.2.5 MC not 1.3.2

No matter what forge version or optifine version (yeah i tried the 1.2.5 most recent optifine, with the forge version is says it is compatible with) and the aaw.class files are causing issues. If using the forge aaw file all liquids don't display and neither does fire.

Use the optifine aaw class file and all works fine, except when trying to add Thaumcraft 2 textures to my sphax texture pack.

I get this error -

java.lang.ArrayIndexOutOfBoundsException: 17

at bv.a(TextureLavaFX.java:56)

at aaw.a(RenderEngine.java:946)

at net.minecraft.client.Minecraft.a(Minecraft.java:432)

at net.minecraft.client.Minecraft.run(Minecraft.java:735)

at java.lang.Thread.run(Unknown Source)

 

Full error report here

44 mods loaded

Optifine OptiFine_1.2.5_HD_U_C7

Minecraft Forge 3.3.8.152

FML v2.2.78.153

Forge Mod Loader version 2.2.78.153 for Minecraft 1.2.5

mod_CodeChickenCore : Available (minecraft.jar)

mod_Stackables : Available (minecraft.jar)

mod_SpawnerGUI : Available (minecraft.jar)

mod_GuiApiBasicExample : Available (minecraft.jar)

mod_GuiApiIngameMessageExample : Available (minecraft.jar)

mod_GuiApiIntermediateExample : Available (minecraft.jar)

mod_GuiApiItemTickExample : Available (minecraft.jar)

mod_GuiApiTWLExamples : Available (minecraft.jar)

mod_MoreXp : Available (minecraft.jar)

mod_BE : Available (minecraft.jar)

mod_keepInventory : Available (minecraft.jar)

mod_MinecraftForge : Available (minecraft.jar)

mod_4096Fix : Available (minecraft.jar)

mod_NotEnoughItems : Available (minecraft.jar)

mod_4096FixForge : Available (minecraft.jar)

mod_IC2 : Available (industrialcraft-2-client_1.97.jar)

mod_AdvancedMachines : Available (AdvancedMachinesClient v1.5.zip)

mod_BuildCraftCore : Available (buildcraft-client-A-core-2.2.14.zip)

mod_BuildCraftEnergy : Available (buildcraft-client-B-energy-2.2.14.zip)

mod_BuildCraftFactory : Available (buildcraft-client-B-factory-2.2.14.zip)

mod_BuildCraftTransport : Available (buildcraft-client-B-transport-2.2.14.zip)

mod_BCIC2Crossover : Available (BCIC2crossover client v1.28.zip)

mod_BuildCraftBuilders : Available (buildcraft-client-B-builders-2.2.14.zip)

mod_AdditionalPipes : Available (buildcraft-client-DA-additionalpipes-2.1.3.zip)

mod_EE : Available (EE2ClientV1.4.6.7.jar)

mod_RedPowerWorld : Available (RedPowerWorld-2.0pr5b2.zip)

mod_Forestry : Available (forestry-client-A-1.4.8.6_bc2.2.jar)

mod_IC2NuclearControl : Available (IC2NuclearControl_client_v1.1.10b.zip)

mod_LogisticsPipes : Available (LogisticsPipes-BC2-0.2.4A.zip)

mod_PortalGun : Available (portalgun)

mod_Railcraft : Available (Railcraft_Client_5.4.7b.zip)

mod_RedPowerControl : Available (RedPowerControl-2.0pr5b2.zip)

mod_RedPowerCore : Available (RedPowerCore-2.0pr5b2.zip)

mod_RedPowerLighting : Available (RedPowerLighting-2.0pr5b2.zip)

mod_RedPowerLogic : Available (RedPowerLogic-2.0pr5b2.zip)

mod_RedPowerMachine : Available (RedPowerMachine-2.0pr5b2.zip)

mod_RedPowerWiring : Available (RedPowerWiring-2.0pr5b2.zip)

mod_Timber : Available (Timber! (1.2.4).zip)

mod_WirelessRedstoneCore : Available (WR-CBE Core-Client 1.2.1.zip)

mod_WirelessRedstoneAddons : Available (WR-CBE Addons-Client 1.2.1.zip)

mod_WirelessRedstoneRedPower : Available (WR-CBE RedPower-Client 1.2.1.1.zip)

mod_XieClient : Available (XieClient_Jul17.zip)

mod_IDResolver : Available (minecraft.jar)

mod_ThaumCraft : Available (ThaumCraft2.1.6d.zip)

 

 

      Minecraft has crashed!     

      ----------------------     

 

Minecraft has stopped running because it encountered a problem.

 

 

 

 

--- BEGIN ERROR REPORT ec04995b --------

Generated 29/08/12 3:36 PM

 

Minecraft: Minecraft 1.2.5

OS: Windows 7 (amd64) version 6.1

Java: 1.7.0_06, Oracle Corporation

VM: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: Mobile Intel® 4 Series Express Chipset Family version 2.1.0 - Build 8.15.10.1892, Intel

 

java.lang.ArrayIndexOutOfBoundsException: 17

at bv.a(TextureLavaFX.java:56)

at aaw.a(RenderEngine.java:946)

at net.minecraft.client.Minecraft.a(Minecraft.java:432)

at net.minecraft.client.Minecraft.run(Minecraft.java:735)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT fd5c8dd9 ----------

 

 

 

Any help would be much appreciated. Also I know in the error log, it says I have older and/or different versions of forge and optifine, but I get the same thing with the latest ones.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Okay, is it secure and can the code be copied to another file for usage or it has to be that exact file?
    • And if i run ./gradlew genEclipseRuns they are error:   * What went wrong: Could not resolve all files for configuration ':runtimeClasspathCopy'. > Could not find net.minecraftforge:forge:1.16.5-36.2.5_mapped_official_1.16.5.   Searched in the following locations:     - file:/Users/kikismine/.gradle/caches/forge_gradle/bundeled_repo/net/minecraftforge/forge/1.16.5-36.2.5_mapped_official_1.16.5/forge-1.16.5-36.2.5_mapped_official_1.16.5.pom     - file:/Users/kikismine/.gradle/caches/forge_gradle/bundeled_repo/net/minecraftforge/forge/1.16.5-36.2.5_mapped_official_1.16.5/forge-1.16.5-36.2.5_mapped_official_1.16.5.jar   Required by:       project :   * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.   * Get more help at https://help.gradle.org   Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.   You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins.   See https://docs.gradle.org/7.1.1/userguide/command_line_interface.html#sec:command_line_warnings   BUILD FAILED in 51s kikismine@Krystof-MacBook-Air KikisMod %
    • The text doesn't show. What did I do wrong this time? public class GuiHandler { String text = "Hello world!"; @SubscribeEvent public void onRenderGui(RenderGameOverlayEvent.Post event) { OverlayRegistry.registerOverlayTop("hello", new IIngameOverlay() { @Override public void render(ForgeIngameGui gui, PoseStack mStack, float partialTicks, int width, int height) { drawString(mStack, Minecraft.getInstance().font, text, width / 2, height / 2, Integer.parseInt("33AA66", 16)); } }); } }
    • New Pastebin stay errors https://pastebin.com/7dUT78cj
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.