Jump to content

Field in GuiScreen not set to public at runtime


TeNNoX

Recommended Posts

I tried to update my mod from 1.6.4 where I used Java Reflection to access the protected field GuiScreen.buttonList

to 1.7.2 where I decided to switch to access transformers for performance (and compatibility)

 

I added a *_at.cfg to ressources folder and re-setup the gradlew stuff and now in the eclipse environment everything works fine and everything is public :)

 

But when I built the jar and tried running it in a not-dev-environment (normal minecraft) I get this error:

java.lang.IllegalAccessError: tried to access field net.minecraft.client.gui.GuiScreen.field_146292_n from class tennox.customselectionbox.CSBClientProxy
at tennox.customselectionbox.CSBClientProxy.onTick(CSBClientProxy.java:31)

 

 

 

Edit:

tennox_customselectionbox_at.cfg:

public net.minecraft.client.gui.GuiScreen *

Link to comment
Share on other sites

Do you have your Coremod stuff setup? (IFMLLoadingPlugin and the like?)

 

I have to admit I did forget that... (Will try with that, but if Access Transformers aren't better, I would like to try with reflection)

But to the reflection stuff: It works fine in the decompiled environment, but when build I get this error:

[17:46:06 INFO]: Client> java.lang.NoSuchFieldException: buttonList
[17:46:06 INFO]: Client> 	at java.lang.Class.getDeclaredField(Unknown Source)

 

My Code:

Field field = guioptions.getClass().getSuperclass().getDeclaredField("buttonList");
field.setAccessible(true);
List buttons = field.get(guioptions)

 

I thought Minecraft is decompiled at runtime? Also it said in the Wiki (http://www.minecraftforge.net/wiki/Using_Access_Transformers):

the naming convention should be srg names and Forge packages

 

What did I understand wrong here?

Link to comment
Share on other sites

Did you check your *at.cfg file is in your built mod jar ?

You also need your manifest file to point to your IFMLLoadingPlugin.

 

jar {
    // Add Coremod Manifest
    manifest {
        attributes 'FMLCorePlugin': "loadingPlugin.classpath"//to be replaced by the correct classpath
        attributes 'FMLCorePluginContainsFMLMod': true//If you want that too
    }
}

 

Link to comment
Share on other sites

The tutorial is a bit unclear. You still need the coremod stuff, it is what makes the modifications work in the compiled minecraft (for the end-user, outside the development environment).

For your development environment, ForgeGradle applies the modifications directly.

 

Too complicated for what I want, just using Reflection now :)

 

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Ok yeah I think this might be where the problem starts. For starters, I think you can get rid of your RecipeType impl and make it a static constant instead. I'm not 100% sure this will fix it but it's posssible. RuneInscribingRecipe public class RuneInscribingRecipe implements Recipe<SimpleContainer> { public static final RecipeType<RuneInscribingRecipe> RECIPE_TYPE = new RecipeType<>(){}; // .... @Override public RecipeType<?> getType() { return RECIPE_TYPE; } // .... } RuneInscriberMenu private Optional<RecipeHolder<RuneInscribingRecipe>> getCurrentRecipe() { SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); List<RecipeHolder<RuneInscribingRecipe>> list = this.blockEntity.getLevel().getRecipeManager().getRecipesFor(RuneInscribingRecipe.RECIPE_TYPE, inventory, this.blockEntity.getLevel()); if (list.isEmpty()) { return Optional.empty(); } return Optional.of(list.get(0)); }   Also, this here is a little suspicious where you're getting the `this.inventory.getStackInSlot` calls. I'd try and make sure those are what you expect they are with either a Debug line in IDE or print statement SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); System.out.printf("CHECKING BASE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); System.out.printf("CHECKING TEMPLATE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); ^ See what the result of those print statements are, make sure they're right
    • Upon testing again after adding them, the game still doesn't crash however the resource packs are still unfortunately broken.
    • Hi! Can someone please point me to the correct FAQ or place? I'm not able do DuckDuckGo myself out of this one. As you can hopefully see, chunks are not rendered. I run a forge server, fresh install on a linux VM. Curseforge on the Win11 client with Embeddium, Oculus and Unbound shader. No mods. Forge 47.2.23 on server & client.  No errors, no crashes, no apparent CPU or RAM issues with the VM. This screenshot was captured while creative, but the same happens when flying in survival. Waiting (floating) for a few minutes sooner or (often) later, lets the missing chunks appear. Usually takes 5-10 minutes.  When on a local game, the chunks appear slowly, but they do appear without pause.   This must be something simple, obvious, but I can't find the correct "search words" to find my way out. "Chunks not loading / rendering" didn't help. Browsing several forums neither. 
    • This is the Forge forums. We only support Forge here. Read the FAQ
    • 1.The game doesn't crash, everything seems normal, but when i insert the designated items into the block entity, the result item does not show up. 2.Yes, I'm using a custom menu, here's the source code:  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.