Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.7.2] Can't run in Eclipse?


acid1103
 Share

Recommended Posts

When I try to run forge in Eclipse, I get this...

 

[17:04:01] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!

[17:04:01] [main/ERROR] [FML]: The minecraft jar file:/C:/Users/[MY_NAME]/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.1.1060/forgeSrc-1.7.2-10.12.1.1060.jar!/net/minecraft/client/ClientBrandRetriever.class appears to be corrupt! There has been CRITICAL TAMPERING WITH MINECRAFT, it is highly unlikely minecraft will work! STOP NOW, get a clean copy and try again!

[17:04:01] [main/ERROR] [FML]: For your safety, FML will not launch minecraft. You will need to fetch a clean version of the minecraft jar file

[17:04:01] [main/ERROR] [FML]: Technical information: The class net.minecraft.client.ClientBrandRetriever should have been associated with the minecraft jar file, and should have returned us a valid, intact minecraft jar location. This did not work. Either you have modified the minecraft jar file (if so run the forge installer again), or you are using a base editing jar that is changing this class (and likely others too). If you REALLY want to run minecraft in this configuration, add the flag -Dfml.ignoreInvalidMinecraftCertificates=true to the 'JVM settings' in your launcher profile.

 

 

 

I've tried running

gradlew cleanCache

and recreating the forge environment, (or what ever you chose to call it) and having nothing other than what is normally setup in Eclipse.. Still, when I try to run (with ONLY the argument "--tweakClass=cpw.mods.fml.common.launcher.FMLTweaker") it doesn't work. Does it matter that I'm opting out of changing my entire workspace directory in Eclipse and instead just have a project with the same .classpath and everything as there would be if I used the Gradle-made workspace directory? (That's a confusingly worded question, but I'm 99% confident that it is not causing the problem.) Regardless, I do, in fact, have a clean forgeSrc-1.7.2-10.12.1.1060.jar, and have even tried running it with the arguments the error messages suggest. But it's still not working... How do I fix this annoying problem?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.