Jump to content

Cannot install Minecraft Forge. dependency issue


Recommended Posts

******There is a new problem, it is in post 10******


I am going to start modding Minecraft using forge.I have successfully downloaded/installed Eclipse and JDK. However, when I attempt to install the forge workspace I encounter a problem.


I am following The Neale Gamings installation Instructions. Link here:


In the step where I use the command window and type "gradlew setupDecompWorkspace", it begins downloading the files. I was having an issue where the download would freeze so i deleted the .gradle folder located at C:\Users\Ravi in hopes that when i re-try it, it will have a fresh folder to work with.


I tried the "gradlew setupDecompWorkspace" command again, but this time it resulted in the following error:

width=677 height=376http://i1270.photobucket.com/albums/jj613/Vaderico/SS31_zpsacd88a5b.png[/img]


Things I have tried to resolve the issue:

1- Try running it in both Java 7 and Java 8

2- Running it with my firewall turned off

3- Deleting the .gradle folder in C:\Users\Ravi and repeating steps 1 and 2

4- Using different commands such as:


>gradlew setupDecompWorkspace

>gradlew setupDevWorkspace

>gradlew.bat setupDecompWorkspace --refresh-dependencies

>gradlew.bat setupDevWorkspace --refresh-dependencies


None of these things have helped resolve the Issue, so I am turning to you guys and girls for a bit of advice

If anyone is able to help me, It will be very grateful.

Link to comment
Share on other sites

Yep same problem here.


Decided to update forge today and what a f* nightmare went back to the older version until someone can tell me what the hell went wrong, all I can think of is that before version .1045 the version of gradle is much older than the one forge are using now and just maybe it needs to either remove crap installed by the older version first or over write some settings, which does not happened and now have to be manually deleted or removed.


But knowing absolutely nothing about gradle how it works etc, I would not really know if what i said makes any sense


Also reinstalled version 1.7.2-10.0.1045 without any problems

Link to comment
Share on other sites

has been fixed. rerun with --refresh-dependencies

Thanks for the reply Abrar. I have run with --refresh-dependencies, but I am now encountering another problem.

The download is freezing at a different point each time. For example:

width=680 height=341http://i1270.photobucket.com/albums/jj613/Vaderico/SS6_zps4a987b2c.png[/img]

In the picture above it seems to have stopped at "77 KB/173". The cursor is still flashing, and this happens every time I run it. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.