Jump to content

EnumHelper cannot be resolved


Recommended Posts



Has EnumHelper changed? I've got this piece of code:


[embed=425,349]public static ToolMaterial ArcadeliusSword= EnumHelper.addToolMaterial("ArcadeliusSword", 4, -1, 12.0F, 11.0F, 35);[/embed]


but it can't be resolved.


YES, i have checked my imports. There are nothing to import. Whatever you say, NO. I've even tried to import it manually, it doesn't exist. YES, i have set up forge correctly, and YES, i have set up everything else correct.


Also, YES, i know Java. I just went from Bukkit-developing to mod-developing because i wanted to start bigger.


Any ideas? Every thread i've found got the same answers: "Check your imports" "Learn to import".


Thanks in advance :)

Link to comment
Share on other sites

Really, just really? You couldn't help a bit more, could you?


This is ridiculous, you don't have to answer me like that. I know what i'm doing - this isn't because "I don't know java", but more of a "i can't get this to work even though i've tried everything, can you plesse help me find the problem?"


I'm sorry,  but you sir, are the kind of people i don't like at all. Please give me something constructive instead of being a jerk.

Link to comment
Share on other sites

What version of Forge are you using?


I have no issues importing or using EnumHelper, here. Have you checked that the files EnumHelper.(java|class) exist?


For fear of insulting your java knowledge - you are importing, specifically,


, yes?

Link to comment
Share on other sites

Oh, i just read through my post one more time and i'm so sorry if i insulted anyone. I was really tired, but i won't make up a lot of excuses :P


Anyways, for some reason, the auto import wasn't working correctly. I thought i added the right import earlier on when i added it manually, but it appears that i didn't. Thank you for the help, Elyon :)

Link to comment
Share on other sites

  • 5 years later...

I am having problems with this too. 


Enumhelper cannot be resolved. 


However, net.minecraftforge.common.util.EnumHelper does not exist either. 


I have heard that you no longer need to use EnumHelper, but I have not been able to find out how. 

Link to comment
Share on other sites

The various enum classes have a create method.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.


Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.


DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

  • Guest locked this topic
This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.