Jump to content

[Solved] Gradle won't replace version in README.txt


Recommended Posts

I'm wondering if anyone can help me. I have a README.txt in the same folder as my mcmod.info file (src/main/resources) which contains an explanation of my mod's versioning system among other things. I thought it might be a good idea to use gradle to automate adding the current version the same way I do with the mcmod.info file. I put the ${version} token in the README and included it in the build script after mcmod.info, but even though the replacement worked on mcmod, the README still says ${version}. Can someone tell me what I'm doing wrong here?


README.txt : https://github.com/Renkin42/Renkin42SWT/blob/master/src/main/resources/README.txt

build.gradle: https://github.com/Renkin42/Renkin42SWT/blob/master/build.gradle

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.