Jump to content

State engine was in incorrect state constructing -- Error


myth494

Recommended Posts

hi, i'm trying to setup a modded server for a small group of people but the server keeps crashing, this is the crash report. i've tried looking up in the fourms, and i cannot seem to find a fix for it.

thanks for the help

 

http://pastebin.com/eK7nr0MB is the Latest Forge log i have

 

---- Minecraft Crash Report ----

// Don't do that.

 

Time: 8/23/14 10:55 AM

Description: Exception in server tick loop

 

cpw.mods.fml.common.MissingModsException

at cpw.mods.fml.common.Loader.sortModList(Loader.java:244)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:472)

at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87)

at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:313)

at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:117)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:387)

at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)

 

 

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

 

-- System Details --

Details:

Minecraft Version: 1.7.10

Operating System: Windows 7 (amd64) version 6.1

Java Version: 1.7.0_05, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

Memory: 955682752 bytes (911 MB) / 1053163520 bytes (1004 MB) up to 3773038592 bytes (3598 MB)

JVM Flags: 3 total; -Xms1048M -Xmx4048M -XX:MaxPermSize=756M

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML: MCP v9.05 FML v7.10.18.1180 Minecraft Forge 10.13.0.1180 89 mods loaded, 89 mods active

mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) Unloaded

FML{7.10.18.1180} [Forge Mod Loader] (forge-1.7.10-10.13.0.1180-universal.jar) Unloaded

Forge{10.13.0.1180} [Minecraft Forge] (forge-1.7.10-10.13.0.1180-universal.jar) Unloaded

appliedenergistics2-core{rv1-beta-6} [AppliedEnergistics2 Core] (minecraft.jar) Unloaded

CodeChickenCore{1.0.3.23} [CodeChicken Core] (minecraft.jar) Unloaded

<CoFH ASM>{000} [CoFH ASM Data Initialization] (minecraft.jar) Unloaded

Micdoodlecore{} [Micdoodle8 Core] (minecraft.jar) Unloaded

NotEnoughItems{1.0.3.51} [Not Enough Items] (NotEnoughItems-1.7.10-1.0.3.51-universal.jar) Unloaded

OpenEye{0.6} [OpenEye] (OpenEye-0.6-1.7.10.jar) Unloaded

TConstruct-Preloader{0.1.1} [Tinkers Corestruct] (minecraft.jar) Unloaded

OpenModsCore{@VERSION@} [OpenModsCore] (minecraft.jar) Unloaded

DamageIndicatorsMod{3.2.0} [Damage Indicators] ([1.7.10]DamageIndicatorsMod-3.2.0.jar) Unloaded

appliedenergistics2{rv1-beta-6} [Applied Energistics 2] (appliedenergistics2-rv1-beta-6.jar) Unloaded

Backpack{2.0.0} [backpack] (backpack-2.0.0-1.7.x.jar) Unloaded

BiblioCraft{1.7.5} [biblioCraft] (BiblioCraft[v1.7.5][MC1.7.10].jar) Unloaded

BiblioWoodsBoP{1.6} [biblioWoods Biomes O'Plenty Edition] (BiblioWoods[biomesOPlenty][v1.6].jar) Unloaded

BiblioWoodsForestry{1.4} [biblioWoods Forestry Edition] (BiblioWoods[Forestry][v1.4].jar) Unloaded

BiblioWoodsNatura{1.2} [biblioWoods Natura Edition] (BiblioWoods[Natura][v1.2].jar) Unloaded

BiomesOPlenty{2.1.0} [biomes O' Plenty] (BiomesOPlenty-1.7.10-2.1.0.960-universal.jar) Unloaded

BuildCraft|Builders{6.0.17} [bC Builders] (buildcraft-6.0.17.jar) Unloaded

BuildCraft|Core{6.0.17} [buildCraft] (buildcraft-6.0.17.jar) Unloaded

BuildCraft|Energy{6.0.17} [bC Energy] (buildcraft-6.0.17.jar) Unloaded

BuildCraft|Factory{6.0.17} [bC Factory] (buildcraft-6.0.17.jar) Unloaded

BuildCraft|Silicon{6.0.17} [bC Silicon] (buildcraft-6.0.17.jar) Unloaded

BuildCraft|Transport{6.0.17} [bC Transport] (buildcraft-6.0.17.jar) Unloaded

CarpentersBlocks{3.2.5} [Carpenter's Blocks] (Carpenters Blocks v3.2.6 - MC 1.7.10.zip) Unloaded

chisel{1.5.6a} [Chisel] (Chisel-1.7.10-1.5.6a.jar) Unloaded

CoFHCore{1.7.10R3.0.0B3} [CoFH Core] (CoFHCore-[1.7.10]3.0.0B3-26.jar) Unloaded

DynamicLights{1.3.5} [Dynamic Lights] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_onFire{1.0.4} [Dynamic Lights Burning Entity Module] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_creepers{1.0.4} [Dynamic Lights Creeper Module] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_dropItems{1.0.7} [Dynamic Lights EntityItem Module] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_entityClasses{1.0.1} [Dynamic Lights Entity Light Module] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_mobEquipment{1.0.5} [Dynamic Lights Mob Equipment Light Module] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_flameArrows{1.0.0} [Dynamic Lights Fiery Arrows Light Module] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_floodLights{1.0.1} [Dynamic Lights Flood Light] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_otherPlayers{1.0.7} [Dynamic Lights OtherPlayers Light Module] (DynamicLights-1.7.10.jar) Unloaded

DynamicLights_thePlayer{1.1.3} [Dynamic Lights Player Light Module] (DynamicLights-1.7.10.jar) Unloaded

EnderStorage{1.4.5.20} [EnderStorage] (EnderStorage-1.7.10-1.4.5.20-universal.jar) Unloaded

ExtraUtilities{1.1.0i} [Extra Utilities] (extrautilities-1.1.0i.jar) Unloaded

Forestry{2.4.2.67} [Forestry for Minecraft] (forestry_1.7.10-2.4.2.67.jar) Unloaded

GalacticraftCore{3.0.1} [Galacticraft Core] (GalacticraftCore-BETA-1.7-3.0.1.170.jar) Unloaded

Growthcraft|Apples{2.1.0} [Growthcraft Apples] (growthcraft-apples-1.7.10-2.1.0.jar) Unloaded

Growthcraft|Bamboo{2.1.0} [Growthcraft Bamboo] (growthcraft-bamboo-1.7.10-2.1.0.jar) Unloaded

Growthcraft|Cellar{2.1.0a} [Growthcraft Cellar] (growthcraft-cellar-1.7.10-2.1.0a.jar) Unloaded

Growthcraft{2.1.0a} [Growthcraft] (growthcraft-core-1.7.10-2.1.0a.jar) Unloaded

Growthcraft|Grapes{2.1.0} [Growthcraft Grapes] (growthcraft-grapes-1.7.10-2.1.0.jar) Unloaded

Growthcraft|Hops{2.1.0} [Growthcraft Hops] (growthcraft-hops-1.7.10-2.1.0.jar) Unloaded

Growthcraft|Rice{2.1.0a} [Growthcraft Rice] (growthcraft-rice-1.7.10-2.1.0a.jar) Unloaded

Hats{4.0.0} [Hats] (Hats-4.0.0.jar) Unloaded

HatStand{4.0.0} [HatStand] (HatStand-4.0.0.jar) Unloaded

iChunUtil{4.0.0} [iChunUtil] (iChunUtil-4.0.0.0.jar) Unloaded

ImmibisCore{59.0.1} [immibis Core] (immibis-core-59.0.1.jar) Unloaded

inventorytweaks{1.59-dev-152-cf6e263} [inventory Tweaks] (InventoryTweaks-1.59-dev-152.jar) Unloaded

IronChest{6.0.49.733} [iron Chest] (ironchest-1.7.10-6.0.49.733-universal.jar) Unloaded

JABBA{1.1.4} [JABBA] (Jabba-1.1.4_1.7.10.jar) Unloaded

Mantle{1.7.10-165.4bc3343} [Mantle] (Mantle_mc1.7.10_0.3.0.jar) Unloaded

MineTweaker3{1.7.10-3.0.3} [MineTweaker 3] (MineTweaker3-1.7.10-3.0.6.jar) Unloaded

Morph{0.9.0} [Morph] (Morph-Beta-0.9.0.jar) Unloaded

MouseTweaks{2.4.4} [Mouse Tweaks] (MouseTweaks-2.4.4-mc1.7.10.jar) Unloaded

Natura{2.2.0} [Natura] (natura-1.7.10-2.2.0-b1.jar) Unloaded

NEIPlugins{1.1.0.7-unofficial} [NEI Plugins Unofficial] (NEIPlugins-MC1.7.10-1.1.0.7-unofficial.jar) Unloaded

NetherOres{1.7.10R2.3.0RC3} [Nether Ores] (NetherOres-[1.7.10]2.3.0RC3-84.jar) Unloaded

OpenMods{0.6} [OpenMods] (OpenModsLib-1.7.10-0.6-snapshot-224.jar) Unloaded

fodc{1.5.1} [Ore Dictionary Converter] (OreDictionaryConverter-1.5.1.jar) Unloaded

ProjRed|Core{4.4.6.45} [ProjectRed] (ProjectRed-Base-1.7.10-4.4.6.45.jar) Unloaded

ProjRed|Compatibility{4.4.6.45} [ProjectRed-Compatibility] (ProjectRed-Compat-1.7.10-4.4.6.45.jar) Unloaded

ProjRed|Integration{4.4.6.45} [ProjectRed-Integration] (ProjectRed-Integration-1.7.10-4.4.6.45.jar) Unloaded

ProjRed|Transmission{4.4.6.45} [ProjectRed-Transmission] (ProjectRed-Integration-1.7.10-4.4.6.45.jar) Unloaded

ProjRed|Illumination{4.4.6.45} [ProjectRed-Illumination] (ProjectRed-Lighting-1.7.10-4.4.6.45.jar) Unloaded

ProjRed|Expansion{4.4.6.45} [ProjectRed-Expansion] (ProjectRed-Mechanical_beta-1.7.10-4.4.6.45.jar) Unloaded

ProjRed|Transportation{4.4.6.45} [ProjectRed-Transportation] (ProjectRed-Mechanical_beta-1.7.10-4.4.6.45.jar) Unloaded

ProjRed|Exploration{4.4.6.45} [ProjectRed-Exploration] (ProjectRed-World-1.7.10-4.4.6.45.jar) Unloaded

Railcraft{9.2.2.0} [Railcraft] (Railcraft_1.7.10-9.2.2.0.jar) Unloaded

RedstoneArsenal{1.7.10R1.1.0B3} [Redstone Arsenal] (RedstoneArsenal-[1.7.10]1.1.0B3-8.jar) Unloaded

statues{2.1.3} [statues] (statues-1.7.10-2.1.3.jar) Unloaded

StevesCarts{2.0.0.b16} [steve's Carts 2] (StevesCarts2.0.0.b16.jar) Unloaded

StevesFactoryManager{A90} [steve's Factory Manager] (StevesFactoryManagerA90.jar) Unloaded

TConstruct{1.7.10-1.6.0.build591} [Tinkers' Construct] (TConstruct_mc1.7.10_1.6.0d39.jar) Unloaded

ThermalExpansion{1.7.10R4.0.0B3} [Thermal Expansion] (ThermalExpansion-[1.7.10]4.0.0B3-11.jar) Unloaded

ThermalFoundation{1.7.10R1.0.0B1} [Thermal Foundation] (ThermalFoundation-[1.7.10]1.0.0B1-6.jar) Unloaded

TMechworks{1.7.10-67.34d1d9b} [Tinkers' Mechworks] (TMechworks_mc1.7.10_0.2.8.jar) Unloaded

Translocator{1.1.1.9} [Translocator] (Translocator-1.7.10-1.1.1.9-universal.jar) Unloaded

Waila{1.5.3} [Waila] (Waila-1.5.3_1.7.10.jar) Unloaded

WailaHarvestability{1.0.4} [Waila Harvestability] (WailaHarvestability-mc1.7.x-1.0.4.jar) Unloaded

witchery{0.20.5} [Witchery] (witchery-1.7.10-0.20.5.jar) Unloaded

ForgeMicroblock{1.1.0.300} [Forge Microblocks] (ForgeMultipart-1.7.10-1.1.0.300-universal.jar) Unloaded

ForgeMultipart{1.1.0.300} [Forge Multipart] (ForgeMultipart-1.7.10-1.1.0.300-universal.jar) Unloaded

McMultipart{1.1.0.300} [Minecraft Multipart Plugin] (ForgeMultipart-1.7.10-1.1.0.300-universal.jar) Unloaded

Profiler Position: N/A (disabled)

Is Modded: Definitely; Server brand changed to 'fml,forge'

Type: Dedicated Server (map_server.txt)

Link to comment
Share on other sites

OMG i cant believe i didnt think of searching in Notepad++

 

i managed to get it running, by removing the mod that gave the error then kept doing that untill i had no errors, then i put them back in one by one and figured out what was causing ALL the errors. it was just because i had client side mods in the mods folder (thought i got rid of them all) the server now runs, thank you so much.

 

although i do still get a few errors with a few mods

 

http://pastebin.com/6imRYEm9

Link to comment
Share on other sites

  • 3 years later...
  • Guest locked this topic
Guest
This topic is now closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • My friends and I are modding to survive But recently I want to use cmd to open the server instead of making the single player game public But when I used two methods to start the server, I encountered two problems first A I used forge to install the server files Created using the original server jar The server was installed successfully and the mod was also loaded successfully. But after I replaced the world file with my survival map, I found that the mod items inside disappeared but could be taken from creation again. So I tried to install the server using forge first B I have studied forge for a long time but successfully installed it. But when I put in mods it crashed But mods can be installed on the server   我和我的朋友們正在mod為了生存 但是最近我想用cmd打開伺服器而不是把單人遊戲公開 但是當我使用兩種方法啟動伺服器時,我遇到了兩個問題 首先AI使用forge安裝伺服器檔案使用原始伺服器jar 建立伺服器已成功安裝,mod 也已成功載入。但是當我用我的生存地圖替換世界文件後,我發現裡面的mod物品消失了,但可以再次從創建中取出。所以我嘗試先使用forge安裝伺服器,BI研究了forge很久但成功安裝了它。但是當我安裝 mods 時它崩潰了但是 mods 可以安裝在伺服器上 我和我的朋友正在mod生存 但最近我想使用cmd開啟伺服器而不是單人遊戲公開   但是當我使用了兩種方法開啟伺服器時遇到了兩種問題   第1個A 我使用了forge安裝伺服器文件 在使用原版伺服器jar建立    伺服器安裝成功 mod也順利加載  但是我將我的生存地圖替換世界文件後發現裡面的mod物品消失了但可以再次從創造拿取  所以我嘗試使用forge安裝伺服器   第2個B forge我研究了很久但也成功安裝了 但是當我放入 mods 之後發生了崩潰 但是mods在1A伺服器上是可以安裝的 Ps 我用谷歌翻譯 so    
    • That’s probably not it because as I stated I’ve done it before. I did it like deadass 10 - 20 times when trying to learn to make this mod pack because I kept wanting to reset my profiles and such. So it definitely works, it looks like maybe the creephosting files were the things that couldn’t be reached I tried reading the crash log
    • I don't know if this is the right place or not, but I have put together a custom modpack and I am in need of others to help me. It's a questing modpack with a lore book i'm currently writing out through Patchouli, and i am in need of somebody who will assist me in making the quests for the pack. It's a Zombie apocalypse modpack inspired by Deceasedcraft  with a tinge of magic and RPG mechanics via Mine and slash. Is there anybody willing to assist me as i'm one person building a modpack I could also use help with optimizations since that's not really my strong suite. 
    • File a report to SPYRECOVERY36 @ gmail com he can legitimately assist in proper review and recovery of all your assets that was stolen. Endeavor to submit your request for a refund to his mail . He also spy and hack any device remotely without any trace. Contact via spyrecovery36 @ gm ail com  
    • Hello, is it possible to upgrade from server 1.16.5 forge to 1.20.1 forge without losing a thing? and how do I do it? You need to change "forge-1.16.5-36.2.35.jar, minecraft_server.1.16.5.jar" and other modes.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.