Jump to content

Re: Minecraft forge won't open for 1.6.4


Recommended Posts

Hi, sorry to jump on this thread too, but i have the exact same issue.


I have no crash/error 'Logs' as i can't even get forge-1.6.4- (has a Jar extension) to do anything, either when i double click on it, or by right clicking and using 'Open with...' and selecting the Java Platform SE binary option.


I've downloaded and installed both the 32bit and 64bit versions of Java 7 (which is the correct version for this version of Forge).


On the 64bit version of Java i get a brief dos/command prompt window open (for less than a second) then close so i can't see what it is saying.


On the 32bit version of Java i get nothing at all.


I see that for Forge 1.7.10 (the one after 1.6.4) it has a 'Installer-win' download option, which is an .exe, but their is only a 'Installer' download which is a .jar for version 1.6.4


Is that the issue maybe? The whole reason for getting the older 1.6.4 version of Forge is to play the Life in the Woods mod for minecraft, so if anyone knows of another way to get Forge 1.6.4 to do something, or how to play Life in the Woods on 1.7.10 i would be very grateful!!!


I've run minecraft latest (1.8 ) a few times first, AND also version 1.6.4 that i need for this mod so i know the base Mincraft game is working on both versions.


i've downloaded installed and uninstalled Java 7 a number of times, both the 32bit and 64bit (my PC+OS is 64bit), i've used jarfix, i've made sure no antivirus or firewall software is running, i've mde sure in in administrator mode and all software is installed with administrator rights.


I've watched youtube tutorials on setting up Life in the woods, which includes where to download the right Forge 1.6.4 from (which is the link at the top of this forum). It's just that for me the .jar file does nothing and i can make it do nothing on my PC?


All very confusing and i've not really seen much help around the internet on this.


here is my log from my .minecraft (with some stuff redacted)


[22:23:05] [Client thread/INFO]: Setting user: ***************

[22:23:05] [Client thread/INFO]: (Session ID is token:************************

[22:23:06] [Client thread/INFO]: LWJGL Version: 2.9.1

[22:23:07] [Client thread/INFO]: Reloading ResourceManager: Default

[22:23:07] [sound Library Loader/INFO]: Starting up SoundSystem...

[22:23:07] [Client thread/WARN]: File minecraft:sounds/mob/ghast/fireball.ogg does not exist, cannot add it to event minecraft:item.fireCharge.use

[22:23:07] [Thread-6/INFO]: Initializing LWJGL OpenAL

[22:23:07] [Thread-6/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

[22:23:07] [Thread-6/INFO]: OpenAL initialized.

[22:23:07] [sound Library Loader/INFO]: Sound engine started

[22:23:09] [Client thread/INFO]: Created: 512x512 textures-atlas

[22:23:13] [server thread/INFO]: Starting integrated minecraft server version 1.8

[22:23:13] [server thread/INFO]: Generating keypair

[22:23:13] [server thread/INFO]: Converting map!

[22:23:13] [server thread/INFO]: Scanning folders...

[22:23:13] [server thread/INFO]: Total conversion count is 0

[22:23:14] [server thread/INFO]: Preparing start region for level 0

[22:23:15] [server thread/INFO]: Preparing spawn area: 11%

[22:23:16] [server thread/INFO]: Preparing spawn area: 24%

[22:23:17] [server thread/INFO]: Preparing spawn area: 40%

[22:23:18] [server thread/INFO]: Preparing spawn area: 58%

[22:23:19] [server thread/INFO]: Preparing spawn area: 77%

[22:23:20] [server thread/INFO]: Preparing spawn area: 91%

[22:23:20] [server thread/INFO]: Changing view distance to 12, from 10

[22:23:21] [server thread/INFO]: *********[local:E:e1ac78fe] logged in with entity id ***at (******************8)

[22:23:21] [server thread/INFO]: ********* joined the game

[22:23:23] [server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 2288ms behind, skipping 45 tick(s)

[22:23:36] [server thread/INFO]: Saving and pausing game...

[22:23:36] [server thread/INFO]: Saving chunks for level 'New World'/Overworld

[22:23:37] [server thread/INFO]: Saving chunks for level 'New World'/Nether

[22:23:37] [server thread/INFO]: Saving chunks for level 'New World'/The End

[22:23:38] [server thread/INFO]: Stopping server

[22:23:38] [server thread/INFO]: Saving players

[22:23:38] [server thread/INFO]: Saving worlds

[22:23:38] [server thread/INFO]: Saving chunks for level 'New World'/Overworld

[22:23:38] [server thread/INFO]: Saving chunks for level 'New World'/Nether

[22:23:38] [server thread/INFO]: Saving chunks for level 'New World'/The End

[22:23:39] [Client thread/INFO]: Stopping!

[22:23:39] [Client thread/INFO]: SoundSystem shutting down...

[22:23:39] [Client thread/WARN]: Author: Paul Lamb, www.paulscode.com



However as Minecraft works fine, and the issue is Forge 1.6.4 doing nothing, i can't see that would help much


Any suggestion greatly appreciated as i just bought Minecraft today to play this mod!!

Link to comment
Share on other sites

Sadly i'm stuck with 1.6.4 for Life in the Woods mod:




It is the whole reason i bought minecraft!


I do seem to have an issue with my Java installations going on this i copy/pasted from the command prompt (using the video guide you gave me, thanks :) ):


Error On 64bit Java 7 (jre-7u67-windows-x64):



Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation.  All rights reserved.


E:\>cd minecraftmods



Volume in drive E has no label.

Volume Serial Number is A2DA-BCB1


Directory of E:\minecraftmods


16/09/2014  21:32    <DIR>          .

16/09/2014  21:32    <DIR>          ..

16/09/2014  18:02    <DIR>          Desktop

18/12/2013  07:41        2,269,863 forge-1.6.4-

16/09/2014  18:07    <DIR>          forge-1.6.4-

16/09/2014  18:06        6,076,441 forge-1.6.4-

              2 File(s)      8,346,304 bytes

              4 Dir(s)  395,934,748,672 bytes free


E:\minecraftmods>java -jar forge-1.6.4-

Exception in thread "main" java.lang.Error: IP Helper Library GetIfTable functio

n failed

        at java.net.NetworkInterface.getAll(Native Method)

        at java.net.NetworkInterface.getNetworkInterfaces(Unknown Source)

        at sun.security.provider.SeedGenerator.addNetworkAdapterInfo(Unknown Sou


        at sun.security.provider.SeedGenerator.access$000(Unknown Source)

        at sun.security.provider.SeedGenerator$1.run(Unknown Source)

        at sun.security.provider.SeedGenerator$1.run(Unknown Source)

        at java.security.AccessController.doPrivileged(Native Method)

        at sun.security.provider.SeedGenerator.getSystemEntropy(Unknown Source)

        at sun.security.provider.SecureRandom$SeederHolder.<clinit>(Unknown Sour


        at sun.security.provider.SecureRandom.engineNextBytes(Unknown Source)

        at java.security.SecureRandom.nextBytes(Unknown Source)

        at java.security.SecureRandom.next(Unknown Source)

        at java.util.Random.nextLong(Unknown Source)

        at java.nio.file.TempFileHelper.generatePath(Unknown Source)

        at java.nio.file.TempFileHelper.create(Unknown Source)

        at java.nio.file.TempFileHelper.createTempFile(Unknown Source)

        at java.nio.file.Files.createTempFile(Unknown Source)

        at javax.imageio.stream.FileCacheImageInputStream.<init>(Unknown Source)


        at com.sun.imageio.spi.InputStreamImageInputStreamSpi.createInputStreamI

nstance(Unknown Source)

        at javax.imageio.ImageIO.createImageInputStream(Unknown Source)

        at javax.imageio.ImageIO.read(Unknown Source)

        at cpw.mods.fml.installer.InstallerPanel.<init>(InstallerPanel.java:86)

        at cpw.mods.fml.installer.SimpleInstaller.launchGui(SimpleInstaller.java


        at cpw.mods.fml.installer.SimpleInstaller.main(SimpleInstaller.java:33)






Error on 32bit Java 7(jre-7u67-windows-i586):



E:\minecraftmods>java -jar forge-1.6.4-

'java' is not recognized as an internal or external command, operable program or batch file.


Any clues there? I installed java to it default choice (C:\Program Files (x86)\Java\jre7\bin\java), that for the 32bit and regular '\Program Files\Java\etc' for the 64bit version. I've used jarfix and it reports everything is correct. I'm a bit stumped! Do i have to run Forge from within the Java installation (so in C: drive etc?)

Link to comment
Share on other sites

The installer for forge should be run from some temporary place, not any place you plan on having the final system installed to.. Though, it should also be putting out files with a different name than the installer, so technically it "shouldn't" matter.. but..


So, have you actually logged into your 1.6.4 -world-? For the installer to work, you have to have launched the 1.6.4 profile at least once.. past just logging in, and into the screen where you can pick a single player world to run. That initial running is what downloads all the game pieces for that version, and Forge needs those pieces already there to install.


And I've found that the .exe installers don't always work nice, the .jar is the way to go... Also, if you already have a forge installed (for the 1.6.4), it might not try to install again.. have you tried creating a new profile and seeing if you have access to a Forge for 1.6.4 as a profile/game?

Link to comment
Share on other sites

Edit: @Savantster, sorry we cross posted, and yes i have run both default current minecraft (1.8 ) and the version 1.6.4 i need for this mod. But i found the solution by chance anyway as below.


Wow. Ok that was the solution!!!!


I had the Forge-1.6.4- on my desktop (and within that E:\minecraftmods directory) and trying to run it from either place did nothing, even if pointing it to the java binary with 'open with' etc.


As soon as i moved the Forge-1.6.4- jar packet inside my \Java\jre7\bin folder and double clicked it i got that pop-up screen asking what i wanted to install (Install Client in my case).


So that is the solution to all the thousands (it seems?) of questions about Forge NOT starting when clicked/run etc. Hurray! I didn't waste money on minecraft :)


Update: and that all worked fine i got the:


Successfully installed client profile Forge for version Forge into launcher and grabbed 2 required libraries


So it looks like that is the solution, put the Forge INSIDE your java installation IF it appears to do nothing when you click/run it.

Link to comment
Share on other sites

  • 11 months later...
This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.