Jump to content

New PC setup, attempting 1.7.1 w/ forge fails to run (SOLVED)


Recommended Posts

I've modded minecraft before, but that was probably 6 months ago. Unfortunately the mod world of minecraft is ever evolving. I used to take jar files and copy contents into other jar files and things worked. Now forge has an installed (I though "Oh thank heaven") but it doesn't seem to work.

The mods I want to use are stable for 1.7.2 so those are the versions I'm downloading. But that's putting the carriage before the horse.

First I want to be able to run minecraft with forge installed. So here's the problem. Use the installed (tried for both 1.7.1 and 1.7.2 'recommended' versions.

After installing and selecting the version in the profile and clicking play, the client fails to run minecraft and the launcher throws this log at me:

[13:55:27] [main/ERROR] [LaunchWrapper]: Unable to launch


at java.util.ArrayList$Itr.checkForComodification(Unknown Source) ~[?:1.8.0_25]

at java.util.ArrayList$Itr.remove(Unknown Source) ~[?:1.8.0_25]

at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]

at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]


This is the full log created after attempting to launch: http://pastebin.com/VCRbtx26

I remember we used to have to delete Meta-Inf so I went into each versions jar and deleted that, no change.

Again, this is vanilla minecraft, only forge installed, no mods in mod folder. I've cleared the versions, re-downloaded, re-installed and get the same result.

I'm running an AMD Athlon x2 dual core with 4GB RAM on WinXP Pro SP3. Vanilla launcher.

I just want minimap and optifine mods... this is too much work! Though Mojang was gonna implement mod support!

Sad panda...




First solution I found, I read that the newest version of Java 1.8 has problems, so I downloaded and installed 1.7, removed 1.8 and made progress. Launcher told me my jar file was corrupt (meta inf was removed) so I reinstalled forge and have a working minecraft build 1.7.2.

The solution was reverting from NEW java to JAVA VERSION 1.7. <<<  SOLUTION!

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.