Jump to content

[1.7] Removing block drops from vanilla blocks and adding my own


pinkyboy9102

Recommended Posts

Hi all,

 

I've been coding my mod for a while now and decided it was time to try and change how you obtain one of my items: Raw Obsidian. Before you just smelted obsidian, but now I want to make it so that when you break Obsidian with a new 'pickaxe' i added called the Hammer, it drops 4 Raw Obsidian and NOTHING else. I am currently trying to do this through an event handler, but it drops the Obsidian Chunks AND the Obsidian block. Does anyone know how to fix this?

 

My Event Handler:

package com.pinkyboy910.craftablespawners.event;

 

*IMPORTS*

 

public class events {

 

@SubscribeEvent

public void onDrops(BlockEvent.HarvestDropsEvent event) {

 

if (event.block == Blocks.obsidian && event.harvester.getHeldItem() != null && event.harvester.getHeldItem().getItem() == MainClass.diamondHammer){

        event.drops.remove(Blocks.obsidian);}

       

        if (event.block == Blocks.obsidian && event.harvester.getHeldItem() !=null && event.harvester.getHeldItem().getItem() == MainClass.diamondHammer){

        event.drops.add(new ItemStack(MainClass.rawObsidian, 4));}

}

 

}

 

 

If anyone knows how to fix this, please help :)

-pinkyboy

Link to comment
Share on other sites

Hi

 

From my point of view, I wonder why you check the condition twice. Is there any reason for this?

 

By the way, I'd suggest to not use the event system. I'd rather code that test in the Hammer itself.

 

Get the drops of the block there and don't spawn them.

 

May my reply was helpful

Sincerely -pick

Since English is not my mother tongue, my sentences may are confusing.

 

I'm coding java for a long time now - just MC and forge stop me sometimes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Please share a link to your crash report on https://paste.ee, as explained in the FAQ. Dumping it directly into the thread often triggers the anti-spam and makes it hard to read due to word wrapping
    • Hi all, I'm running a 1.20.1 Minecraft Forge server with a hosting website and something seems to have gone wrong. It started as an occasional crash that has now become extremely frequent and I don't know what exactly is causing it. I already tried disabling watchdog but the server crashes anyway. Oddly it only occasionally generates a crash report after a crash occurs. Based on viewing the server console's research usage it seems that the CPU spikes astronomically high (100% usage), especially when chunks are being loaded or when a new person joins the server. I downloaded Spark to create a profile (https://spark.lucko.me/bBlWe7ou29) but I lack experience with this mod and don't understand what I'm looking at/how this should help me diagnose the issue. I am using a lot of mods so I'm guessing there is some sort of issue there or a corrupted chunk (although MCRF found no chunk errors). We actually don't experience any lag until the crash occurs, so it's some sort of sudden spike in resource usage. Based on the crash report I've already tried removing Canary and Modernfix but there was no change. Thanks for any help you can provide. Specs:  4 cores x 4200MHz AMD Ryzen 9 5950X 4GB RAM Crash report:  
    • will test that once i get home, thanks
    • I am getting this exception (I am new and just trying to create an item) Caused by: java.io.FileNotFoundException: abrasmagics:models/item/ingot_test.json at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:69) ~[SimpleReloadableResourceManager.class:?] at net.minecraft.client.renderer.block.model.ModelBakery.loadModel(ModelBakery.java:334) ~[ModelBakery.class:?] at net.minecraftforge.client.model.ModelLoader.access$1400(ModelLoader.java:115) ~[ModelLoader.class:?] at net.minecraftforge.client.model.ModelLoader$VanillaLoader.loadModel(ModelLoader.java:861) ~[ModelLoader$VanillaLoader.class:?] at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]   However the directory is set up correctly and the file does exist   idk how to upload images so here is a treeview of the directories:   src ├───main │ ├───java │ │ └───net │ │ └───abrasmods │ │ └───abrasmagics │ │ ├───init │ │ ├───items │ │ └───utils │ │ ├───handlers │ │ ├───misc │ │ └───proxy │ └───resources │ └───assets │ └───abrasmagics │ ├───models │ │ ├───block │ │ └───item │ └───textures └───test ├───java └───resources   the file ingot_test.json is under models/item. The directory seems fine and the file does exist so anyone plz help.   i am using intellij and is coding for 1.12.2
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.