Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge[1.7.10] Particle Problem


Microcellule
 Share

Recommended Posts

Hi there ! I have un unexpected problem with my particles ... i let you see what kind of problem is (click on the image to see the gif) ;)

 

width=180 height=135http://s24.postimg.org/5fwzwjcoh/Bug_particle.jpg[/img]

 

 

Here is my code for the particules.

 

 

 

package ThelosMod.Particules;

 

import net.minecraft.client.Minecraft;

import net.minecraft.client.particle.EntityFX;

import net.minecraft.client.renderer.Tessellator;

import net.minecraft.entity.player.EntityPlayer;

import net.minecraft.util.AxisAlignedBB;

import net.minecraft.util.ResourceLocation;

import net.minecraft.world.World;

import static org.lwjgl.opengl.GL11.*;

 

import org.lwjgl.opengl.GL11;

 

import ThelosMod.ThelosMod;

 

public class ThelosParticlesFX extends EntityFX

{

 

private static final ResourceLocation texture = new ResourceLocation("thelosmod","textures/particles/thelos.png");

 

public ThelosParticlesFX(World world, double x,double y, double z)

{

super(world, x, y, z);

setGravity(0.0F);

 

}

 

public void renderParticle(Tessellator tess,float partialTicks, float par3, float par4, float par5,float par6, float par7)

{

Minecraft.getMinecraft().renderEngine.bindTexture(texture);

GL11.glDisable(GL11.GL_LIGHTING);

glDepthMask(false);

glBlendFunc(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA);

glAlphaFunc(GL_GREATER,0.003921569F);

tess.startDrawingQuads();

tess.setBrightness(getBrightnessForRender(partialTicks));

float scale= 0.1F * particleScale;

float x = (float)(prevPosX + (posX - prevPosX) * partialTicks - interpPosX);

float y = (float)(prevPosY + (posX - prevPosY) * partialTicks - interpPosY);

float z = (float)(prevPosZ + (posX - prevPosZ) * partialTicks - interpPosZ);

tess.addVertexWithUV(x - par3 * scale - par6 * scale, y- par4* scale ,z - par5*scale - par7 * scale, 0, 0);

tess.addVertexWithUV(x - par3 * scale + par6 * scale, y+ par4* scale ,z - par5*scale + par7 * scale, 1, 0);

tess.addVertexWithUV(x + par3 * scale + par6 * scale, y+ par4* scale ,z + par5*scale + par7 * scale, 1, 1);

tess.addVertexWithUV(x + par3 * scale - par6 * scale, y- par4* scale ,z + par5*scale - par7 * scale, 0, 1);

tess.draw();

glDisable(GL_BLEND);

glDepthMask(true);

glAlphaFunc(GL_GREATER, 0.1F);

}

 

 

public int getFXLayer()

{

return 3;

}

 

public ThelosParticlesFX setMaxAge(int maxAge)

{

particleMaxAge=maxAge;

return this;

}

public ThelosParticlesFX setGravity(float gravity)

{

particleGravity=gravity;

return this;

}

public ThelosParticlesFX setScale(float scale)

{

particleScale=scale;

return this;

}

}

 

 

 

I don't know what the problem is and i Follow this tut0 to see how it works :

 

I don't understand why my particles don't stay 3 blocks on top of the head of the player ! Is so strange, and even if i do nothing in the method OnUpdate(), particles are going away anyway. Modify the gravity doesn't change anything too.

 

 

Thanks for your futur answer ;)

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I have been trying to install forge, but I can't even get the installer to run. I'm really not sure what the issue is, first let me make sure I am even using the installer right, I downloaded the forge installer matching my minecraft version (1.19.2), if I double click the .jar from the download then I see a flash of a black window that immediately disappears. If I use a command prompt, I receive the following output: C:\Users\austi> java -jar forge-1.19.2-43.0.19-installer.jar Error: Unable to access jarfile forge-1.19.2-43.0.19-installer.jar   I feel like this is more likely a java issue than a forge issue but I was hoping that people here might be able to help. I've tried a couple versions of java, at first I was using 8 I believe because all of the install guides for forge were a bit older so they linked to the java website rather than oracle. I tried version 18 from the oracle site and received the same result from command prompt.
    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.