Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.8] Generate model file internally?


61352151511
 Share

Recommended Posts

Not sure if this is possible but what I'd like is to generate Strings in a json format within code, and then register that as the model, so instead of having an actual file, it's just done on launch. These will be cached if the user wishes to save them, it basically saves the effort of having to create model files for every block/item. If this is possible could I get some insight on how to do so?

Link to comment
Share on other sites

Thanks, I think I got most of it done however one issue I'm having is getting the field.

 

@SuppressWarnings({"rawtypes", "unchecked"}) public synchronized static void assembleResources() {
if (FMLCommonHandler.instance().getEffectiveSide().isClient()) {
	try {
		Field field = Minecraft.getMinecraft().getClass().getDeclaredField("defaultResourcePacks");
		field.setAccessible(true);
		Field modField = Field.class.getDeclaredField("modifiers");
		modField.setAccessible(true);
		modField.setInt(field, field.getModifiers() & ~Modifier.FINAL);
		List rPacks = (List) field.get(Lists.newArrayList());
		rPacks.add(new EasyModResourcePack());
		field.set(field, rPacks);
	} catch (Exception e) {
		LogHelper.warn("An exception was thrown creating resource pack");
		LogHelper.warn(e.getMessage() != null ? e.getMessage() : "");
		e.printStackTrace();
	}
}
}

 

The line "List rPacks = (List) field.get(Lists.newArrayList());" Throws an error, Can not set java.util.List field net.minecraft.client.Minecraft.defaultResourcePacks to java.util.ArrayList

 

If someone knows how to fix this issue, that would really help. I'm no reflection expert, I wouldn't even consider myself at the level of beginner yet, so I'm probably doing something wrong.

Link to comment
Share on other sites

Ok, please learn reflection properly.

 

First of all you don't need that modifiers hack, that is only needed for static final fields. Then you can use Minecraft.class instead of Minecraft.getMinecraft().getClass(). And then field.get needs the instance to get the field from. The field defaultResourcePacks does not exist in the List class, so you can't pass it a List. Obviously.

And you don't need to call field.set ever in this case.

Link to comment
Share on other sites

private final DefaultResourcePack mcDefaultResourcePack;

It's not a static field but it's final, and I get illegal access exception's without it.

 

The only things I've changed are

Field field = Minecraft.class.getDeclaredField("defaultResourcePacks");

List rPacks = (List) field.get(Minecraft.getMinecraft());

 

Now if I don't set the field how am I supposed to add to the default resource packs? Does calling rPacks.add do it?

Link to comment
Share on other sites

It's not a static field but it's final, and I get illegal access exception's without it.

setAccessible is enough. You only need to hack the modifiers if the field is both static and final.

 

Now if I don't set the field how am I supposed to add to the default resource packs? Does calling rPacks.add do it?

Yes. That's how Java works. Objects are passed by reference, not by value.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello There! In the 73rd episode of Bed Wars we get into a lobby with a guy who had a cool name and for some reason Ben is very impressed with the name and thus the title!  
    • I have been trying to install forge, but I can't even get the installer to run. I'm really not sure what the issue is, first let me make sure I am even using the installer right, I downloaded the forge installer matching my minecraft version (1.19.2), if I double click the .jar from the download then I see a flash of a black window that immediately disappears. If I use a command prompt, I receive the following output: C:\Users\austi> java -jar forge-1.19.2-43.0.19-installer.jar Error: Unable to access jarfile forge-1.19.2-43.0.19-installer.jar   I feel like this is more likely a java issue than a forge issue but I was hoping that people here might be able to help. I've tried a couple versions of java, at first I was using 8 I believe because all of the install guides for forge were a bit older so they linked to the java website rather than oracle. I tried version 18 from the oracle site and received the same result from command prompt. It is also entirely possible that I am doing something else wrong that is blatantly obvious to everyone else.
    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.