• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Oh right, you already pointed it out. Toss everything and try McJty's tutorial
    • The same one listed above.
    • There is absolutely no reason for those setup() methods, what tutorial are you following?
    • Hey, I get this error when I run it now : [Server-Worker-7/WARN] [minecraft/ModelBakery]: Unable to load model: 'minecraft:first_mod#inventory' referenced from: minecraft:first_mod#inventory: java.io.FileNotFoundException: minecraft:models/item/first_mod.json . In my ModEventSubscriber class this is the code :  package com.gmail.yoshifan100000.first_mod; import net.minecraft.item.Item; import net.minecraft.util.ResourceLocation; import net.minecraftforge.event.RegistryEvent; import net.minecraftforge.eventbus.api.SubscribeEvent; import net.minecraftforge.fml.common.Mod.EventBusSubscriber; import net.minecraftforge.registries.IForgeRegistryEntry; @EventBusSubscriber(modid = Main.MODID, bus = EventBusSubscriber.Bus.MOD) public final class ModEventSubscriber { @SubscribeEvent public static void onRegisterItems(RegistryEvent.Register<Item> event) { event.getRegistry().registerAll( setup(new Item(new Item.Properties()), "example_ingot") ); } public static <T extends IForgeRegistryEntry<T>> Item setup(final Item item, final String string) { return setup(item, new ResourceLocation(Main.MODID)); } public static <T extends IForgeRegistryEntry<T>> T setup(final T entry, final ResourceLocation registryName) { entry.setRegistryName(registryName); return entry; } } And my main contains :  package com.gmail.yoshifan100000.first_mod; import net.minecraftforge.fml.common.Mod; import org.apache.logging.log4j.LogManager; import org.apache.logging.log4j.Logger; @Mod(Main.MODID) public final class Main { public static final String MODID = "first_mod"; private static final Logger LOGGER = LogManager.getLogger(); public void ExampleMod() { LOGGER.debug("Hello from Example Mod!"); } }  
    • Fixed it. I have no clue why this fixes it but I added  .func_235861_h_()   to my properties list like so:   public class MyBlock extends Block { public MyBlock() { super(Properties.create(Material.ROCK) .harvestTool(ToolType.PICKAXE) .harvestLevel(0) .hardnessAndResistance(1.5f, 6f) .sound(SoundType.STONE) .func_235861_h_() ); } }   And now everything functions like it's supposed to. This is 1.16.1 by the way. Sorry for the unsupported version but hey, there ya go for anyone that has having trouble in the beta version. 👍   Edit: Don't know why I didn't test this before posting, but it fixed the bare hand mining thing, but still can be harvested outside of a given harvest level (I put the method on a different block with a higher harvest level.) Still need help!
  • Topics

  • Who's Online (See full list)