Jump to content

Forge not working with Imac 10.6.8

Recommended Posts



I have encountered a problem where the Minecraft Forge Installer will not launch. When I try to open it, it goes through the animation for opening files but nothing happens. I have tried to find a solution by looking at other topics with the same problem but they never seem to end with a solution. Some websites say I need Java 7 to run Forge but other users appear to have fixed it but I could never replicate their success.


I am using a Imac with version 10.6.8 if that is of any use.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.