Jump to content

[1.8] atlas texture big mess


perromercenary00

Recommended Posts

 

this is the trouble

 

https://youtu.be/ycDa2JrMRj0

 

first everyting has become white or green expt for entities tile entities and the gui's

second i dont speak english to fluent so it makes harder to explain

 

soo i gona try explain miself

i been development a prety gun mod whith high res fireweapons  are like 14 weapons goin from bows and arrows to 9mm guns to  5.7*28mm guns to 5.56*45Nato guns and grenade launchers i like to sort them for the munition type

 

the trouble there is to many high res textures declared in the atlas  and this break it somehow

the last time i get stuck in green and white i wass using to many 512*512 textures, so i fix the mod downgrading the icons from 512 to 128*128 textures and any other less importan thing to 256*256

that allow to make room to add shotguns and rifles but now adding the grenade launcher hit the limit again, and dont wanna downgrade any else 

 

hypothesis one, i think i if i split the mod then i will have more space becoze there gona have two texture atlas an thaths the double of space

so i split the mod not in 2 but in 3 mods

 

the first

modmercenario-1.8_0010.jar

https://drive.google.com/file/d/0B8sU_NyZQBd7bUZvUVR3cEhJRzA/view?usp=sharing

just contens the basic tools pickaxes swords shovels all 64*64 textures

 

the second

armasmercenarias-1.8_0010.jar

https://drive.google.com/file/d/0B8sU_NyZQBd7bXQwSGxWeTlSekk/view?usp=sharing

has the guis the bows and arrows and the guns whith low caliber like 9mm m92 and 5.7*28mm p90 the colt and the shootguns  mix of textures in 128,  256 and 512

 

the third

armasmercenarias2-1.8_0010.jar

https://drive.google.com/file/d/0B8sU_NyZQBd7MmtQOHh3SUlza2c/view?usp=sharing

has the heavy weapons m4a1 bayonete ak200 and the grenade launcher

the grenade launcher 79M is the last weapon i been development and is the one that hit this theorical atlas limit so the code is not finish and has some purples blockes and shotguns sounds

 

hypothesis one fail and that let mi whith contradictory output

 

if i put only the first part modmercenario 18 0010  whith the second armasmercenarias  1.8 0010 then happen this

https://youtu.be/Q_wYchU-Ml8

everytingh works

 

if i put  the first part modmercenario 18 0010  whith the third part armas mercenarias2  1.8 0010 then happen this

https://youtu.be/_6QqFYbaG48

everytingh works

 

if the two parts separatly works the the code is fine and the textures two

 

if i put in the minecraft part two and three at same time  whithout the first, the first dont care

white and green like the first video

 

if i rejoint the thre mods parts in one, but i remove the extra textures from the grenade launcher then it works fine even whith heavy mods from others

like biomas o plenty and drzackmod creatures and the epicarno dimension at same time

 

this is the rejoined mod whithout grenade launcher textures, dont use along the other three 

modmercenario-1.8_0011.jar

https://drive.google.com/file/d/0B8sU_NyZQBd7V0ZhVTcwOEotNTA/view?usp=sharing

 

 

#####################################33

i think im the only one that has this kind of trouble

 

but what i see i dont understand this texture atlas to well and dont get if this is one for all or one for mod if the trouble is the bigger of the exture atlas for what other mods dont cause this to fail when run at the same time whith mi mod

 

some one has an idea of whath i can do to fix this

 

 

Link to comment
Share on other sites

Hi

 

I think your textures are probably just too large.  Minecraft puts all block and item textures into one texture sheet, which is a limited size.  Do you get any error messages in the console?

 

You could try putting a breakpoint into here

TextureMap::
    public void loadTextureAtlas(IResourceManager resourceManager)
    {
        int i = Minecraft.getGLMaximumTextureSize();
        Stitcher stitcher = new Stitcher(i, i, true, 0, this.mipmapLevels);
        this.mapUploadedSprites.clear();
        this.listAnimatedSprites.clear(); 
       {etc}

and seeing whether that's actually the problem.  If it is, I don't know how you can fix it.  In 1.7.10 with IItemRenderer, you could perhaps have bound to a different texture sheet that you created yourself, but that's not possible for item rendering now, unless you use ASM+Reflection to insert a method call at the appropriate location.

 

-TGG

 

 

 

Link to comment
Share on other sites

long time ago there wass errors for textures in non canonical sizes but thats not a trouble anymore there is no error in output exept for those

 

[06:19:15] [Client thread/ERROR] [FML]: Model definition for location modmercenario:culataHierro#inventory not found

[06:19:15] [Client thread/ERROR] [FML]: Model definition for location modmercenario:bala9mm_obsidiana#inventory not found

[06:19:15] [Client thread/ERROR] [FML]: Model definition for location modmercenario:culataMadera#inventory not found

[06:19:15] [Client thread/ERROR] [FML]: Model definition for location modmercenario:bala5728mm_redstone#inventory not found

[06:19:15] [Client thread/ERROR] [FML]: Model definition for location modmercenario:movingParts#inventory not found

[06:19:15] [Client thread/ERROR] [FML]: Model definition for location modmercenario:fusilFAMASG2b#inventory not found

[06:19:15] [Client thread/ERROR] [FML]: Model definition for location modmercenario:bala55645mm_Standar#inventory not found

 

a dont like to just trow al the json in the model/items folder  but have a folder arrangued for every tipe of item

 

 

update some test if i take the

 

this is the rejoined mod whithout grenade launcher textures, dont use along the other three

modmercenario-1.8_0011.jar

https://drive.google.com/file/d/0B8sU_NyZQBd7V0ZhVTcwOEotNTA/view?usp=sharing

 

and set a high res texture like

[1.7]_R3D.CRAFT_DR-64x_v0.1.5.rar

 

then it becomes green an white

Link to comment
Share on other sites

Seems to be an issue with your graphics card not being able to render huge texture sheets properly.

 

Anyways, can you give us the whole fml-client-latest.log inside the /logs/ folder? Use http://gist.github.com for that, please.

 

Also, could you try to disable the new loading screen inside the

config/splash.properties

file? I know it's a very big assumption, since it shouldn't affect anything at all, but it's worth a try...

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Minecraft opened, but when I went to create a new world I got another error. https://pastebin.com/mmdNztmW
    • java.lang.RuntimeException: Could not execute entrypoint stage 'main' due to errors, provided by 'terrablender'!     at net.fabricmc.loader.impl.FabricLoaderImpl.lambda$invokeEntrypoints$2(FabricLoaderImpl.java:388) ~[fabric-loader-0.15.11.jar:?]     at net.fabricmc.loader.impl.util.ExceptionUtil.gatherExceptions(ExceptionUtil.java:33) ~[fabric-loader-0.15.11.jar:?]     at net.fabricmc.loader.impl.FabricLoaderImpl.invokeEntrypoints(FabricLoaderImpl.java:386) ~[fabric-loader-0.15.11.jar:?]     at net.fabricmc.loader.impl.game.minecraft.Hooks.startServer(Hooks.java:63) ~[fabric-loader-0.15.11.jar:?]     at net.minecraft.server.Main.main(Main.java:112) ~[server-intermediary.jar:?]     at net.fabricmc.loader.impl.game.minecraft.MinecraftGameProvider.launch(MinecraftGameProvider.java:470) ~[fabric-loader-0.15.11.jar:?]     at net.fabricmc.loader.impl.launch.knot.Knot.launch(Knot.java:74) ~[fabric-loader-0.15.11.jar:?]     at net.fabricmc.loader.impl.launch.knot.KnotServer.main(KnotServer.java:23) ~[fabric-loader-0.15.11.jar:?]     at net.fabricmc.loader.impl.launch.server.FabricServerLauncher.main(FabricServerLauncher.java:69) ~[fabric-loader-0.15.11.jar:?] Caused by: java.lang.NoSuchFieldError: Class me.lortseam.completeconfig.data.BooleanEntry does not have member field 'boolean checkbox'     at me.lortseam.completeconfig.data.BooleanEntry.<init>(BooleanEntry.java:25) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at me.lortseam.completeconfig.data.Entry.create(Entry.java:42) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at me.lortseam.completeconfig.data.EntrySet.lambda$resolve$1(EntrySet.java:31) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:212) ~[?:?]     at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:194) ~[?:?]     at java.util.Spliterators$ArraySpliterator.forEachRemaining(Spliterators.java:1024) ~[?:?]     at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:556) ~[?:?]     at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:546) ~[?:?]     at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151) ~[?:?]     at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174) ~[?:?]     at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:265) ~[?:?]     at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:611) ~[?:?]     at me.lortseam.completeconfig.data.EntrySet.resolve(EntrySet.java:32) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at me.lortseam.completeconfig.data.Parent.resolveContainer(Parent.java:58) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at me.lortseam.completeconfig.data.Parent.resolve(Parent.java:110) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at me.lortseam.completeconfig.data.Config.lambda$new$0(Config.java:51) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at me.lortseam.completeconfig.data.Config.deserialize(Config.java:94) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at me.lortseam.completeconfig.data.Config.load(Config.java:121) ~[completeconfig-base-2.5.0-cd5950f26b406f27.jar:?]     at io.github.uhq_games.regions_unexplored.RegionsUnexplored.onTerraBlenderInitialized(RegionsUnexplored.java:70) ~[RegionsUnexploredFabric-0.5.31.20.1.jar:?]     at terrablender.core.TerraBlenderFabric.lambda$onInitialize$0(TerraBlenderFabric.java:40) ~[TerraBlender-fabric-1.20.1-3.0.1.7.jar:?]     at java.util.ArrayList.forEach(ArrayList.java:1597) ~[?:?]     at terrablender.core.TerraBlenderFabric.onInitialize(TerraBlenderFabric.java:38) ~[TerraBlender-fabric-1.20.1-3.0.1.7.jar:?]     at net.fabricmc.loader.impl.FabricLoaderImpl.invokeEntrypoints(FabricLoaderImpl.java:384) ~[fabric-loader-0.15.11.jar:?]  
    • Hi, I have the oficial launcher using the version 1.21, and forge 51.0.13, as soon as I start the installation the games crashes and gives me "exit code: 1", I haven't put any mods yet in the folder. Its the second time that uninstall and install everything and nothing works, checket my graphics and they are updated. https://pastebin.com/STPgEiVs   thanks!
    • Ty very much it worked
    • no clue what is going on, you guys seem more knowledgeable than I am. So here's my log as well as my mod list. Error Folder On Google Drive  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.