Jump to content

GameRegistry.registerBlock generates error due to 'atr' argument


サムエル

Recommended Posts

I'm trying to make a simple block mod and I can't use the GameRegistry.registerBlock method without getting an error because the first argument needs to be an 'atr' type and it's apparent that this class doesn't exist. The same thing goes for GameRegistry.registerItem with the 'alq' type. What's strange is that I can't find even one instance of anyone else having this problem anywhere online. I am using NetBeans but I have also tried Eclipse and got the equivalent error. Does anyone know how I can fix this error and still have my mod work on version 1.8?

Link to comment
Share on other sites

I tried to run the first line of code "gradlew.bat setupDecompWorkspace" and I get the following error 3 minutes in:

 

 

Failure: Build failed with an exception.

 

* What went wrong:

Execution failed for task ':MakeStart'.

> Unable to find a javac compiler;

com.sun.tools.javac.Main is not in the classpath.

Perhaps JAVA_HOME does not point to the JDK.

It is currently set to "C:\Program Files\Java\jre1.8.0_45"

 

 

I see what's wrong here but I don't know how to fix it.

Link to comment
Share on other sites

I re-ran it and encountered yet another error and since my system language isn't English I will have to translate the error.

 

 

[ant: javac] Warning: [options] Bootstrap classpath can't be set with -source 1.6

 

 

This one didn't force the program to end but it caused it to get stuck at "Building 65% > :decompile".

 

Edit: Nevermind, it finished... I just wasn't expecting it to get stuck there for like 10 minutes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.