Jump to content

Cauldron - Attack of the BTeam


jCompton

Recommended Posts

Hello, I'm trying to set up Cauldron for an 'Attack of the BTeam' server on the Technic Launcher, but I'm having difficulty. I believe I've set it up right, but I can't be 100% sure. I've never done this before so I'm new to it, only ever had MC servers or Tekkit Classic.

 

Anyway, here is what the console says when I try starting the servers '14.07 12:43:27 [Multicraft] Server stopped

14.07 12:43:27 [Multicraft] Looks like a crash, check the server console. Return value: 255

14.07 12:43:27 [Multicraft] Server shut down

14.07 12:43:27 [server] INFO Jul 14, 2015 12:43:27 PM net.minecraft.launchwrapper.LogWrapper log

14.07 12:43:27 [server] INFO Considering library net.java.jinput:jinput-platform:2.0.5

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl-platform:2.9.1-nightly-20130708-debug3

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl_util:2.9.1-nightly-20130708-debug3

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl:2.9.1-nightly-20130708-debug3

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl-platform:2.9.0

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl_util:2.9.0

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl:2.9.0

14.07 12:43:27 [server] INFO Considering library com.google.code.gson:gson:2.2.2

14.07 12:43:27 [server] INFO Considering library net.java.jutils:jutils:1.0.0

14.07 12:43:27 [server] INFO Considering library net.java.jinput:jinput:2.0.5

14.07 12:43:27 [server] INFO Considering library commons-io:commons-io:2.4

14.07 12:43:27 [server] INFO Considering library org.apache.commons:commons-lang3:3.1

14.07 12:43:27 [server] INFO Considering library com.google.guava:guava:14.0

14.07 12:43:27 [server] INFO Considering library org.bouncycastle:bcprov-jdk15on:1.47

14.07 12:43:27 [server] INFO Considering library argo:argo:2.25_fixed

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl_util:2.9.0

14.07 12:43:27 [server] INFO Considering library org.lwjgl.lwjgl:lwjgl:2.9.0

14.07 12:43:27 [server] INFO Considering library com.paulscode:soundsystem:20120107

14.07 12:43:27 [server] INFO Considering library com.paulscode:librarylwjglopenal:20100824

14.07 12:43:27 [server] INFO Considering library com.paulscode:libraryjavasound:20101123

14.07 12:43:27 [server] INFO Considering library com.paulscode:codecwav:20101023

14.07 12:43:27 [server] INFO Considering library com.paulscode:codecjorbis:20101023

14.07 12:43:27 [server] INFO Considering library net.sf.jopt-simple:jopt-simple:4.5

14.07 12:43:27 [server] INFO Considering library lzma:lzma:0.0.1

14.07 12:43:27 [server] INFO Considering library org.scala-lang:scala-compiler:2.10.2

14.07 12:43:27 [server] INFO Considering library org.scala-lang:scala-library:2.10.2

14.07 12:43:27 [server] INFO Considering library org.ow2.asm:asm-all:4.1

14.07 12:43:27 [server] INFO Considering library net.minecraft:launchwrapper:1.8

14.07 12:43:27 [server] INFO Considering library net.minecraftforge:minecraftforge:9.11.1.965

14.07 12:43:26 [Multicraft] Loaded config for "Default"

14.07 12:43:26 [Multicraft] Starting server!

14.07 12:43:26 [Multicraft] Loading server properties'

 

 

Link to comment
Share on other sites

I've decided to switch over to 1.7.10 (Direwolf 20) and use Cauldron, I'm getting this: http://pastebin.com/wMJr4wCK

 

What's the issue?

 

Seems like fastcraft is causing the error... I also see the cauldron server uses a quite outdated Forge version... Isn't there any updated version of the cauldron server you use?

So either update your cauldron server (if possible) or remove fastcraft.

 

PS: I used kcauldron to test my coremod with. Their version has somewhat updated Forge versions IIRC...

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Show your eula.txt. Is it next to the jar file?

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Add crash-reports with sites like https://paste.ee/ Maybe an issue with blur, essentials or cumulus_menus
    • Add the crash-report or latest.log (logs-folder) with sites like https://paste.ee/ and paste the link to it here  
    • I have a problem, I am trying to put two different effects to two different armors but when I run it only the emerald armor effect works. This is the code public class ModArmorItem extends ArmorItem{ private static final Map<ArmorMaterial, MobEffectInstance> MATERIAL_TO_EFFECT_MAP = (new ImmutableMap.Builder<ArmorMaterial, MobEffectInstance>()) .put(ModArmorMaterials.EMERALD, new MobEffectInstance(MobEffects.HERO_OF_THE_VILLAGE,200, 1,false,false, true)) .put(ModArmorMaterials.OBSIDIAN, new MobEffectInstance(MobEffects.FIRE_RESISTANCE,200, 1,false,false, true)).build(); public ModArmorItem(ArmorMaterial pMaterial, Type pType, Properties pProperties) { super(pMaterial, pType, pProperties); } @Override public void onArmorTick(ItemStack stack, Level world, Player player){ if (!world.isClientSide()) { if (hasFullSuitOfArmorOn(player)) { evaluateArmorEffects(player); } } } private void evaluateArmorEffects(Player player) { for (Map.Entry<ArmorMaterial,MobEffectInstance> entry : MATERIAL_TO_EFFECT_MAP.entrySet()){ ArmorMaterial mapArmorMaterial = entry.getKey(); MobEffectInstance mapStatusEffect = entry.getValue(); if (hasCorrectArmorOn(mapArmorMaterial, player)) { addStatusEffectForMaterial(player, mapArmorMaterial, mapStatusEffect); } } } private void addStatusEffectForMaterial(Player player, ArmorMaterial mapArmorMaterial, MobEffectInstance mapStatusEffect) { boolean hasPlayerEffect = player.hasEffect(mapStatusEffect.getEffect()); if (hasCorrectArmorOn(mapArmorMaterial, player) && !hasPlayerEffect) { player.addEffect(new MobEffectInstance(mapStatusEffect)); } } private boolean hasCorrectArmorOn(ArmorMaterial material, Player player) { for (ItemStack armorStack : player.getInventory().armor){ if (!(armorStack.getItem() instanceof ArmorItem)) { return false; } } ArmorItem helmet = ((ArmorItem)player.getInventory().getArmor(3).getItem()); ArmorItem breastplace = ((ArmorItem)player.getInventory().getArmor(2).getItem()); ArmorItem leggins = ((ArmorItem)player.getInventory().getArmor(1).getItem()); ArmorItem boots = ((ArmorItem)player.getInventory().getArmor(0).getItem()); return helmet.getMaterial() == material && breastplace.getMaterial() == material && leggins.getMaterial() == material && boots.getMaterial() == material; } private boolean hasFullSuitOfArmorOn(Player player){ ItemStack helmet = player.getInventory().getArmor(3); ItemStack breastplace = player.getInventory().getArmor(2); ItemStack leggins = player.getInventory().getArmor(1); ItemStack boots = player.getInventory().getArmor(0); return !helmet.isEmpty() && !breastplace.isEmpty() && !leggins.isEmpty() && !boots.isEmpty(); } } Also when I place two effects on the same armor, the game crashes. Here is the crash file. The code is the same, only this part is different   private static final Map<ArmorMaterial, MobEffectInstance> MATERIAL_TO_EFFECT_MAP = (new ImmutableMap.Builder<ArmorMaterial, MobEffectInstance>()) .put(ModArmorMaterials.EMERALD, new MobEffectInstance(MobEffects.HERO_OF_THE_VILLAGE,200, 1,false,false, true)) .put(ModArmorMaterials.EMERALD, new MobEffectInstance(MobEffects.FIRE_RESISTANCE,200, 1,false,false, true)).build(); I hope you guys can help me. Thanks.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.