Jump to content

Java SE Runtime Has Stopped Working - BEX64 Error


Recommended Posts

I posted it on MC Forums, but the ppl on the normal forums look to just know how to solve simple errors  ??? (unfortunately mine isn't the case). Here's the deal (with few edits):



First of First, I use updated (mostly recommended, but used latest for testing) versions of Forge (, 1490, 1492) for 1.7.10 (not latest MC, but forge versions are still being baked for it, so please don't get mad)


You gonna hear me talk about this a lot in the post, so here's the devious error (the description of items is on portuguese, but the information is the same):




Nome do Evento de Problema: BEX64

Nome do Aplicativo: javaw.exe

Versão do Aplicativo:

Carimbo de Data/Hora do Aplicativo: 55763d32

Nome do Módulo de Falhas: explorerEx64.dll

Versão do Módulo de Falhas:

Carimbo de Data/Hora do Módulo de Falhas: 54c0d01f

Deslocamento de Exceção: 000000000001dca1

Código de Exceção: c0000417

Dados de Exceção: 0000000000000000

Versão do sistema operacional: 6.1.7601.

Identificação da Localidade: 1046

Informações Adicionais 1: 550a

Informações Adicionais 2: 550a4c33a2a602b37b0ff5a3114de48e

Informações Adicionais 3: 1b6c

Informações Adicionais 4: 1b6c946786d6975c4ee3f8d14e261213

Leia nossa declaração de privacidade online:


Se a declaração de privacidade online não estiver disponível, leia nossa declaração de privacidade offline:





I think this problem is related to a interaction between Forge and Java Configurations. Why not java itself? Well, I sure have reasons to think this isn't the case, so let me tell my history:


Yesterday, I decided to update to Java 8 U51, and as I know about it's problems, I looked after forge 1.6+ problems but they always says this a thing fixed on previous versions, so I tried it anyways. I was greet with the classy error of java stopped working, right before the launcher log tries to switch to the game output (yes, I love logs) OR when it closes. Then I tried with 1492 and same thing. I tried to go back to Java 8 U11, but same thing again.


I remembered the time when I had problems with minecraft crashing mid-game because of old versions of LWJGL, and as it only stops working (with stop I mean it won't start at all) with forge, I deleted the library folder, and just in case, moved everything important (I mean mods, saves, resource packs and the config folder) to another folder and cleaned .minecraft. After I reinstalled forge, I discovered that everything was futile. Same error, same details.


Finally, even if I did not understand why the problem was happening (remember I use a updated version of forge), I gave up on Forge 8. This is where things get odd. I mean, really odd.


I went on Oracle to download Java 7 U80. Yes, it is still here, but in archives only now, meaning you can't get it the same way as before, but you can get it after all. When I launched the game again, guess what... The same error, but with a different java version in the log. Well, well, where it different and I'd not be so frustrated...


Everytime somebody gets a error with BEX64, they either solve it using methods which won't solve mine, change forge versions because they where using really old ones, or don't get any proper answer in the problem. So this is the only chance of solving the problem I have so far.


I uninstalled every version of java before every try, tried both JRE and JDK (actually I can't use this one in the launcher, but only in the game itself), tried to use the executable launcher and some "alternative" launchers and used JavaRa, No solution and no change in the error. Thus I think it has nothing to do with the java version, but the fact that they changed something in the default configurations between versions.


No clue what, however.


Could you guys help me?


As a side note, I add what I said in the comments of my own post: I'd add logs if i could get any  :(


That said, if anyone knows a way to generate logs of the actual launcher, I will try it gladly.

Link to comment
Share on other sites

If anyone is in doubt if should or not help me because I have no logs, please remember that I can try anything to gather information, it's just that the game does not even launch, so no logs are generated in either the .minecraft nor logs folder.


I may be being a little paranoic about the matter, but I never had to handle with direct java-forge related problems without finding the answer quick (because such errors are normally general), so the absence of logs makes me fell powerless.

Link to comment
Share on other sites

This one is new, but everything google tells me is that is a video driver/card issue. There isn't much I can say about it beyond that.

Vanilla works?

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Sure, vanilla works.


I had one Gradle setup before, so I can tell you my environment variables are gone after updating java.


As I have been playing with them for long, I could not tell if they would become needed. Thing is I don't remember every one I had. So I'm trying to figure if the launcher could rely on one of them when with Forge or Liteloader (any modded profile produces the error). Changing the launcher makes no difference.


I really believe this isn't from graphic card drivers in my case, but I updated the drivers yesterday anyways, and nothing changed.

Link to comment
Share on other sites

As a note:  Liteloader also won't work, so I wonder if my java is refusing to launch modded enviroment at all


Tried changing few things here and there in the variables and nothing... Do you have a debbug program or something similar, because I can't give more information by myself...


Please help me discover what could have change when I updated from J7 U71 to J8 U51and was not reversible via downgrade, I have no chance to find it alone.


Edit: Bex64 means either DEP or Buffer Overflow. I use DEP on the option with only system tasks.


So we have Buffer Overflow left...


Minecraft by itself won't generate logs, right? So I wonder if forge and liteloader are trying to store temporary information but found no space or java did not allowed they to do so.


Is there any java configuration to prevent buffer overflows?



Another edit: Yep, definitely buffer overflow. Deactivated the DEP via


bcdedit.exe /set {current} nx AlwaysOff


and no changes so far.






Still, even if I know what the problem is, I have no solutions so far.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.